Bug 170483 - [patch] Correct multimedia/gstreamer Dependency Declaration
Summary: [patch] Correct multimedia/gstreamer Dependency Declaration
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-multimedia (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-08-08 17:50 UTC by A.J. Kehoe IV
Modified: 2012-09-20 11:20 UTC (History)
0 users

See Also:


Attachments
file.diff (546 bytes, patch)
2012-08-08 17:50 UTC, A.J. Kehoe IV
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description A.J. Kehoe IV 2012-08-08 17:50:01 UTC
The FreeBSD port multimedia/gstreamer uses automatic detection to declare an optional dependency.  This causes problems for port and package management.

Fix: I've attached a patch that corrects this by using the method suggested in the FreeBSD Porter's Handbook on the "Dependencies" page under "Problems Caused by Automatic Dependencies":

http://www.freebsd.org/doc/en_US.ISO8859-1/books/porters-handbook/makefile-depend.html

Patch attached with submission follows:
Comment 1 Edwin Groothuis freebsd_committer freebsd_triage 2012-08-08 17:50:13 UTC
Responsible Changed
From-To: freebsd-ports-bugs->freebsd-multimedia

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 2 Koop Mast freebsd_committer freebsd_triage 2012-09-08 11:16:46 UTC
State Changed
From-To: open->closed

Committed thanks! I just tweaked the desc a bit.
Comment 3 dfilter service freebsd_committer freebsd_triage 2012-09-08 11:17:06 UTC
Author: kwm
Date: Sat Sep  8 10:16:52 2012
New Revision: 303888
URL: http://svn.freebsd.org/changeset/ports/303888

Log:
  Convert automatic dependancy to OPTION
  
  PR:		ports/170483
  Submitted by:	"A.J. Kehoe IV (Nanoman)" <9ya139x4@nanoman.ca>

Modified:
  head/multimedia/gstreamer/Makefile

Modified: head/multimedia/gstreamer/Makefile
==============================================================================
--- head/multimedia/gstreamer/Makefile	Sat Sep  8 10:10:19 2012	(r303887)
+++ head/multimedia/gstreamer/Makefile	Sat Sep  8 10:16:52 2012	(r303888)
@@ -45,10 +45,13 @@ MAN1=	gst-feedback-${GST_VERSION}.1 gst-
 	gst-typefind-${GST_VERSION}.1 gst-xmlinspect-${GST_VERSION}.1 \
 	gst-xmllaunch-${GST_VERSION}.1
 
+OPTIONS_DEFINE=	LIBCHECK
+LIBCHECK_DESC=	Unit tests support
+
 .include <bsd.port.pre.mk>
 
-.if (exists(${LOCALBASE}/lib/libcheck.a) || defined(WITH_CHECK))
-LIB_DEPENDS+=	check.0:${PORTSDIR}/devel/libcheck
+.if ${PORT_OPTIONS:MCHECK}
+LIB_DEPENDS+=	check:${PORTSDIR}/devel/libcheck
 PLIST_SUB+=	CHECK=""
 .else
 CONFIGURE_ARGS+=--disable-check
_______________________________________________
svn-ports-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/svn-ports-all
To unsubscribe, send any mail to "svn-ports-all-unsubscribe@freebsd.org"
Comment 4 A.J. Kehoe IV 2012-09-17 18:09:29 UTC
kwm@FreeBSD.org wrote:
> Synopsis: [patch] Correct multimedia/gstreamer Dependency Declaration
>
> State-Changed-From-To: open->closed
> State-Changed-By: kwm
> State-Changed-When: Sat Sep 8 10:16:46 UTC 2012
> State-Changed-Why:
> Committed thanks! I just tweaked the desc a bit.
>
> http://www.freebsd.org/cgi/query-pr.cgi?pr=170483

Thanks, kwm!  "${PORT_OPTIONS:MCHECK}" should actually be
"${PORT_OPTIONS:MLIBCHECK}", though.  Either that, or change the name of
the Check option from "LIBCHECK" to "CHECK".
Comment 5 Koop Mast 2012-09-20 11:16:06 UTC
On 17-9-2012 19:09, A.J. Kehoe IV (Nanoman) wrote:
> kwm@FreeBSD.org wrote:
>> Synopsis: [patch] Correct multimedia/gstreamer Dependency Declaration
>>
>> State-Changed-From-To: open->closed
>> State-Changed-By: kwm
>> State-Changed-When: Sat Sep 8 10:16:46 UTC 2012
>> State-Changed-Why:
>> Committed thanks! I just tweaked the desc a bit.
>>
>> http://www.freebsd.org/cgi/query-pr.cgi?pr=170483
> Thanks, kwm!  "${PORT_OPTIONS:MCHECK}" should actually be
> "${PORT_OPTIONS:MLIBCHECK}", though.  Either that, or change the name of
> the Check option from "LIBCHECK" to "CHECK".
>

Woops, fixed thanks!