View | Details | Raw Unified | Return to bug 210666 | Differences between
and this patch

Collapse All | Expand All

(-)b/Mk/Uses/bdb.mk (-2 lines)
Lines 65-72 WARNING+= "WITH_BDB_VER is deprecated and will be removed on 2016-08-01. Use DEF Link Here
65
BDB_DEFAULT:=${WITH_BDB_VER}
65
BDB_DEFAULT:=${WITH_BDB_VER}
66
.endif
66
.endif
67
67
68
.include "${PORTSDIR}/Mk/bsd.default-versions.mk"
69
70
_BDB_DEFAULT_save:=${BDB_DEFAULT}
68
_BDB_DEFAULT_save:=${BDB_DEFAULT}
71
69
72
_DB_PORTS=		48 5 6
70
_DB_PORTS=		48 5 6
(-)b/Mk/Uses/firebird.mk (-1 lines)
Lines 7-13 Link Here
7
7
8
.if !defined(_INCLUDE_USES_FIREBIRD_MK)
8
.if !defined(_INCLUDE_USES_FIREBIRD_MK)
9
_INCLUDE_USES_FIREBIRD_MK=	yes
9
_INCLUDE_USES_FIREBIRD_MK=	yes
10
.include "${PORTSDIR}/Mk/bsd.default-versions.mk"
11
10
12
.if !empty(firebird_ARGS)
11
.if !empty(firebird_ARGS)
13
FIREBIRD_VER=	${firebird_ARGS}
12
FIREBIRD_VER=	${firebird_ARGS}
(-)b/Mk/Uses/fortran.mk (-1 lines)
Lines 16-22 fortran_ARGS= gcc Link Here
16
.endif
16
.endif
17
17
18
.if ${fortran_ARGS} == gcc
18
.if ${fortran_ARGS} == gcc
19
.include "${PORTSDIR}/Mk/bsd.default-versions.mk"
20
_GCC_VER=	${GCC_DEFAULT:S/.//}
19
_GCC_VER=	${GCC_DEFAULT:S/.//}
21
.if ${GCC_DEFAULT} == ${LANG_GCC_IS}
20
.if ${GCC_DEFAULT} == ${LANG_GCC_IS}
22
BUILD_DEPENDS+=	gfortran${_GCC_VER}:lang/gcc
21
BUILD_DEPENDS+=	gfortran${_GCC_VER}:lang/gcc
(-)b/Mk/Uses/ghostscript.mk (-3 lines)
Lines 38-46 _GS_ARGS= ${ghostscript_ARGS} Link Here
38
IGNORE?=	Unknown ghostscript argument ${_GS_ARGS}
38
IGNORE?=	Unknown ghostscript argument ${_GS_ARGS}
39
.endif
39
.endif
40
40
41
# Determine version number of Ghostscript to use
42
.include "${PORTSDIR}/Mk/bsd.default-versions.mk"
43
44
.if ${GHOSTSCRIPT_DEFAULT:N[789]:Nagpl}
41
.if ${GHOSTSCRIPT_DEFAULT:N[789]:Nagpl}
45
IGNORE?=	Invalid GHOSTSCRIPT_DEFAULT value: ${GHOSTSCRIPT_DEFAULT}, please select one of ${_GS_VERSION}
42
IGNORE?=	Invalid GHOSTSCRIPT_DEFAULT value: ${GHOSTSCRIPT_DEFAULT}, please select one of ${_GS_VERSION}
46
.endif
43
.endif
(-)b/Mk/Uses/lua.mk (-1 lines)
Lines 14-20 _INCLUDE_USES_LUA_MK= yes Link Here
14
# Mk/bsd.default-versions.mk in sync.
14
# Mk/bsd.default-versions.mk in sync.
15
_LUA_VALID_VERSIONS=	53 52 51
15
_LUA_VALID_VERSIONS=	53 52 51
16
16
17
.include "${PORTSDIR}/Mk/bsd.default-versions.mk"
18
_LUA_DEFAULT_VERSION=	${LUA_DEFAULT:S/.//}
17
_LUA_DEFAULT_VERSION=	${LUA_DEFAULT:S/.//}
19
.if ! ${_LUA_VALID_VERSIONS:M${_LUA_DEFAULT_VERSION}}
18
.if ! ${_LUA_VALID_VERSIONS:M${_LUA_DEFAULT_VERSION}}
20
IGNORE=	Invalid lua version ${LUA_DEFAULT}
19
IGNORE=	Invalid lua version ${LUA_DEFAULT}
(-)b/Mk/Uses/mysql.mk (-2 lines)
Lines 26-33 Link Here
26
.if !defined(_INCLUDE_USES_MYSQL_MK)
26
.if !defined(_INCLUDE_USES_MYSQL_MK)
27
_INCLUDE_USES_MYSQL_MK=	yes
27
_INCLUDE_USES_MYSQL_MK=	yes
28
28
29
.include "${PORTSDIR}/Mk/bsd.default-versions.mk"
30
31
.if !empty(mysql_ARGS)
29
.if !empty(mysql_ARGS)
32
.undef _WANT_MYSQL_VER
30
.undef _WANT_MYSQL_VER
33
.undef _WANT_MYSQL_SERVER
31
.undef _WANT_MYSQL_SERVER
(-)b/Mk/Uses/perl5.mk (-1 lines)
Lines 51-57 THIS_IS_OLD_PERL= yes Link Here
51
# end of remove
51
# end of remove
52
# When adding a version, please keep the comment in
52
# When adding a version, please keep the comment in
53
# Mk/bsd.default-versions.mk in sync.
53
# Mk/bsd.default-versions.mk in sync.
54
.include "${PORTSDIR}/Mk/bsd.default-versions.mk"
55
.if ${PERL5_DEFAULT} == 5.18
54
.if ${PERL5_DEFAULT} == 5.18
56
.include "${PORTSDIR}/lang/perl5.18/version.mk"
55
.include "${PORTSDIR}/lang/perl5.18/version.mk"
57
.elif ${PERL5_DEFAULT} == 5.20
56
.elif ${PERL5_DEFAULT} == 5.20
(-)b/Mk/Uses/pgsql.mk (-2 lines)
Lines 43-50 PGSQL_LIBVER= 5 Link Here
43
PGSQL$v_LIBVER?=	${PGSQL_LIBVER}
43
PGSQL$v_LIBVER?=	${PGSQL_LIBVER}
44
.endfor
44
.endfor
45
45
46
.include "${PORTSDIR}/Mk/bsd.default-versions.mk"
47
48
.for v in ${PGSQL_DEFAULT}
46
.for v in ${PGSQL_DEFAULT}
49
.  if ! ${VALID_PGSQL_VER:M$v}
47
.  if ! ${VALID_PGSQL_VER:M$v}
50
IGNORE=		Invalid PGSQL default version ${PGSQL_DEFAULT}; valid versions are ${VALID_PGSQL_VER}
48
IGNORE=		Invalid PGSQL default version ${PGSQL_DEFAULT}; valid versions are ${VALID_PGSQL_VER}
(-)b/Mk/Uses/php.mk (-2 lines)
Lines 38-45 PHP_Include_MAINTAINER= ale@FreeBSD.org Link Here
38
38
39
_INCLUDE_USES_PHP_MK=	yes
39
_INCLUDE_USES_PHP_MK=	yes
40
40
41
.include "${PORTSDIR}/Mk/bsd.default-versions.mk"
42
43
.  if defined(DEFAULT_PHP_VER)
41
.  if defined(DEFAULT_PHP_VER)
44
WARNING+=	"DEFAULT_PHP_VER is defined, consider using DEFAULT_VERSIONS=php=${DEFAULT_PHP_VER} instead"
42
WARNING+=	"DEFAULT_PHP_VER is defined, consider using DEFAULT_VERSIONS=php=${DEFAULT_PHP_VER} instead"
45
.  endif
43
.  endif
(-)b/Mk/Uses/python.mk (-3 lines)
Lines 260-268 _PYTHON_RUN_DEP= yes Link Here
260
_PYTHON_TEST_DEP=	yes
260
_PYTHON_TEST_DEP=	yes
261
.endif
261
.endif
262
262
263
# Determine version number of Python to use
264
.include "${PORTSDIR}/Mk/bsd.default-versions.mk"
265
266
.if defined(PYTHON_DEFAULT_VERSION)
263
.if defined(PYTHON_DEFAULT_VERSION)
267
WARNING+=	"PYTHON_DEFAULT_VERSION is defined, consider using DEFAULT_VERSIONS=python=${PYTHON_DEFAULT_VERSION:S/^python//} instead"
264
WARNING+=	"PYTHON_DEFAULT_VERSION is defined, consider using DEFAULT_VERSIONS=python=${PYTHON_DEFAULT_VERSION:S/^python//} instead"
268
.endif
265
.endif
(-)b/Mk/Uses/ssl.mk (-2 lines)
Lines 28-35 Link Here
28
.if !defined(_INCLUDE_USES_SSL_MK)
28
.if !defined(_INCLUDE_USES_SSL_MK)
29
_INCLUDE_USES_SSL_MK=	yes
29
_INCLUDE_USES_SSL_MK=	yes
30
30
31
.include "${PORTSDIR}/Mk/bsd.default-versions.mk"
32
33
.if ${SSL_DEFAULT} == base
31
.if ${SSL_DEFAULT} == base
34
OPENSSLBASE=		/usr
32
OPENSSLBASE=		/usr
35
OPENSSLDIR?=		/etc/ssl
33
OPENSSLDIR?=		/etc/ssl
(-)b/Mk/Uses/tcl.mk (-1 lines)
Lines 78-84 _TCLTK_VALID_VERSIONS= 84 85 86 Link Here
78
# Bring in the default and check that the specified version is in the list of
78
# Bring in the default and check that the specified version is in the list of
79
# valid versions.
79
# valid versions.
80
#
80
#
81
.include "${PORTSDIR}/Mk/bsd.default-versions.mk"
82
_TCLTK_DEFAULT_VERSION=	${TCLTK_DEFAULT:S/.//}
81
_TCLTK_DEFAULT_VERSION=	${TCLTK_DEFAULT:S/.//}
83
.if ! ${_TCLTK_VALID_VERSIONS:M${_TCLTK_DEFAULT_VERSION}}
82
.if ! ${_TCLTK_VALID_VERSIONS:M${_TCLTK_DEFAULT_VERSION}}
84
IGNORE=	Invalid tcltk version ${TCLTK_DEFAULT}
83
IGNORE=	Invalid tcltk version ${TCLTK_DEFAULT}
(-)b/Mk/bsd.apache.mk (-2 lines)
Lines 85-92 Link Here
85
85
86
Apache_Pre_Include=		bsd.apache.mk
86
Apache_Pre_Include=		bsd.apache.mk
87
87
88
.include "${PORTSDIR}/Mk/bsd.default-versions.mk"
89
90
.if defined(DEFAULT_APACHE_VER)
88
.if defined(DEFAULT_APACHE_VER)
91
WARNING+=	"DEFAULT_APACHE_VER is defined, consider using DEFAULT_VERSIONS+=apache=${DEFAULT_APACHE_VER} instead"
89
WARNING+=	"DEFAULT_APACHE_VER is defined, consider using DEFAULT_VERSIONS+=apache=${DEFAULT_APACHE_VER} instead"
92
.endif
90
.endif
(-)b/Mk/bsd.fpc.mk (-2 lines)
Lines 30-37 Link Here
30
30
31
_FPCMKINCLUDED=	yes
31
_FPCMKINCLUDED=	yes
32
32
33
.include "${PORTSDIR}/Mk/bsd.default-versions.mk"
34
35
.if defined(DEFAULT_FPC_VER)
33
.if defined(DEFAULT_FPC_VER)
36
WARNING+=	"DEFAULT_FPC_VER is defined, consider using DEFAULT_VERSIONS=fpc=${DEFAULT_FPC_VER} instead"
34
WARNING+=	"DEFAULT_FPC_VER is defined, consider using DEFAULT_VERSIONS=fpc=${DEFAULT_FPC_VER} instead"
37
.endif
35
.endif
(-)b/Mk/bsd.gcc.mk (-2 lines)
Lines 31-38 Link Here
31
31
32
GCC_Include_MAINTAINER=		gerald@FreeBSD.org
32
GCC_Include_MAINTAINER=		gerald@FreeBSD.org
33
33
34
.include "${PORTSDIR}/Mk/bsd.default-versions.mk"
35
36
# All GCC versions supported by the ports framework.  Keep them in
34
# All GCC versions supported by the ports framework.  Keep them in
37
# ascending order and in sync with the table below. 
35
# ascending order and in sync with the table below. 
38
# When adding a version, please keep the comment in
36
# When adding a version, please keep the comment in
(-)b/Mk/bsd.port.mk (+2 lines)
Lines 1266-1271 WITH_DEBUG= yes Link Here
1266
1266
1267
.include "${PORTSDIR}/Mk/bsd.options.mk"
1267
.include "${PORTSDIR}/Mk/bsd.options.mk"
1268
1268
1269
.include "${PORTSDIR}/Mk/bsd.default-versions.mk"
1270
1269
# Start of pre-makefile section.
1271
# Start of pre-makefile section.
1270
.if !defined(AFTERPORTMK) && !defined(INOPTIONSMK)
1272
.if !defined(AFTERPORTMK) && !defined(INOPTIONSMK)
1271
1273
(-)b/Mk/bsd.ruby.mk (-2 lines)
Lines 128-135 Ruby_Include_MAINTAINER= ruby@FreeBSD.org Link Here
128
# RUBY_ELISPDIR		- Installation path for emacs lisp files.
128
# RUBY_ELISPDIR		- Installation path for emacs lisp files.
129
#
129
#
130
130
131
.include "${PORTSDIR}/Mk/bsd.default-versions.mk"
132
133
.if defined(RUBY_DEFAULT_VER)
131
.if defined(RUBY_DEFAULT_VER)
134
WARNING+=	"RUBY_DEFAULT_VER is defined, consider using DEFAULT_VERSIONS=ruby=${RUBY_DEFAULT_VER} instead"
132
WARNING+=	"RUBY_DEFAULT_VER is defined, consider using DEFAULT_VERSIONS=ruby=${RUBY_DEFAULT_VER} instead"
135
.endif
133
.endif
(-)b/devel/efl/Makefile (-1 / +2 lines)
Lines 94-99 OPENGL_USE= GL=gl Link Here
94
SDL_USE=			SDL=sdl2
94
SDL_USE=			SDL=sdl2
95
SDL_CONFIGURE_ENABLE=		sdl
95
SDL_CONFIGURE_ENABLE=		sdl
96
96
97
SSL_VARS=	WITH_OPENSSL_PORT=yes
98
97
.include <bsd.port.options.mk>
99
.include <bsd.port.options.mk>
98
100
99
.if ${PORT_OPTIONS:MNVIDIA}
101
.if ${PORT_OPTIONS:MNVIDIA}
Lines 109-115 PLIST_SUB+= AUDIO="@comment " Link Here
109
111
110
.if ${PORT_OPTIONS:MSSL}
112
.if ${PORT_OPTIONS:MSSL}
111
USE_OPENSSL=			yes
113
USE_OPENSSL=			yes
112
WITH_OPENSSL_PORT=		yes
113
.else
114
.else
114
CONFIGURE_ARGS+=		--with-crypto=none
115
CONFIGURE_ARGS+=		--with-crypto=none
115
.endif
116
.endif
(-)b/www/node/Makefile (-10 / +1 lines)
Lines 42-57 MAKE_ENV+= CC.host=${CC} CXX.host=${CXX} LINK.host=${CXX} LINK.target=${CXX} Link Here
42
LIB_DEPENDS+=	libcares.so:dns/c-ares\
42
LIB_DEPENDS+=	libcares.so:dns/c-ares\
43
		libuv.so:devel/libuv
43
		libuv.so:devel/libuv
44
44
45
.include <bsd.port.options.mk>
45
BUNDLED_SSL_VARS_OFF=	WITH_OPENSSL_PORT=yes
46
47
.if empty(PORT_OPTIONS:MBUNDLED_SSL)
48
49
.if ${OSVERSION} < 1100085
50
# node.js requires openssl 1.0.2, use the port since base isn't new enough
51
WITH_OPENSSL_PORT=	yes
52
.endif
53
54
.endif
55
46
56
.include <bsd.port.pre.mk>
47
.include <bsd.port.pre.mk>
57
48
(-)b/www/node4/Makefile (-10 / +1 lines)
Lines 42-57 MAKE_ENV+= CC.host=${CC} CXX.host=${CXX} LINK.host=${CXX} LINK.target=${CXX} Link Here
42
42
43
LIB_DEPENDS+=	libuv.so:devel/libuv
43
LIB_DEPENDS+=	libuv.so:devel/libuv
44
44
45
.include <bsd.port.options.mk>
45
BUNDLED_SSL_VARS_OFF=	WITH_OPENSSL_PORT=yes
46
47
.if empty(PORT_OPTIONS:MBUNDLED_SSL)
48
49
.if ${OSVERSION} < 1100085
50
# node.js requires openssl 1.0.2, use the port since base isn't new enough
51
WITH_OPENSSL_PORT=yes
52
.endif
53
54
.endif
55
46
56
.include <bsd.port.pre.mk>
47
.include <bsd.port.pre.mk>
57
48

Return to bug 210666