View | Details | Raw Unified | Return to bug 227187
Collapse All | Expand All

(-)devel/grpc/files/patch-src_core_lib_security_credentials_jwt_jwt__verifier.cc (-1 / +1 lines)
Lines 5-11 Link Here
5
 }
5
 }
6
 
6
 
7
-#if OPENSSL_VERSION_NUMBER < 0x10100000L
7
-#if OPENSSL_VERSION_NUMBER < 0x10100000L
8
+#if OPENSSL_VERSION_NUMBER < 0x10100000L || defined(LIBRESSL_VERSION_NUMBER)
8
+#if OPENSSL_VERSION_NUMBER < 0x10100000L || (defined(LIBRESSL_VERSION_NUMBER) && LIBRESSL_VERSION_NUMBER < 0x20700000L)
9
 
9
 
10
 // Provide compatibility across OpenSSL 1.02 and 1.1.
10
 // Provide compatibility across OpenSSL 1.02 and 1.1.
11
 static int RSA_set0_key(RSA* r, BIGNUM* n, BIGNUM* e, BIGNUM* d) {
11
 static int RSA_set0_key(RSA* r, BIGNUM* n, BIGNUM* e, BIGNUM* d) {

Return to bug 227187