View | Details | Raw Unified | Return to bug 235493
Collapse All | Expand All

(-)files/patch-scripts_genie.lua (+11 lines)
Line 0 Link Here
1
--- scripts/genie.lua.orig	2018-07-24 19:45:05 UTC
2
+++ scripts/genie.lua
3
@@ -996,7 +996,7 @@ end
4
 
5
 
6
 		local version = str_to_version(_OPTIONS["gcc_version"])
7
-		if string.find(_OPTIONS["gcc"], "clang") or string.find(_OPTIONS["gcc"], "pnacl") or string.find(_OPTIONS["gcc"], "asmjs") or string.find(_OPTIONS["gcc"], "android") then
8
+		if string.find(_OPTIONS["gcc"], "clang") or string.find(_OPTIONS["gcc"], "pnacl") or string.find(_OPTIONS["gcc"], "asmjs") or string.find(_OPTIONS["gcc"], "android") or string.find(_OPTIONS["gcc"], "freebsd") then
9
 			if (version < 30400) then
10
 				print("Clang version 3.4 or later needed")
11
 				os.exit(-1)

Return to bug 235493