View | Details | Raw Unified | Return to bug 237376 | Differences between
and this patch

Collapse All | Expand All

(-)emulators/pcem/Makefile (-2 / +8 lines)
Lines 16-32 Link Here
16
		libwx_gtk3u_core-3.0.so:x11-toolkits/wxgtk30 \
16
		libwx_gtk3u_core-3.0.so:x11-toolkits/wxgtk30 \
17
		libSDL2.so:devel/sdl20
17
		libSDL2.so:devel/sdl20
18
18
19
USES=		autoreconf compiler gmake openal:soft pkgconfig sdl zip
19
USES=		compiler gmake openal:soft pkgconfig sdl zip
20
USE_WX=		3.0
20
USE_WX=		3.0
21
USE_SDL=	sdl2
21
USE_SDL=	sdl2
22
22
23
WRKSRC=		${WRKDIR}/pcem_emulator-pcem-faf5d6423060/
23
WRKSRC=		${WRKDIR}/pcem_emulator-pcem-faf5d6423060/
24
PATCHDIR=files
25
PLIST_FILES=	bin/pcem
24
PLIST_FILES=	bin/pcem
26
CONFIGURE_ARGS=	--enable-release-build --with-wx-config=wxgtk3u-3.0-config
25
CONFIGURE_ARGS=	--enable-release-build --with-wx-config=wxgtk3u-3.0-config
27
GNU_CONFIGURE=	yes
26
GNU_CONFIGURE=	yes
28
ONLY_FOR_ARCHS=	amd64
27
ONLY_FOR_ARCHS=	amd64
29
28
29
CFLAGS+=	-I${LOCALBASE}/include
30
CXXFLAGS+=	-I${LOCALBASE}/include
31
LDFLAGS+=	-L${LOCALBASE}/lib
32
33
post-patch:
34
	@${REINPLACE_CMD} -e 's,  x86_64),  x86_64|amd64),' ${WRKSRC}/configure
35
30
.include <bsd.port.options.mk>
36
.include <bsd.port.options.mk>
31
37
32
.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1300000
38
.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1300000
(-)emulators/pcem/files/patch-configure.ac (-32 lines)
Lines 1-32 Link Here
1
--- configure.ac.orig	2019-04-17 19:37:48 UTC
2
+++ configure.ac
3
@@ -64,6 +64,10 @@ case "${host_cpu}" in
4
     CPU=x86_64
5
     AC_MSG_RESULT(${host_cpu})
6
     ;;
7
+    amd64)
8
+    CPU=x86_64
9
+    AC_MSG_RESULT(${host_cpu})
10
+    ;;
11
     *)
12
     AC_MSG_ERROR([Unsupported CPU.])
13
     ;;
14
@@ -149,6 +153,18 @@ case "$host" in
15
            [echo "You need to install the OpenAL library."
16
            exit -1])
17
        build_linux="yes"
18
+       ;;
19
+    *-*-freebsd*)
20
+       CFLAGS="$CFLAGS -I/usr/local/include"
21
+       CXXFLAGS="$CXXFLAGS -I/usr/local/include"
22
+       LDFLAGS="$LDFLAGS -L/usr/local/lib"
23
+       AC_CHECK_LIB([GL], [glGetError], [], \
24
+           [echo "You need to install the OpenGL library."
25
+           exit -1])
26
+       AC_CHECK_LIB([openal], [alGetError], [], \
27
+           [echo "You need to install the OpenAL library."
28
+           exit -1])
29
+       build_other="yes"
30
        ;;
31
     *)
32
        AC_CHECK_LIB([GL], [glGetError], [], \

Return to bug 237376