View | Details | Raw Unified | Return to bug 239540
Collapse All | Expand All

(-)www/mitmproxy/Makefile (+1 lines)
Lines 4-9 Link Here
4
PORTNAME=	mitmproxy
4
PORTNAME=	mitmproxy
5
PORTVERSION=	4.0.4
5
PORTVERSION=	4.0.4
6
DISTVERSIONPREFIX=	v
6
DISTVERSIONPREFIX=	v
7
PORTREVISION=	1
7
CATEGORIES=	www python
8
CATEGORIES=	www python
8
9
9
MAINTAINER=	gaod@hychen.org
10
MAINTAINER=	gaod@hychen.org
(-)www/mitmproxy/files/patch-setup.py (-4 / +12 lines)
Lines 1-6 Link Here
1
--- setup.py.orig	2019-02-14 12:22:24 UTC
1
--- setup.py.orig	2019-07-30 16:02:34 UTC
2
+++ setup.py
2
+++ setup.py
3
@@ -61,7 +61,7 @@ setup(
3
@@ -61,24 +61,24 @@ setup(
4
     # It is not considered best practice to use install_requires to pin dependencies to specific versions.
4
     # It is not considered best practice to use install_requires to pin dependencies to specific versions.
5
     install_requires=[
5
     install_requires=[
6
         "blinker>=1.4",
6
         "blinker>=1.4",
Lines 8-15 Link Here
8
+        "brotli>=0.7.0",
8
+        "brotli>=0.7.0",
9
         "certifi>=2015.11.20.1",  # no semver here - this should always be on the last release!
9
         "certifi>=2015.11.20.1",  # no semver here - this should always be on the last release!
10
         "click>=6.2",
10
         "click>=6.2",
11
         "cryptography>=2.1.4,<2.4",
11
-        "cryptography>=2.1.4,<2.4",
12
@@ -75,10 +75,10 @@ setup(
12
+        "cryptography>=2.1.4",
13
         "h2>=3.0.1,<4",
14
         "hyperframe>=5.1.0,<6",
15
         "kaitaistruct>=0.7,<0.9",
16
         "ldap3>=2.5,<2.6",
17
         "passlib>=1.6.5",
18
         "pyasn1>=0.3.1,<0.5",
19
-        "pyOpenSSL>=17.5,<18.1",
20
+        "pyOpenSSL>=17.5",
13
         "pyparsing>=2.1.3",
21
         "pyparsing>=2.1.3",
14
         "pyperclip>=1.6.0",
22
         "pyperclip>=1.6.0",
15
         "ruamel.yaml>=0.13.2",
23
         "ruamel.yaml>=0.13.2",

Return to bug 239540