View | Details | Raw Unified | Return to bug 242025 | Differences between
and this patch

Collapse All | Expand All

(-)www/mitmproxy/Makefile (-8 / +9 lines)
Lines 4-10 Link Here
4
PORTNAME=	mitmproxy
4
PORTNAME=	mitmproxy
5
PORTVERSION=	4.0.4
5
PORTVERSION=	4.0.4
6
DISTVERSIONPREFIX=	v
6
DISTVERSIONPREFIX=	v
7
PORTREVISION=	1
7
PORTREVISION=	2
8
CATEGORIES=	www python
8
CATEGORIES=	www python
9
9
10
MAINTAINER=	gaod@hychen.org
10
MAINTAINER=	gaod@hychen.org
Lines 15-36 Link Here
15
15
16
RUN_DEPENDS=	${PYTHON_PKGNAMEPREFIX}click>=6.2:devel/py-click@${PY_FLAVOR} \
16
RUN_DEPENDS=	${PYTHON_PKGNAMEPREFIX}click>=6.2:devel/py-click@${PY_FLAVOR} \
17
		${PYTHON_PKGNAMEPREFIX}blinker>=1.4:devel/py-blinker@${PY_FLAVOR} \
17
		${PYTHON_PKGNAMEPREFIX}blinker>=1.4:devel/py-blinker@${PY_FLAVOR} \
18
		${PYTHON_PKGNAMEPREFIX}certifi>0:security/py-certifi@${PY_FLAVOR} \
18
		${PYTHON_PKGNAMEPREFIX}certifi>=2015.11.20.1:security/py-certifi@${PY_FLAVOR} \
19
		${PYTHON_PKGNAMEPREFIX}wsproto>=0.13.0:net/py-wsproto@${PY_FLAVOR} \
19
		${PYTHON_PKGNAMEPREFIX}wsproto>=0.11.0:net/py-wsproto@${PY_FLAVOR} \
20
		${PYTHON_PKGNAMEPREFIX}ldap3>=2.5:net/py-ldap3@${PY_FLAVOR} \
20
		${PYTHON_PKGNAMEPREFIX}ldap3>=2.5:net/py-ldap3@${PY_FLAVOR} \
21
		${PYTHON_PKGNAMEPREFIX}passlib>=1.6.5:security/py-passlib@${PY_FLAVOR} \
21
		${PYTHON_PKGNAMEPREFIX}passlib>=1.6.5:security/py-passlib@${PY_FLAVOR} \
22
		${PYTHON_PKGNAMEPREFIX}pyasn1>=0.3.1:devel/py-pyasn1@${PY_FLAVOR} \
22
		${PYTHON_PKGNAMEPREFIX}pyasn1>=0.3.1<0.5:devel/py-pyasn1@${PY_FLAVOR} \
23
		${PYTHON_PKGNAMEPREFIX}openssl>=17.5:security/py-openssl@${PY_FLAVOR} \
23
		${PYTHON_PKGNAMEPREFIX}openssl>=17.5:security/py-openssl@${PY_FLAVOR} \
24
		${PYTHON_PKGNAMEPREFIX}pyparsing>=2.1.3:devel/py-pyparsing@${PY_FLAVOR} \
24
		${PYTHON_PKGNAMEPREFIX}pyparsing>=2.1.3:devel/py-pyparsing@${PY_FLAVOR} \
25
		${PYTHON_PKGNAMEPREFIX}ruamel.yaml>=0.13.2:devel/py-ruamel.yaml@${PY_FLAVOR} \
25
		${PYTHON_PKGNAMEPREFIX}ruamel.yaml>=0.13.2:devel/py-ruamel.yaml@${PY_FLAVOR} \
26
		${PYTHON_PKGNAMEPREFIX}tornado>=4.3:www/py-tornado@${PY_FLAVOR} \
26
		${PYTHON_PKGNAMEPREFIX}tornado>=4.3<5.2:www/py-tornado@${PY_FLAVOR} \
27
		${PYTHON_PKGNAMEPREFIX}urwid>=2.0.1:devel/py-urwid@${PY_FLAVOR} \
27
		${PYTHON_PKGNAMEPREFIX}urwid>=2.0.1:devel/py-urwid@${PY_FLAVOR} \
28
		${PYTHON_PKGNAMEPREFIX}brotli>=0.7.0:archivers/py-brotli@${PY_FLAVOR} \
28
		${PYTHON_PKGNAMEPREFIX}brotli>=0.7.0:archivers/py-brotli@${PY_FLAVOR} \
29
		${PYTHON_PKGNAMEPREFIX}sortedcontainers>=1.5.4:devel/py-sortedcontainers@${PY_FLAVOR} \
29
		${PYTHON_PKGNAMEPREFIX}sortedcontainers>=1.5.4:devel/py-sortedcontainers@${PY_FLAVOR} \
30
		${PYTHON_PKGNAMEPREFIX}pyperclip>=1.6.0:devel/py-pyperclip@${PY_FLAVOR} \
30
		${PYTHON_PKGNAMEPREFIX}pyperclip>=1.6.0:devel/py-pyperclip@${PY_FLAVOR} \
31
		${PYTHON_PKGNAMEPREFIX}hyperframe>=5.1.0:www/py-hyperframe@${PY_FLAVOR} \
31
		${PYTHON_PKGNAMEPREFIX}hyperframe>=5.1.0<6:www/py-hyperframe@${PY_FLAVOR} \
32
		${PYTHON_PKGNAMEPREFIX}kaitaistruct>=0.7:devel/py-kaitaistruct@${PY_FLAVOR} \
32
		${PYTHON_PKGNAMEPREFIX}kaitaistruct>=0.7<0.9:devel/py-kaitaistruct@${PY_FLAVOR} \
33
		${PYTHON_PKGNAMEPREFIX}h2>=3.1.0:www/py-h2@${PY_FLAVOR}
33
		${PYTHON_PKGNAMEPREFIX}h2>=3.0.1<4:www/py-h2@${PY_FLAVOR} \
34
		${PYTHON_PKGNAMEPREFIX}cryptography>=2.1.4:security/py-cryptography@${PY_FLAVOR}
34
35
35
USES=		python:3.5+
36
USES=		python:3.5+
36
USE_PYTHON=	distutils autoplist noflavors
37
USE_PYTHON=	distutils autoplist noflavors
(-)www/mitmproxy/files/patch-setup.py (-3 / +5 lines)
Lines 1-4 Link Here
1
--- setup.py.orig	2019-07-30 16:02:34 UTC
1
--- setup.py.orig	2019-12-09 13:30:10 UTC
2
+++ setup.py
2
+++ setup.py
3
@@ -61,24 +61,24 @@ setup(
3
@@ -61,24 +61,24 @@ setup(
4
     # It is not considered best practice to use install_requires to pin dependencies to specific versions.
4
     # It is not considered best practice to use install_requires to pin dependencies to specific versions.
Lines 13-19 Link Here
13
         "h2>=3.0.1,<4",
13
         "h2>=3.0.1,<4",
14
         "hyperframe>=5.1.0,<6",
14
         "hyperframe>=5.1.0,<6",
15
         "kaitaistruct>=0.7,<0.9",
15
         "kaitaistruct>=0.7,<0.9",
16
         "ldap3>=2.5,<2.6",
16
-        "ldap3>=2.5,<2.6",
17
+        "ldap3>=2.5",
17
         "passlib>=1.6.5",
18
         "passlib>=1.6.5",
18
         "pyasn1>=0.3.1,<0.5",
19
         "pyasn1>=0.3.1,<0.5",
19
-        "pyOpenSSL>=17.5,<18.1",
20
-        "pyOpenSSL>=17.5,<18.1",
Lines 24-31 Link Here
24
-        "sortedcontainers>=1.5.4,<2.1",
25
-        "sortedcontainers>=1.5.4,<2.1",
25
+        "sortedcontainers>=1.5.4",
26
+        "sortedcontainers>=1.5.4",
26
         "tornado>=4.3,<5.2",
27
         "tornado>=4.3,<5.2",
27
         "urwid>=2.0.1,<2.1",
28
-        "urwid>=2.0.1,<2.1",
28
-        "wsproto>=0.11.0,<0.12.0",
29
-        "wsproto>=0.11.0,<0.12.0",
30
+        "urwid>=2.0.1",
29
+        "wsproto>=0.13.0",
31
+        "wsproto>=0.13.0",
30
     ],
32
     ],
31
     extras_require={
33
     extras_require={

Return to bug 242025