View | Details | Raw Unified | Return to bug 131436
Collapse All | Expand All

(-)Makefile (-4 / +18 lines)
Lines 8-14 Link Here
8
8
9
PORTNAME=	gnumeric
9
PORTNAME=	gnumeric
10
PORTVERSION=	1.9.3
10
PORTVERSION=	1.9.3
11
PORTREVISION=	2
11
PORTREVISION=	3
12
CATEGORIES=	math gnome
12
CATEGORIES=	math gnome
13
MASTER_SITES=	GNOME
13
MASTER_SITES=	GNOME
14
DIST_SUBDIR=	gnome2
14
DIST_SUBDIR=	gnome2
Lines 21-27 Link Here
21
21
22
USE_BZIP2=	yes
22
USE_BZIP2=	yes
23
USE_GETTEXT=	yes
23
USE_GETTEXT=	yes
24
USE_PERL5=	yes
25
USE_GMAKE=	yes
24
USE_GMAKE=	yes
26
USE_GNOME=	gnomeprefix intlhack gnomehack gnomehier \
25
USE_GNOME=	gnomeprefix intlhack gnomehack gnomehier \
27
		libgsf_gnome pygtk2 desktopfileutils libgnomeui
26
		libgsf_gnome pygtk2 desktopfileutils libgnomeui
Lines 30-36 Link Here
30
USE_LDCONFIG=	yes
29
USE_LDCONFIG=	yes
31
INSTALLS_ICONS=	yes
30
INSTALLS_ICONS=	yes
32
GNU_CONFIGURE=	yes
31
GNU_CONFIGURE=	yes
33
CONFIGURE_ARGS=	--without-guile --with-bonobo
32
CONFIGURE_ARGS=	--with-bonobo
34
CONFIGURE_ENV=	CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
33
CONFIGURE_ENV=	CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
35
		LIBS="-L${LOCALBASE}/lib -liconv ${PTHREAD_LIBS}" \
34
		LIBS="-L${LOCALBASE}/lib -liconv ${PTHREAD_LIBS}" \
36
		python_prog=${PYTHON_VERSION}
35
		python_prog=${PYTHON_VERSION}
Lines 42-51 Link Here
42
41
43
PLIST_SUB=	VERSION=${PORTVERSION}
42
PLIST_SUB=	VERSION=${PORTVERSION}
44
43
45
OPTIONS=	GNOMEDB "Enable libgnomedb support" off
44
OPTIONS=	GNOMEDB "Enable libgnomedb support" off \
45
			PERL "Enable Perl as extension language" on \
46
			GUILE "Enable Guile as extension language" off
46
47
47
.include <bsd.port.pre.mk>
48
.include <bsd.port.pre.mk>
48
49
50
.if defined(WITH_GUILE)
51
LIB_DEPENDS+=	guile.19:${PORTSDIR}/lang/guile
52
CONFIGURE_ARGS+=	--with-guile
53
.else
54
CONFIGURE_ARGS+=	--without-guile
55
.endif
56
57
.if defined(WITH_PERL)
58
USE_PERL5=	yes
59
.else
60
CONFIGURE_ARGS+=	--without-perl
61
.endif
62
49
.if defined(WITH_GNOMEDB)
63
.if defined(WITH_GNOMEDB)
50
USE_GNOME+=		libgnomedb
64
USE_GNOME+=		libgnomedb
51
CONFIGURE_ARGS+=	--with-gda
65
CONFIGURE_ARGS+=	--with-gda

Return to bug 131436