Bug 211511

Summary: panic while restarting network (iwm7260 wifi)
Product: Base System Reporter: ben.lavery <ben.lavery>
Component: kernAssignee: freebsd-wireless mailing list <wireless>
Status: New ---    
Severity: Affects Only Me CC: amvandemore, sbruno
Priority: ---    
Version: 11.0-BETA3   
Hardware: amd64   
OS: Any   
Attachments:
Description Flags
dmesg
none
Dumps none

Description ben.lavery@hashbang0.com 2016-08-01 20:13:34 UTC
Created attachment 173169 [details]
dmesg

I've been having problems with my iwm7260 wifi card since switching to the 11-STABLE/BETA builds where it won't pick up my home network.

After editing wpa_supplicant.conf to try and resolve this, I restarted the network a few times in quick succession and got a panic.

I'm currently on r303628, having the latest changes to iwm by Sean Bruno.
Comment 1 ben.lavery@hashbang0.com 2016-08-01 20:16:46 UTC
Created attachment 173171 [details]
Dumps

bzip2ed tarball of the dumps
Comment 2 amvandemore 2019-01-12 01:16:29 UTC
I also experience this panic.

iwm0: hw rev 0x230, fw ver 22.361476.0, address xxxxxxxx

FreeBSD ge73 12.0-STABLE FreeBSD 12.0-STABLE r342149 GENERIC-NODEBUG  amd64

I experienced the issue under 11.x as well.

iwm0@pci0:2:0:0:        class=0x028000 card=0x10108086 chip=0x24fd8086 rev=0x78 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = 'Wireless 8265 / 8275'
    class      = network

This card is also quite unreliable if I increase the channel width on the AP.  Disconnects around an hourly basis with very little info in the logs.