Bug 226964

Summary: editors/libreoffice: 6.0.2_2 crashes at start with libi18npoollo.so: Undefined symbol
Product: Ports & Packages Reporter: rotkap
Component: Individual Port(s)Assignee: freebsd-office mailing list <office>
Status: Closed Overcome By Events    
Severity: Affects Only Me CC: ben, lwhsu, projects, w.schwarzenfeld
Priority: ---    
Version: Latest   
Hardware: Any   
OS: Any   

Description rotkap 2018-03-27 08:53:58 UTC
$> libreoffice 
/usr/local/lib/libreoffice/program/../program/libi18npoollo.so: Undefined symbol "__cxa_thread_atexit"



Its a fresh version 6. it shows for a moment the startup-screen, before crashing.
Comment 1 rotkap 2018-03-27 10:54:08 UTC
by the way - I use German
Comment 2 rotkap 2018-03-27 11:14:32 UTC
But the german package isn't the cause - i tried it without.
Comment 3 Patrick Hess 2018-03-29 14:23:41 UTC
Same issue here. I'm running 10.3, and this seems to be a known problem on < 11:
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=214473
Comment 4 ben 2018-04-23 21:24:34 UTC
my deployments are also running FreeBSD 10.3 and prior to me performing a pkg upgrade last week LibreOffice was running just fine, now it's giving the same error with libi18npoollo.so reported in this thread.  I've just switched to using OpenOffice for now until this is resolved.
Comment 5 Li-Wen Hsu freebsd_committer 2019-02-07 17:36:19 UTC
Does it still happen in 6.0.7 and FreeBSD >= 11.2?
Comment 6 Patrick Hess 2019-02-07 17:58:07 UTC
6.0.7 works perfectly fine here on 11.2.

For me, the issue went away immediately after upgrading to 11.x.