Bug 108313

Summary: editors/openoffice.org port build fails
Product: Ports & Packages Reporter: Robin Smith <rasmith>
Component: Individual Port(s)Assignee: freebsd-openoffice (Nobody) <openoffice>
Status: Closed FIXED    
Severity: Affects Only Me    
Priority: Normal    
Version: Latest   
Hardware: Any   
OS: Any   

Description Robin Smith 2007-01-24 17:10:18 UTC
A build of editors/openoffice.org on 24 Jan 2007 (fresh cvsup) fails as follows:

v .pyc
dmake:  Error: -- `/usr/ports/editors/openoffice.org-2/work/OOE680_m6/solver/680/unxfbsdi.pro/bin/python' not found, and can't be made
'---* RULES.MK *---'

ERROR: Error 65280 occurred while making /usr/ports/editors/openoffice.org-2/work/OOE680_m6/pyuno/zipcore
dmake:  Error code 1, while making 'build_instsetoo_native'
'---*  *---'
*** Error code 255

This was during a portupgrade, not a fresh install: editors/openoffice.org-2.0.4 was built (within last six months, I don't have the date) on 6.0-STABLE without problems and is currently installed.  All port dependencies are up to date.

How-To-Repeat: cd /usr/ports/editors/openoffice.org
make

Or:

portupgrade openoffice.org # what I actually did
Comment 1 Edwin Groothuis freebsd_committer 2007-01-24 21:45:52 UTC
Responsible Changed
From-To: freebsd-ports-bugs->openoffice

Over to maintainer
Comment 2 Per olof Ljungmark 2007-02-09 13:54:51 UTC
I have the same issue on -STABLE, but buils fine on a recent -CURRENT:
FreeBSD 7.0-CURRENT #0: Tue Feb  6 17:26:48 CET 2007

I'm wondering if lang/python is the cause, it does not build om my 
-STABLE at the moment.
Comment 3 Per olof Ljungmark 2007-02-10 07:22:42 UTC
It appears that the reason is ncurses from ports breaking python. After 
removing it, OO seem to build ok, I'm about ten hours into it right now.
Comment 4 Robin Smith 2007-02-10 14:49:08 UTC
From: Per olof Ljungmark <peo@intersonic.se>
Subject: Re: ports/108313: editors/openoffice.org port build fails
Date: Sat, 10 Feb 2007 08:22:42 +0100

> It appears that the reason is ncurses from ports breaking python. After 
> removing it, OO seem to build ok, I'm about ten hours into it right now.

Thanks for this.  I'm running a build now.

R.
Comment 5 Robin Smith 2007-02-11 19:50:26 UTC
From: Per olof Ljungmark <peo@intersonic.se>
Subject: Re: ports/108313: editors/openoffice.org port build fails
Date: Sat, 10 Feb 2007 08:22:42 +0100

> It appears that the reason is ncurses from ports breaking python. After 
> removing it, OO seem to build ok, I'm about ten hours into it right now.

That fixed the build problem for me (build and install completed
without incident).

I did of course have to delete the ncurses port (needed on my system
only by rxvt-unicode, which I don't actually need anyway).
Comment 6 Mark Linimon freebsd_committer freebsd_triage 2007-04-01 12:30:25 UTC
State Changed
From-To: open->feedback

Does this problem still recur with the latest openoffice?
Comment 7 Mark Linimon freebsd_committer freebsd_triage 2007-06-12 08:55:20 UTC
State Changed
From-To: feedback->closed

Feedback timeout (2 months).
Comment 8 Mathieu Arnold freebsd_committer 2007-06-19 12:07:54 UTC
State Changed
From-To: closed->open

Yes, it does, with 2.2.1 on my i386 6.2, removing ncurse port solves the 
problem.
Comment 9 Chris.Shenton 2007-10-31 20:32:35 UTC
Same here, still. I don't have ncurses installed, FWIW.

FreeBSD PECTOPAH.shenton.org 6.2-STABLE FreeBSD 6.2-STABLE #14: Wed  
May 23 13:26:48 EDT 2007     root@PECTOPAH.shenton.org:/usr/obj/usr/ 
src/sys/SHENTON  i386

/more100/ports/editors/openoffice.org-2

# $FreeBSD: ports/editors/openoffice.org-2/Makefile,v 1.290  
2007/10/17 10:12:35 ade Exp $
...
PORTREVISION=   1
OOOVERSION=     2.3.0

Here's the end where it bombed during portupgrade.

register component 'proxyfac.uno' in registry 'pyuno_services.tmp'  
succesful!
register component 'pythonloader.uno' in registry  
'pyuno_services.tmp' succesful!
cd ../../unxfbsdi.pro/lib && mv pyuno_services.tmp pyuno_services.rdb
/more100/ports/editors/openoffice.org-2/work/OOG680_m6/pyuno/zipcore
dmake: Executing shell macro: $(FIND) $(SOLARLIBDIR)$/python -type f|  
$(GREP) -v .pyc |$(GREP) -v .py\~ |$(GREP) -v .orig
dmake:  Error: -- `/more100/ports/editors/openoffice.org-2/work/ 
OOG680_m6/solver/680/unxfbsdi.pro/bin/python' not found, and can't be  
made
---* RULES.MK *---

ERROR: Error 65280 occurred while making /more100/ports/editors/ 
openoffice.org-2/work/OOG680_m6/pyuno/zipcore
dmake:  Error code 1, while making 'build_instsetoo_native'
---*  *---
*** Error code 255
Comment 10 Josh Paetzel <josh@tcbug.org> 2007-11-01 12:15:46 UTC
->uname -a
FreeBSD homebase.tcbug.org 6.2-STABLE FreeBSD 6.2-STABLE #3: Sat Oct 13 
21:59:31 CDT 2007     
jpaetzel@homebase.tcbug.org:/usr/obj/usr/src/sys/HOMEBASE  i386

->pkg_info -xI ncurses
ncurses-5.6_1       Library for terminal-independent, full-screen output

->pkg_info -xI python
python25-2.5.1_1    An interpreted object-oriented programming language

I was successfully able to build openoffice.org-2.3.0_1 from ports.  I suspect 
this problem has gone away on it's own.

--
Thanks,

Josh Paetzel

PGP: 8A48 EF36 5E9F 4EDA 5A8C 11B4 26F9 01F1 27AF AECB
Comment 11 chris 2008-02-21 22:50:18 UTC
My vitals:

  chris@PECTOPAH:ports<109> uname -a
  FreeBSD PECTOPAH.shenton.org 6.3-PRERELEASE FreeBSD 6.3-PRERELEASE #17: Mon Nov 12 21:44:00 EST 2007     root@PECTOPAH.shenton.org:/usr/obj/usr/src/sys/SHENTON  i386

Last night I tried again to build openoffice with portupgrade, and again
it failed.  This morning I removed the old, working OO and tried
building the -2-RC version from ports.  I get the same -- or similar --
failure as before

  ...
  register component 'pythonloader.uno' in registry 'pyuno_services.tmp'
  succesful!
  cd ../../unxfbsdi.pro/lib && mv pyuno_services.tmp pyuno_services.rdb
  /more100/ports/editors/openoffice.org-2-RC/work/OOH680_m7/pyuno/zipcore
  dmake:  Error: --
  `/more100/ports/editors/openoffice.org-2-RC/work/OOH680_m7/solver/680/unxfbsdi.pro/bin/python'
  not found, and can't be made
  ---* RULES.MK *---

  ERROR: Error 65280 occurred while making
  /more100/ports/editors/openoffice.org-2-RC/work/OOH680_m7/pyuno/zipcore
  dmake:  Error code 1, while making 'build_instsetoo_native'
  ---*  *---
  *** Error code 255

  Stop in /more100/ports/editors/openoffice.org-2-RC.

Previous messages in this thread have suggested problems with ncurses or
epm but I don't have those:

    chris@PECTOPAH:ports<103> pkg_info -c '*curses*'
    pkg_info: can't find package '*curses*' installed or in a file!

    chris@PECTOPAH:ports<104> pkg_info -c '*epm*'
    pkg_info: can't find package '*epm*' installed or in a file!

    chris@PECTOPAH:ports<106> pkg_info -c 'python*'
    Information for python24-2.4.4_2:
    Comment:
    An interpreted object-oriented programming language

I thought I saw OO building a private python, a 2.3 version IIRC, so I
don't understand what in my system is breaking the builds of two
different OO versions in ports: .

  openoffice.org-2    
  openoffice.org-2-RC:


Any hints? Thanks.
Comment 12 Olaf Seibert 2009-05-07 16:16:58 UTC
I see similar problems when trying to compile OpenOffice, both OOo 2 and
3. This is on FreeBSD 6.1-RELEASE for amd64. I updated by ports tree
fairly recently, about a week ago or so.

For editors/openoffice.org-2 the end of the build looks like this:

Making: ../../unxfbsdx.pro/lib/pythonloader.uno.so
c++ -Wl,-z,combreloc -Wl,-rpath,'$ORIGIN:$ORIGIN/../ure-link/lib' -shared -Wl,-O
1 -Wl,--version-script ../../unxfbsdx.pro/misc/component_pythonloader.uno.map -L
../../unxfbsdx.pro/lib -L../lib -L/usr/ports/editors/openoffice.org-2/work/OOH680_m18/solenv/unxfbsdx/lib -L/usr/ports/editors/openoffice.org-2/work/OOH680_m18/solver/680/unxfbsdx.pro/lib -L/usr/ports/editors/openoffice.org-2/work/OOH680_m18/solenv/unxfbsdx/lib -L/usr/local/jdk1.6.0/lib -L/usr/local/jdk1.6.0/jre/lib/amd64 -L/usr/local/jdk1.6.0/jre/lib/amd64/server -L/usr/local/jdk1.6.0/jre/lib/amd64/native_threads -L/usr/local/lib ../../unxfbsdx.pro/slo/pythonloader.uno_version.o -o ../../unxfbsdx.pro/lib/ pythonloader.uno.so ../../unxfbsdx.pro/slo/pyuno_loader.o -luno_cppu -luno_cppuhelpergcc3 -luno_sal -lpyuno -lpython2.3 -pthread -lm -Wl,-Bdynamic -lstlport_gcc
rm -f ../../unxfbsdx.pro/lib/check_pythonloader.uno.so
mv ../../unxfbsdx.pro/lib/pythonloader.uno.so ../../unxfbsdx.pro/lib/check_pythonloader.uno.so
/usr/ports/editors/openoffice.org-2/work/OOH680_m18/solenv/bin/checkdll.sh -L../../unxfbsdx.pro/lib -L/usr/ports/editors/openoffice.org-2/work/OOH680_m18/solver/680/unxfbsdx.pro/lib  ../../unxfbsdx.pro/lib/check_pythonloader.uno.so
Checking DLL ../../unxfbsdx.pro/lib/check_pythonloader.uno.so ...: WARNING: Undefined symbol "GetVersionInfo"
-rwxr-xr-x  1 root  wheel  34098 May  7 16:09 ../../unxfbsdx.pro/lib/pythonloader.uno.so
-------------
cp pythonloader.py ../../unxfbsdx.pro/lib/pythonloader.py
rm -f ../../unxfbsdx.pro/lib/pyuno_services.rdb ../../unxfbsdx.pro/lib/pyuno_services.tmp ../../unxfbsdx.pro/lib/pyuno_services.rdb
cd ../../unxfbsdx.pro/lib && regcomp -register -r pyuno_services.tmp -c stocservices.uno -c invocation.uno -c introspection.uno -c invocadapt.uno -c proxyfac.uno -c reflection.uno -c pythonloader.uno
stocservices.uno
invocation.uno
introspection.uno
invocadapt.uno
proxyfac.uno
reflection.uno
pythonloader.uno
register component 'stocservices.uno' in registry 'pyuno_services.tmp' succesful!
register component 'invocation.uno' in registry 'pyuno_services.tmp' succesful!
register component 'introspection.uno' in registry 'pyuno_services.tmp' succesful!
register component 'invocadapt.uno' in registry 'pyuno_services.tmp' succesful!
register component 'proxyfac.uno' in registry 'pyuno_services.tmp' succesful!
register component 'reflection.uno' in registry 'pyuno_services.tmp' succesful!
register component 'pythonloader.uno' in registry 'pyuno_services.tmp' succesful!
cd ../../unxfbsdx.pro/lib && mv pyuno_services.tmp pyuno_services.rdb
/usr/ports/editors/openoffice.org-2/work/OOH680_m18/pyuno/zipcore
dmake:  Error: -- `/usr/ports/editors/openoffice.org-2/work/OOH680_m18/solver/680/unxfbsdx.pro/bin/python' not found, and can't be made
---* RULES.MK *---

ERROR: Error 65280 occurred while making /usr/ports/editors/openoffice.org-2/work/OOH680_m18/pyuno/zipcore
dmake:  Error code 1, while making 'build_instsetoo_native'
---*  *---

Stop in /usr/ports/editors/openoffice.org-2.
twoquid.5:/usr/ports/editors/openoffice.org-2$


For openoffice-3, I don't have the build output anymore but it was
related to the directory .../pyuno/zipcore as well and mentioned the
same error number:

"Error 65280 occurred while making .../pyuno/zipcore".

This was apparently only mentioned at the end of the build and the
actual errors had long vanished from the scrollback.

-Olaf.
--
Comment 13 Martin Wilke freebsd_committer 2009-05-31 00:03:03 UTC
State Changed
From-To: open->feedback

Could you please test if this issue still exists with an fresh ports 
tree and 7.2 or higher. Thanks for your report!
Comment 14 Pav Lucistnik freebsd_committer 2009-12-19 16:38:36 UTC
State Changed
From-To: feedback->closed

Feedback timeout