Bug 109097

Summary: [PATCH] Mk/bsd.tcl.mk improvement proposal
Product: Ports & Packages Reporter: Martin Matuska <martin>
Component: Individual Port(s)Assignee: Port Management Team <portmgr>
Status: Closed FIXED    
Severity: Affects Only Me    
Priority: Normal    
Version: Latest   
Hardware: Any   
OS: Any   
Attachments:
Description Flags
file.diff
none
bsd.tcl.mk.patch none

Description Martin Matuska 2007-02-12 17:40:03 UTC
- adds threads support for tcl
- enables settings for 83+ 84+ and 85+ (Tcl and Tk),
  others are possible
- supersedes ports/109082
Comment 1 Mark Linimon freebsd_committer freebsd_triage 2007-02-12 21:18:11 UTC
Responsible Changed
From-To: freebsd-ports-bugs->portmgr

This looks like it needs a regression test on the cluster.
Comment 2 Martin Matuska 2007-02-16 10:47:45 UTC
There were little bugs in the patch.
a) the compatibility mode with USE_TCL_BUILD needs TCL_NO_RUN_DEPENDS set
  (analogy: USE_TK_BUILD and TK_NO_RUN_DEPENDS)
b) USE_TCL => _USE_TCL in a case (was reported as recursive)
c) added TCL_HAS_THREADS for ports to detect if a threaded version is
installed (or wanted to be installed) ->
this enables port maintainers to add --enable-threads to their
CONFIGURE_ARGS etc.

Fix: see attachment.
Comment 3 Pav Lucistnik freebsd_committer 2007-03-14 23:10:09 UTC
You mentioned on IRC that the current patch here in obsolete. Could you
supply me with the state of the art one? I'd like to include it in the
exprun soon-ish.

-- 
Pav Lucistnik <pav@oook.cz>
              <pav@FreeBSD.org>

arch> I went grocery shopping, made a pot of chilli, played ey,
then ate some chilli
Comment 4 Martin Matuska 2007-03-19 16:06:11 UTC
Here is a link to the latest result of my work:
http://www.matuska.org/martin/cgi/viewvc.cgi/ports/Mk/bsd.tcl.mk?view=markup

Download link:
http://www.matuska.org/martin/cgi/viewvc.cgi/ports/Mk/bsd.tcl.mk?revision=HEAD

Patch against bsd.tcl.mk from FreeBSD CVS (against my HEAD from SVN):
http://www.matuska.org/martin/cgi/viewvc.cgi/ports/Mk/bsd.tcl.mk?r1=45&r2=HEAD&view=patch

I will keep testing and looking for bugs and fix them in SVN.
Test reports and suggestions are welcome.
Comment 5 Pav Lucistnik freebsd_committer 2007-03-19 16:20:44 UTC
>  Here is a link to the latest result of my work:
>  http://www.matuska.org/martin/cgi/viewvc.cgi/ports/Mk/bsd.tcl.mk?view=markup
>  
>  Download link:
>  http://www.matuska.org/martin/cgi/viewvc.cgi/ports/Mk/bsd.tcl.mk?revision=HEAD
>  
>  Patch against bsd.tcl.mk from FreeBSD CVS (against my HEAD from SVN):
>  http://www.matuska.org/martin/cgi/viewvc.cgi/ports/Mk/bsd.tcl.mk?r1=45&r2=HEAD&view=patch
>  
>  I will keep testing and looking for bugs and fix them in SVN.
>  Test reports and suggestions are welcome.

Do tell us once you want this included in the official ports tree.

-- 
Pav Lucistnik <pav@oook.cz>
              <pav@FreeBSD.org>

Orfax's hip flask contained Old Janx Spirit, a mixture of potions of
stupidity, paralysis, naivery, ruination, lose memories, confusion,
and slime mold juice, with a twist of lemon.
    - from a post on Angband Community Forum
Comment 6 Martin Matuska 2007-03-27 15:59:12 UTC
I would like to submit revision 57 for testing:

Full file:
http://www.matuska.org/martin/cgi/viewvc.cgi/ports/Mk/bsd.tcl.mk?revision=57

Patch against current CVS:
http://www.matuska.org/martin/cgi/viewvc.cgi/ports/Mk/bsd.tcl.mk?r1=57&r2=45&view=patch
Comment 7 Pav Lucistnik freebsd_committer 2007-03-27 16:19:56 UTC
I have looked on the patch briefly, and I have few questions:
- can you make up a patch that converts all ports to new semantics wrt
  USE_TCL/USE_TK now providing lib instead of run dependency
- TK_NO_RUN_DEPENDS seems superfluous when we have USE_TK_BUILD, no?

-- 
Pav Lucistnik <pav@oook.cz>
              <pav@FreeBSD.org>

Just because you're an angel doesn't mean you have to be a fool.
Comment 8 Pav Lucistnik freebsd_committer 2007-03-29 18:16:53 UTC
State Changed
From-To: open->analyzed

Updated patch (martinko's svn rev 61) being tested on pointyhat exprun
Comment 9 Pav Lucistnik freebsd_committer 2007-04-02 23:54:42 UTC
State Changed
From-To: analyzed->closed

Committed, thanks!
Comment 10 dfilter service freebsd_committer 2007-04-02 23:55:35 UTC
pav         2007-04-02 22:55:29 UTC

  FreeBSD ports repository

  Modified files:
    Mk                   bsd.port.mk bsd.tcl.mk 
  Log:
  - Overhaul bsd.tcl.mk: most importantly, change the semantics to match
    USE_PERL5* macros:
  
    USE_TCL, USE_TK: lib depends
    USE_TCL_BUILD, USE_TK_BUILD: build depends
    USE_TCL_RUN, USE_TK_RUN: run depends
  
    See comment block in bsd.tcl.mk for details
  
  PR:             ports/109097
  Submitted by:   Martin Matuska <martin@matuska.org>
  Tested on:      pointyhat exp-run
  
  Revision  Changes    Path
  1.562     +2 -2      ports/Mk/bsd.port.mk
  1.8       +386 -112  ports/Mk/bsd.tcl.mk
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 11 dfilter service freebsd_committer 2007-04-02 23:56:19 UTC
pav         2007-04-02 22:56:15 UTC

  FreeBSD ports repository

  Modified files:
    astro/gpsman         Makefile 
    astro/ptiger         Makefile 
    astro/tclgeomap      Makefile 
    astro/tkgeomap       Makefile 
    astro/xeartk         Makefile 
    cad/pcb              Makefile 
    comms/tkhylafax      Makefile 
    deskutils/zorro      Makefile 
    devel/cbrowser       Makefile 
    devel/tkcvs          Makefile 
    devel/tkp4           Makefile 
    editors/impress      Makefile 
    emulators/bsvc       Makefile 
    games/klondike       Makefile 
    games/tkmoo          Makefile 
    graphics/aolserver-nsgd Makefile 
    graphics/tkpng       Makefile 
    irc/tkirc            Makefile 
    lang/erlang          Makefile 
    lang/tcl-wrapper     Makefile 
    math/py-matplotlib   Makefile 
    misc/ewipe           Makefile 
    misc/fcalc           Makefile 
    misc/tkregexp        Makefile 
    multimedia/tkxanim   Makefile 
    net/openverse        Makefile 
    net/tcpillust        Makefile 
    net-im/tkabber-devel Makefile 
    net-mgmt/ipacco      Makefile 
    ports-mgmt/instant-tinderbox Makefile 
    security/aolserver-nsmcrypt Makefile 
    security/aolserver-nsmhash Makefile 
    security/gorilla     Makefile 
    security/secpanel    Makefile 
    textproc/msort       Makefile 
    textproc/redet       Makefile 
    textproc/redland-bindings Makefile 
    textproc/xml2rfc     Makefile 
    www/tdom             Makefile 
    www/websh            Makefile 
    x11-toolkits/py-tktreectrl Makefile 
    x11-toolkits/tile    Makefile 
    x11-toolkits/tkdnd   Makefile 
    x11-toolkits/tktray  Makefile 
    x11-toolkits/tktreectrl Makefile 
  Log:
  - Convert existing ports to a new bsd.tcl.mk order
  
  PR:             ports/109097
  Submitted by:   Martin Matuska <martin@matuska.org>
  Tested on:      pointyhat exp-run
  
  Revision  Changes    Path
  1.18      +1 -1      ports/astro/gpsman/Makefile
  1.3       +1 -1      ports/astro/ptiger/Makefile
  1.6       +0 -2      ports/astro/tclgeomap/Makefile
  1.6       +1 -2      ports/astro/tkgeomap/Makefile
  1.3       +1 -1      ports/astro/xeartk/Makefile
  1.55      +1 -1      ports/cad/pcb/Makefile
  1.22      +1 -1      ports/comms/tkhylafax/Makefile
  1.28      +1 -1      ports/deskutils/zorro/Makefile
  1.7       +1 -1      ports/devel/cbrowser/Makefile
  1.36      +1 -1      ports/devel/tkcvs/Makefile
  1.9       +1 -1      ports/devel/tkp4/Makefile
  1.9       +1 -1      ports/editors/impress/Makefile
  1.24      +1 -1      ports/emulators/bsvc/Makefile
  1.14      +6 -3      ports/games/klondike/Makefile
  1.10      +1 -1      ports/games/tkmoo/Makefile
  1.3       +2 -7      ports/graphics/aolserver-nsgd/Makefile
  1.3       +0 -2      ports/graphics/tkpng/Makefile
  1.20      +1 -1      ports/irc/tkirc/Makefile
  1.104     +1 -1      ports/lang/erlang/Makefile
  1.2       +2 -2      ports/lang/tcl-wrapper/Makefile
  1.17      +2 -2      ports/math/py-matplotlib/Makefile
  1.31      +1 -1      ports/misc/ewipe/Makefile
  1.2       +1 -1      ports/misc/fcalc/Makefile
  1.8       +1 -1      ports/misc/tkregexp/Makefile
  1.9       +1 -1      ports/multimedia/tkxanim/Makefile
  1.24      +2 -2      ports/net-im/tkabber-devel/Makefile
  1.4       +1 -1      ports/net-mgmt/ipacco/Makefile
  1.13      +2 -2      ports/net/openverse/Makefile
  1.6       +0 -1      ports/net/tcpillust/Makefile
  1.7       +2 -2      ports/ports-mgmt/instant-tinderbox/Makefile
  1.3       +2 -7      ports/security/aolserver-nsmcrypt/Makefile
  1.3       +2 -7      ports/security/aolserver-nsmhash/Makefile
  1.7       +1 -2      ports/security/gorilla/Makefile
  1.18      +1 -1      ports/security/secpanel/Makefile
  1.8       +1 -1      ports/textproc/msort/Makefile
  1.23      +1 -1      ports/textproc/redet/Makefile
  1.13      +2 -2      ports/textproc/redland-bindings/Makefile
  1.14      +2 -2      ports/textproc/xml2rfc/Makefile
  1.5       +4 -10     ports/www/tdom/Makefile
  1.3       +0 -2      ports/www/websh/Makefile
  1.2       +1 -1      ports/x11-toolkits/py-tktreectrl/Makefile
  1.3       +3 -4      ports/x11-toolkits/tile/Makefile
  1.3       +0 -2      ports/x11-toolkits/tkdnd/Makefile
  1.4       +0 -2      ports/x11-toolkits/tktray/Makefile
  1.8       +5 -7      ports/x11-toolkits/tktreectrl/Makefile
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"