Bug 113861

Summary: x11/xrandr returns failed request with radeon driver
Product: Ports & Packages Reporter: Dominic Fandrey <LoN_Kamikaze>
Component: Individual Port(s)Assignee: freebsd-x11 (Nobody) <x11>
Status: Closed FIXED    
Severity: Affects Only Me    
Priority: Normal    
Version: Latest   
Hardware: Any   
OS: Any   

Description Dominic Fandrey 2007-06-19 19:10:00 UTC
The xrandr command outputs the following error message, when called without
parameters:

X Error of failed request:  BadRequest (invalid request code or no such operation)
  Major opcode of failed request:  154 (RANDR)
  Minor opcode of failed request:  6 ()
  Serial number of failed request:  9
  Current serial number in output stream:  9

I have two machines using the radeon driver. One Radeon 9200 SE with 128MB video
memory and a Radeon Mobility 7500 (M7) with 32MB video memory. The problem exists
on both machines.

How-To-Repeat: Just run
# xrandr
on a machine using the radeon driver.
Comment 1 Edwin Groothuis freebsd_committer 2007-06-19 19:10:12 UTC
Responsible Changed
From-To: freebsd-ports-bugs->freebsd-x11

Over to maintainer
Comment 2 Florent Thoumie freebsd_committer 2007-09-14 15:44:33 UTC
State Changed
From-To: open->feedback

Can you reproduce the issue with X.org 7.3?
Comment 3 Dominic Fandrey 2007-09-14 15:55:29 UTC
Fortunately the issue is gone.

You can close this. :)
Comment 4 Martin Wilke freebsd_committer 2007-09-14 16:07:13 UTC
State Changed
From-To: feedback->closed

close by submitter request.