Bug 118111

Summary: rc: network.subr Add MAC address based interface renaming
Product: Base System Reporter: Thomas Hurst <tom>
Component: confAssignee: Kyle Evans <kevans>
Status: Open ---    
Severity: Affects Some People CC: eborisch+FreeBSD, emaste, freebsd, kevans, koobs, lifanov, ltning-freebsd, net, olivierw1+bugzilla-freebsd, pi, shurd, travis
Priority: Normal Keywords: easy, feature, needs-qa
Version: CURRENTFlags: koobs: maintainer-feedback? (net)
koobs: mfc-stable12?
koobs: mfc-stable11?
Hardware: Any   
OS: Any   
See Also: https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=212480
Description Flags
Patch against CURRENT none

Description Thomas Hurst 2007-11-18 23:00:04 UTC
I recently temporarily added an additional network card to my system for
testing, thus moving all my interface names about; em0 becomes em1, etc,
necessitating annoying configuration changes and/or cable juggling.

Many Linux distributions solve this problem with /etc/iftab or /etc/mactab,
wiring an interface name to a MAC address so they're no longer dependent on
probe order.

This patch adds similar functionality to network.subr's ifnet_rename function,
so things like the following can be added to rc.conf:

ifconfig_mac_names="lan0 inet0"

Also included is a small patch against the rc.conf(5) manpage.

Both patches are against RELENG_7, but should apply relatively cleanly against
Comment 1 OlivierW 2016-12-18 23:23:52 UTC

It would be nice to have this patch merged as I think it's quite useful :-)

Best Regards
Comment 2 Thomas Hurst 2018-07-13 23:37:54 UTC
Created attachment 195121 [details]
Patch against CURRENT

Since this hasn't had much love lately, I've done a bit of work to update the network.subr patch against CURRENT so at least there's something new to look at.

This patch changes how it works a little - the original example now looks like this:


Not quite as pretty, but the patch is a fair bit simpler now.

Renaming is still pretty rudimentary - it can't reliably pin, say, "em0", because another interface may already have that name, but one step at a time.

Care also needs to be taken if a system is sharing "ether" across multiple interfaces, e.g. with lagg.  hwaddr might be more appropriate in these cases, and this naming scheme helpfully leaves room for that in future.
Comment 3 Kubilay Kocak freebsd_committer freebsd_triage 2019-05-21 03:59:40 UTC
Can't be in progress without an assignee