Bug 119550

Summary: [ppp] ppp not starting during bootup.
Product: Base System Reporter: Mel <mel.xyzzy>
Component: confAssignee: freebsd-bugs (Nobody) <bugs>
Status: Open ---    
Severity: Affects Only Me    
Priority: Normal    
Version: 6.3-PRERELEASE   
Hardware: Any   
OS: Any   

Description Mel 2008-01-10 23:20:01 UTC
$ fgrep '$FreeBSD' /etc/rc.d/ppp
# $FreeBSD: src/etc/rc.d/ppp,v 1.11.2.4 2007/10/31 18:53:07 emax Exp $

$ grep 'DEBUG:.*ppp' /var/log/messages
Jan 10 13:11:17 squeeze root: /etc/rc: DEBUG: checkyesno: pppoed_enable is set to NO.

NOTE: manual start here:
Jan 10 13:26:19 squeeze rachie: /etc/rc.d/ppp: DEBUG: checkyesno: ppp_enable is set to YES.
Jan 10 13:26:19 squeeze rachie: /etc/rc.d/ppp: DEBUG: run_rc_command: doit: ppp_start 
Jan 10 13:26:20 squeeze rachie: /etc/rc.d/ppp: DEBUG: run_rc_command: start_postcmd: ppp_poststart 

rcorder lists ppp to be executed.

rc.conf:
ppp_enable="YES"
ppp_mode="ddial"
ppp_profile="acs_alaska"

Fix: 

Tried to figure out why, but it doesn't even show up as candidate for execution,
so the rc_debug output is useless. It used to work with a previous install,
judging from kernel.old date, created on Aug 20.
How-To-Repeat: 	Reboot a machine with ppp enabled as above.
Comment 1 Mel 2008-01-29 19:38:01 UTC
Here's what cron says:
# crontab -l|grep ppp
@reboot /etc/rc.d/ppp start

/etc/rc.d/ppp: DEBUG: checkyesno: ppp_enable is set to YES.
/etc/rc.d/ppp: DEBUG: run_rc_command: doit: ppp_start 
Starting PPP profile: acs_alaska.
/etc/rc.d/ppp: DEBUG: run_rc_command: start_postcmd: ppp_poststart 
/etc/rc.d/ipfilter: DEBUG: checkyesno: ipfilter_enable is set to NO.
/etc/rc.d/pf: DEBUG: checkyesno: pf_enable is set to YES.
/etc/rc.d/pf: DEBUG: run_rc_command: doit: pf_resync

-- 
Mel
Comment 2 admin 2008-07-13 22:52:19 UTC
Hello!

  The problem is in /etc/rc.d/ppp script's function
  ppp_start_profile():

  su -m $ppp_user -c "$command ${rc_flags} ${_ppp_profile}"
  
  The su command does not execute during bootup that's why ppp is not
  started.
  Fix:
  Replace
     su -m $ppp_user -c "$command ${rc_flags} ${_ppp_profile}"
  with
    $command ${rc_flags} ${_ppp_profile}

  ppp will be executed with root privileges
-- 
WBR, Fedorenko Vadim
Comment 3 Marian Cerny 2008-10-11 19:18:55 UTC
I had the same problem and I am confirming that Vadim's fix (removing su
from /etc/rc.d/ppp) worked for me.

Marian
Comment 4 Eitan Adler freebsd_committer freebsd_triage 2017-12-31 08:00:49 UTC
For bugs matching the following criteria:

Status: In Progress Changed: (is less than) 2014-06-01

Reset to default assignee and clear in-progress tags.

Mail being skipped