Bug 121236

Summary: [PATCH] mail/postfix: fix package data_directory creation
Product: Ports & Packages Reporter: Artis Caune <Artis.Caune>
Component: Individual Port(s)Assignee: freebsd-ports-bugs mailing list <ports-bugs>
Status: Closed FIXED    
Severity: Affects Only Me    
Priority: Normal    
Version: Latest   
Hardware: Any   
OS: Any   
Attachments:
Description Flags
file.diff none

Description Artis Caune 2008-02-29 21:30:01 UTC
When adding postfix package, make install is not run and new postfix parameter 'data_directory=/var/lib/postfix' is not created.

Change /var/lib to /var/db

Fix: Patch attached with submission follows:
How-To-Repeat: # make package
# pkg_delete postfix-2.5.1,1
# rmdir /var/lib/postfix
# pkg_add postfix-2.5.1,1.tbz
Comment 1 Edwin Groothuis freebsd_committer 2008-02-29 21:30:10 UTC
State Changed
From-To: open->feedback

Awaiting maintainers feedback (via the GNATS Auto Assign Tool)
Comment 2 scott 2008-03-01 00:08:03 UTC
I had a similar problem:
fatal: tls_prng_exch_open: cannot open PRNG exchange file

Seemed to be caused by /var/lib not being readable by Postfix. Looks  
like this patch would fix the problem,
Comment 3 dfilter service freebsd_committer 2008-03-01 01:44:39 UTC
mnag        2008-03-01 01:44:31 UTC

  FreeBSD ports repository

  Modified files:
    mail/postfix         Makefile pkg-install 
    mail/postfix/files   patch-conf::main.cf 
  Added files:
    mail/postfix/files   patch-conf__postfix-files 
  Log:
  - Fix data_directory
  
  PR:             121236
  Submitted by:   Artis Caune <Artis.Caune___latnet.lv>
  
  Revision  Changes    Path
  1.137     +2 -0      ports/mail/postfix/Makefile
  1.4       +12 -5     ports/mail/postfix/files/patch-conf::main.cf
  1.1       +11 -0     ports/mail/postfix/files/patch-conf__postfix-files (new)
  1.26      +2 -1      ports/mail/postfix/pkg-install
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 4 Marcus Alves Grando freebsd_committer 2008-03-01 01:50:58 UTC
State Changed
From-To: feedback->closed

Committed. Thanks!