Bug 123738

Summary: [PATCH] Fixed mail/dkim-milter build with WITH_POSTFIX_MILTER option being enabled
Product: Ports & Packages Reporter: Alexander Zhuravlev <zaa>
Component: Individual Port(s)Assignee: freebsd-ports-bugs mailing list <ports-bugs>
Status: Closed FIXED    
Severity: Affects Only Me CC: umq
Priority: Normal    
Version: Latest   
Hardware: Any   
OS: Any   
Attachments:
Description Flags
dkim-milter.diff
none
dkim-milter.patch none

Description Alexander Zhuravlev 2008-05-16 19:20:02 UTC
	

I've just tried to build the port with WITH_POSTFIX_MILTER option being enabled and got the error mentioned below:

==========================================================================================
sirius:...mail/dkim-milter> make WITH_POSTFIX_MILTER=yes WITH_VERIFY_DOMAINKEYS=yes install
...
install  -o root -g wheel -m 444 /usr/obj/usr/ports/mail/dkim-milter/work/dkim-milter-2.5.5/libdkim/docs/`/usr/bin/basename /libdkim/rfc2822_mailbox_split.html` /usr/local/share/doc/dkim-milter/libdkim/
cat: pkg-message.postfix: No such file or directory
*** Error code 1

Stop in /usr/ports/mail/dkim-milter.
==========================================================================================

Fix: I've managed to successfully install the port by applying the following patch.
Comment 1 Edwin Groothuis freebsd_committer 2008-05-16 19:20:08 UTC
Maintainer of mail/dkim-milter,

Please note that PR ports/123738 has just been submitted.

If it contains a patch for an upgrade, an enhancement or a bug fix
you agree on, reply to this email stating that you approve the patch
and a committer will take care of it.

The full text of the PR can be found at:
    http://www.freebsd.org/cgi/query-pr.cgi?pr=ports/123738

-- 
Edwin Groothuis via the GNATS Auto Assign Tool
edwin@FreeBSD.org
Comment 2 Edwin Groothuis freebsd_committer 2008-05-16 19:20:11 UTC
State Changed
From-To: open->feedback

Awaiting maintainers feedback (via the GNATS Auto Assign Tool)
Comment 3 Hirohisa Yamaguchi 2008-05-17 01:51:23 UTC
Hi,

I could not reproduce the install error here with 7.0-RELEASE-p1.
pkg-message.postfix's shown correctly.

I don't understand how the patch fixes the problem.

At Fri, 16 May 2008 18:20:08 UT,
Edwin Groothuis wrote:
> Please note that PR ports/123738 has just been submitted.

> The full text of the PR can be found at:
>     http://www.freebsd.org/cgi/query-pr.cgi?pr=ports/123738

-- 

	Hirohisa Yamaguchi
	  umq@ueo.co.jp
Comment 4 Alexander Zhuravlev 2008-05-17 02:27:25 UTC
On Sat, May 17, 2008 at 09:51:23AM +0900, Hirohisa Yamaguchi wrote:
> Hi,
> 
> I could not reproduce the install error here with 7.0-RELEASE-p1.
> pkg-message.postfix's shown correctly.

Please put the following entry to /etc/make.conf

WRKDIRPREFIX=/usr/obj

then proceed to the /usr/ports/mail/dkim-milter/ and try to install the
port.

The patch moves pkg-message.postfix to files/pkg-message.postfix.in,
which is being post-processed (ports system performs replacements of
%%PREFIX%%, etc in the pkg-message.postfix.in file) and copied to ${WRKDIR}/pkg-message.postfix.
Then the ports system displays content of the ${WRKDIR}/pkg-message.postfix file.
Comment 5 Hirohisa Yamaguchi 2008-05-17 03:28:43 UTC
At Sat, 17 May 2008 05:27:25 +0400,
Alexander Zhuravlev wrote:

> Please put the following entry to /etc/make.conf
> 
> WRKDIRPREFIX=/usr/obj
> 
> then proceed to the /usr/ports/mail/dkim-milter/ and try to install the
> port.

Okay, I see the problem.
Attached patch should work.

I'll consider using SUB_FILES for pkg-message.postfix in the next
update, since a better instruction for postfix users are discussed in
upstream.
So, I keep pkg-message.postfix untouched this time.


Regards,

-- 

	Hirohisa Yamaguchi
	  umq@ueo.co.jp
Comment 6 dfilter service freebsd_committer 2008-05-18 15:32:53 UTC
miwi        2008-05-18 14:32:48 UTC

  FreeBSD ports repository

  Modified files:
    mail/dkim-milter     Makefile 
  Log:
  - Fix build with WITH_POSTFIX_MILTER option being enabled
  
  PR:             123738
  Submitted by:   Alexander Zhuravlev <zaa@zaa.pp.ru>
  Approved by:    maintainer
  
  Revision  Changes    Path
  1.49      +2 -1      ports/mail/dkim-milter/Makefile
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 7 Martin Wilke freebsd_committer 2008-05-18 15:32:56 UTC
State Changed
From-To: feedback->closed

Committed. Thanks!