Bug 126308

Summary: [patch] editors/openoffice.org-2 compilation fails on -CURRENT
Product: Ports & Packages Reporter: Ted Faber <faber>
Component: Individual Port(s)Assignee: freebsd-openoffice (Nobody) <openoffice>
Status: Closed FIXED    
Severity: Affects Only Me CC: faber
Priority: Normal    
Version: Latest   
Hardware: Any   
OS: Any   
Attachments:
Description Flags
file.diff none

Description Ted Faber 2008-08-06 20:00:09 UTC
	The configure script for the local copy of libxslt that OO compiles has
	a line in it that is invalide for FreeBSD's /bin/test that causes the
	configure script to fail.  Specifically, the script uses == for
	equality and /bin/test expects =/ I'm not sure why OO is compiling the
	local copy of libxslt, but this patch removes the configuration error.

	This is resolved somewhat indirectly.  OO patches the libxslt
	configuration script, and this patch alters that patch.

Fix: Attached:
How-To-Repeat: 	I suspect that there's an installed ports interaction that's causing
	the compilation to go on, but casuing a local copy of libxslt to get
	compiled by the port should fail on any FreeBSD.
Comment 1 Mark Linimon freebsd_committer freebsd_triage 2008-08-06 20:17:59 UTC
Responsible Changed
From-To: freebsd-ports-bugs->openoffice

Over to maintainer(s).
Comment 2 Alexey Shuvaev 2008-08-30 12:56:55 UTC
The supplied patch worked fine for me. The system is:

> uname -a
FreeBSD wep4017.physik.uni-wuerzburg.de 8.0-CURRENT FreeBSD 8.0-CURRENT #0: Thu Aug 28 13:17:09 CEST 2008     root@wep4017.physik.uni-wuerzburg.de:/usr/obj/usr/src/sys/GENERIC  amd64

Thanks,
Alexey.
Comment 3 Martin 2008-09-09 15:42:04 UTC
Thanks. This patch fixes the build process on -STABLE, too.

--
Martin
Comment 4 Ted Faber 2008-09-09 16:29:12 UTC
On Tue, Sep 09, 2008 at 04:42:04PM +0200, Martin wrote:
> 
> Thanks. This patch fixes the build process on -STABLE, too.

Glad to help.

-- 
Ted Faber
http://www.isi.edu/~faber           PGP: http://www.isi.edu/~faber/pubkeys.asc
Unexpected attachment on this mail? See http://www.isi.edu/~faber/FAQ.html#SIG
Comment 5 Martin 2008-09-27 08:48:04 UTC
Hi,

I wonder why this bugfix does not get committed.

Perhaps the steps to reproduce the bug are missing, because some people
are telling me, they have no problems.

So this is how I build OpenOffice and get this error:

cd /usr/ports/editors/openoffice.org-2
make install clean WITH_TTF_BYTECODE_ENABLED=yes WITH_CUPS=yes
LOCALIZED_LANG=de WITHOUT_MOZILLA=yes

--
Thank you,
Martin
Comment 6 Maho Nakata freebsd_committer 2008-10-11 08:04:07 UTC
State Changed
From-To: open->closed

Fixed by but we do not reference your patch to avoid 
SCA issue. (all patch submitters shall sign to SCA 
otherwise we cannot upstream)