Bug 130622

Summary: [PATCH] Fix graphics/sane-backends build
Product: Ports & Packages Reporter: Mel <mel>
Component: Individual Port(s)Assignee: Dmitry Marakasov <amdmi3>
Status: Closed FIXED    
Severity: Affects Only Me    
Priority: Normal    
Version: Latest   
Hardware: Any   
OS: Any   
Attachments:
Description Flags
patch-include_sane_sanei_tcp.h none

Description Mel 2009-01-16 14:50:00 UTC
graphics/sane-backends fails to compile due to a header error:
In file included from epson2_net.c:19:
../include/sane/sanei_tcp.h:28: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'sanei_tcp_write'
../include/sane/sanei_tcp.h:29: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'sanei_tcp_read'
epson2_net.c: In function 'sanei_epson_net_read_raw':
epson2_net.c:57: warning: implicit declaration of function 'sanei_tcp_read'
epson2_net.c: In function 'sanei_epson_net_write':
epson2_net.c:194: warning: implicit declaration of function 'sanei_tcp_write'
gmake[1]: *** [epson2_net.lo] Error 1
gmake[1]: Leaving directory `/usr/obj/usr/ports/graphics/sane-backends/work/sane-backends-1.0.19/backend'
gmake: *** [all-recursive] Error 1
*** Error code 2

How-To-Repeat: make -C /usr/ports/graphics/sane-backends build
Comment 1 Beech Rintoul freebsd_committer 2009-01-18 01:13:56 UTC
State Changed
From-To: open->closed

Committed, Thanks!
Comment 2 Beech Rintoul freebsd_committer 2009-01-18 01:20:02 UTC
State Changed
From-To: closed->open

Wrong pr
Comment 3 Dmitry Marakasov freebsd_committer 2009-01-18 03:06:33 UTC
Responsible Changed
From-To: freebsd-ports-bugs->amdmi3

I'll take it.
Comment 4 dfilter service freebsd_committer 2009-01-20 15:44:40 UTC
amdmi3      2009-01-20 15:44:28 UTC

  FreeBSD ports repository

  Added files:
    graphics/sane-backends/files patch-include_sane_sanei_tcp.h 
  Log:
  - Add patch to fix build error (couldn't reproduce it though; submitter mail bounces, so I can't get any details)
  
  PR:             130622
  Submitted by:   Mel <mel at rachie dot is-a-geek dot net>
  
  Revision  Changes    Path
  1.1       +10 -0     ports/graphics/sane-backends/files/patch-include_sane_sanei_tcp.h (new)
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 5 Dmitry Marakasov freebsd_committer 2009-01-20 15:44:45 UTC
State Changed
From-To: open->closed

Committed. Thanks!