Bug 132036

Summary: [panic] page fault when connecting Olympus C740 camera
Product: Base System Reporter: David Johnson <david>
Component: usbAssignee: freebsd-usb mailing list <usb>
Status: Open ---    
Severity: Affects Only Me    
Priority: Normal    
Version: 7.1-STABLE   
Hardware: Any   
OS: Any   

Description David Johnson 2009-02-24 01:10:01 UTC
FreeBSD page faults and panics when connecting an Olympus C740 camera. This happens every time on two separate systems with 7.1-STABLE. I have had this camera a few years, and this is new behavior. It was definitely not doing this the last time I connected the camera in November with 7.0-RELEASE.

From log/messages:

Feb 23 16:27:06 radagast root: Unknown USB device: vendor 0x07b4 product 0x0105
bus uhub4
Feb 23 16:27:06 radagast kernel: umass0: <OLYMPUS C740UZ, class 0/0, rev 1.10/0.
01, addr 2> on uhub4

From crash/info.0:

Dump header from device /dev/ad8s1b
  Architecture: i386
  Architecture Version: 2
  Dump Length: 239534080B (228 MB)
  Blocksize: 512
  Dumptime: Mon Feb 23 16:27:06 2009
  Hostname: radagast.usermode.org
  Magic: FreeBSD Kernel Dump
  Version String: FreeBSD 7.1-STABLE #1: Sun Feb 15 14:58:30 PST 2009
    david@radagast.usermode.org:/usr/obj/usr/src/sys/RADAGAST
  Panic String: page fault
  Dump Parity: 2507188485
  Bounds: 0
  Dump Status: good

I can provide a core if necessary.

How-To-Repeat: Connect camera to USB port.
Comment 1 Eitan Adler freebsd_committer freebsd_triage 2017-12-31 07:58:40 UTC
For bugs matching the following criteria:

Status: In Progress Changed: (is less than) 2014-06-01

Reset to default assignee and clear in-progress tags.

Mail being skipped