Bug 141655

Summary: [sio] [patch] Serial Console failure on Dell servers
Product: Base System Reporter: lordsith49
Component: kernAssignee: freebsd-bugs (Nobody) <bugs>
Status: Open ---    
Severity: Affects Only Me    
Priority: Normal    
Version: Unspecified   
Hardware: Any   
OS: Any   
Attachments:
Description Flags
file.diff none

Description lordsith49 2009-12-15 20:50:01 UTC
Tty/login access on the serial console of Dell models 2950 and R710 stops working immediately after a single login session over the console. Sending a <ctrl-d> seems to temporarily resolve the issue long enough to log in, but the issue will immediately return once the session is ended.

Fix: I found this on the Internet and I tried it. It worked in our lab:
How-To-Repeat: Configure a Dell 2950 or R710 with FreeBSD 7.2 for serial console using the Handbook instructions.
Reboot the server.
Log in using the serial console.
Log out.
The serial console will stop responding until you hit <ctrl-d>.
Comment 1 astrelkov 2010-05-27 10:26:30 UTC
Hi!
I have situation like this on Dell R410 and Dell R510 servers.

Configure a Dell R410 or R510 with FreeBSD 7.3 for serial console using the Handbook instructions.
Reboot the server.
Log in using the serial console.
Log out.
The serial console will stop responding.
But if you try to login "in blind", you will. You could see your login on server, but console will be "blind".
After resetting getty on ttyd0 by HUP you could login only once. After that situation repeats.

This patch repair situation.

-- 
?????? ????? Alexey Strelkov

Autonomous Nonprofit Organization
"Regional Network Information Center" (RU-CENTER)
Comment 2 James Kelly 2010-06-07 18:02:49 UTC
Hi all.  I can confirm adding the delay does indeed address this
problem on a Dell PowerEdge 1950.  I tested it against FreeBSD 6.4 and
7.3, works like a charm!  Build-test only against 6.1-6.3 and 7-stable
also worked.

HTH!

-- 
James.
Comment 3 Eitan Adler freebsd_committer freebsd_triage 2017-12-31 07:59:46 UTC
For bugs matching the following criteria:

Status: In Progress Changed: (is less than) 2014-06-01

Reset to default assignee and clear in-progress tags.

Mail being skipped