Bug 141780

Summary: gdb in base inadequate for devel/anjuta; devel/gdb6 required
Product: Ports & Packages Reporter: vaibhav.gavane
Component: Individual Port(s)Assignee: freebsd-gnome mailing list <gnome>
Status: Closed FIXED    
Severity: Affects Only Me    
Priority: Normal    
Version: Latest   
Hardware: Any   
OS: Any   

Description vaibhav.gavane 2009-12-19 17:40:03 UTC
Anjuta assumes certain capabilities of gdb (such as the inferior-tty-set MI command), and the one that is included in the base system of FreeBSD does not support them.

Fix: 

Install devel/gdb6.

Patch plugins/gdb/debugger.c to make #define GDB_PATH "gdb66".
How-To-Repeat: When a program is debugged using Anjuta, console I/O does not work in the Debug Terminal.

The error "Undefined MI command: inferior-tty-set" can be seen in the Debugger Log.
Comment 1 Edwin Groothuis freebsd_committer 2009-12-19 17:40:13 UTC
Responsible Changed
From-To: freebsd-ports-bugs->gnome

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 2 Joe Marcus Clarke freebsd_committer 2009-12-19 20:23:43 UTC
State Changed
From-To: open->closed

Fixed, thanks!
Comment 3 dfilter service freebsd_committer 2009-12-19 20:23:49 UTC
marcus      2009-12-19 20:23:35 UTC

  FreeBSD ports repository

  Modified files:
    devel/anjuta         Makefile 
  Added files:
    devel/anjuta/files   patch-plugins_gdb_debugger.c 
  Log:
  Use the gdb6 from ports to satisfy the gdb requirements of Anjuta.
  
  PR:             141780
  
  Revision  Changes    Path
  1.81      +3 -1      ports/devel/anjuta/Makefile
  1.1       +11 -0     ports/devel/anjuta/files/patch-plugins_gdb_debugger.c (new)
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"