Bug 158653

Summary: installing PC-BSD 9 Current with legacy USB Keyboard doesnt work
Product: Base System Reporter: Marcus <marcus>
Component: i386Assignee: freebsd-i386 (Nobody) <i386>
Status: Open ---    
Severity: Affects Only Me    
Priority: Normal    
Version: Unspecified   
Hardware: Any   
OS: Any   

Description Marcus 2011-07-05 02:20:09 UTC
Hi!

 Im familiar with Linux an Windows. Had installed FreeBSD in a Virtualbox without problems and wanted to install PC-BSD on my PC.

 I downloaded FreeBSD 9 Current 20110701 i386 CD. I use an Trust USB-Keyboard with URL http://trust.com/products/product.aspx?artnr=14842 (14967).
 The discs boot fine into graphical GUI on my pc. 
 When the install interface comes up, my keyboard doesnt work.
 
no keyboard. no Mouse/no trackball working

 I asked google,proof enable legacy-drivers for USB keyboards, which is in BIOS working ok.
My keyboard has no PS/2. 

 I will appreciate any answers and suggestions, if anyone could get me some light into this cloudy problem.
 My hardware is working fine otherwise, memtest ok. I have a ubuntu and a windows7/xp install, works fine.

 Thanks!

Fix: 

starting windows7 and ubuntu 11.04 the keyboard is working normal also with integrated trackball, no idea what todo with pcbsd

searchengine results here:
http://forums.pcbsd.org/showthread.php?t=13246&highlight=legacy+keyboard
(solution bios update has been checked)

it looks like i have the latest bios 1.7j:
http://www.ecs.com.tw/ECSWebSite/Product/Product_Detail.aspx?CategoryID=1&DetailID=327&DetailName=Feature&MenuID=24&LanID=0

or:
http://www.ecs.com.tw/ECSWebSite/Product/Product_Detail.aspx?CategoryID=1&DetailID=63&DetailName=Feature&MenuID=24&LanID=4

another keyboard link in german:
http://www.winsupportforum.de/forum/windows-xp-allgemein/7485-trust-usb-funk-tastatur-geht-nicht-unter-xp.html

is there a solution, any idea?
How-To-Repeat: on every restart bios is working ok with legacy usb setup, but then later after cd-boot there is no function
Comment 1 Eitan Adler freebsd_committer freebsd_triage 2017-12-31 08:01:08 UTC
For bugs matching the following criteria:

Status: In Progress Changed: (is less than) 2014-06-01

Reset to default assignee and clear in-progress tags.

Mail being skipped