Bug 161719

Summary: [request] Support for Realtek 5209 SD card reader
Product: Base System Reporter: Sebastian Chmielewski <chmiels>
Component: kernAssignee: freebsd-bugs mailing list <bugs>
Status: Closed DUPLICATE    
Severity: Affects Only Me CC: ae, arrowd, greg
Priority: Normal    
Version: 1.0-CURRENT   
Hardware: Any   
OS: Any   
See Also: https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=204521

Description Sebastian Chmielewski 2011-10-16 18:50:09 UTC
Lenovo L420 has builtin SD card reader Realtek 5209. There is a driver for it made by Realtek.com available at:

http://www.realtek.com.tw/downloads/downloadsView.aspx?Langid=1&PNid=15&PFid=25&Level=4&Conn=3&DownTypeID=3&GetDown=false

Device is identified by:

none1@pci0:4:0:0:       class=0xff0000 card=0x21dd17aa chip=0x520910ec rev=0x01 hdr=0x00
    vendor     = 'Realtek Semiconductor Co., Ltd.'
Comment 1 Mark Linimon freebsd_committer freebsd_triage 2011-10-17 00:06:51 UTC
State Changed
From-To: open->suspended

Mark suspended awaiting someone to do the porting work.
Comment 2 stsp 2012-11-29 23:48:15 UTC
OpenBSD now has a driver for this chip:
http://article.gmane.org/gmane.os.openbsd.cvs/116460
Comment 3 Greg V 2016-01-01 11:21:01 UTC
See bug #204521 for a porting request for OpenBSD's rtsx(4).
Comment 4 Eitan Adler freebsd_committer freebsd_triage 2018-05-20 23:53:03 UTC
For bugs matching the following conditions:
- Status == In Progress
- Assignee == "bugs@FreeBSD.org"
- Last Modified Year <= 2017

Do
- Set Status to "Open"
Comment 5 Gleb Popov freebsd_committer 2019-07-03 10:07:22 UTC

*** This bug has been marked as a duplicate of bug 204521 ***