Bug 167441

Summary: editors/libreoffice - Unable to print
Product: Ports & Packages Reporter: Peter Jeremy <peterjeremy>
Component: Individual Port(s)Assignee: FreeBSD Office Team <office>
Status: Closed FIXED    
Severity: Affects Only Me    
Priority: Normal    
Version: Latest   
Hardware: Any   
OS: Any   

Description Peter Jeremy 2012-04-30 07:00:26 UTC
	By default, LibreOffice has no printers available.  According to the
	Help, printers should be installed using spadmin (this is similar to
	OpenOffice.org) but when I start it, I get a popup window stating "No
	printers can be installed because the file system is read-only."  This
	error message is obviously wrong because I don't have any read-only
	filesystems.

	After spending some time poring over kdump output and the source code,
	I've ascertained that the problem is that the LibreOffice port doesn't
	install any driver (PPD) files - it doesn't even create the relevant
	directory.

	After looking through the output of "configure --help" and the port
	Makefiles, this appears to be a bug in the port.  Tracking down this
	bug was made unnecessarily hard due the erroneous error message.

Fix: 

The immediate bug is "--without-ppds" in the port Makefile.  I'm
	not sure if further changes (eg fetching driver files) is necessary.
How-To-Repeat: 	Install LO.
	Run /usr/local/lib/libreoffice/program/spadmin
Comment 1 Edwin Groothuis freebsd_committer 2012-04-30 07:00:44 UTC
Responsible Changed
From-To: freebsd-ports-bugs->office

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 2 Baptiste Daroussin freebsd_committer 2012-05-19 00:54:45 UTC
Did you try rebuilding removing the --without-ppds as you propose? and
can you confirm
that it fixes the problem for you?

regards,
Bapt
Comment 3 Peter Jeremy 2012-05-27 04:40:59 UTC
On 2012-May-18 23:54:45 +0000, Baptiste Daroussin <bapt@freebsd.org> wrote:
>Did you try rebuilding removing the --without-ppds as you propose? and
>can you confirm that it fixes the problem for you?


Sorry for the delay.  If I remove the --without-ppds option and
rebuild libreoffice, then printing does work for me.  Caveats:
- Only a generic PPD is installed, you need to manually install a
  PPD for your printer.  This wasn't an issue for me because OOo
  doesn't come with a suitable PPD either.
- spadmin appears to do nothing for several minutes on the first
  interaction after starting.  Once this timeout has passed, it
  behaves normally.
- Starting to print is extremely slow.

I suspect the latter two points may be related to it trying to connect
to an ipp server and timing out (even when CUPS is disabled in spadmin).

-- 
Peter Jeremy
Comment 4 g.s 2013-02-19 12:58:02 UTC
Hello,

I just tried to upgrade to LibreOffice 3.6.5_2 and this problem showed
up again. I'm not running CUPS, my "make config" options for LibreOffice
are GTK2, MERGELIBS and SVG, nothing else.
It compiled and installed without any problems, but it tells me there
were no printers available and I cannot even print to a file, I don't
get any error message for printing to a file, I just don't get that
file. When I truss the LibreOffice start, there are no CUPS strings
showing up. I also tried adding --with-ppds to the Makefile in the no
CUPS part, but that didn't change anything.
/usr/local/lib/libreoffice/share/psprint/driver/ does exist and it
contains SGENPRT.PS and SGENT42.PS, a truss -f however, does not show
access to this directory. I then tried compiling with CUPS support and
with ppds and - BINGO, then it works. I don't know what CUPS is required
for, but for some reason LibreOffice doesn't want to print without it.
Comment 5 G. Paul Ziemba 2013-12-11 00:25:25 UTC
Experiencing same problem here. System is 9.1-STABLE r249454M,
ports are from Aug 23, 2013. editors/libreoffice 4.0.5_2.

I also think PR 167309 is a duplicate of this problem.

I use plain old lpd for printing (entries in /etc/printcap run
jobs through apsfilter).

In order to get libreoffice printing to work, I had to:

    1. enable the CUPS option
    2. edit editors/libreoffice/Makefile a la:

    --- Makefile.orig       2013-08-22 13:44:37.000000000 -0700
    +++ Makefile    2013-12-09 16:30:43.000000000 -0800
    @@ -188,7 +188,8 @@
     
     .if ${PORT_OPTIONS:MCUPS}
     LIB_DEPENDS+=          cups:${PORTSDIR}/print/cups-client
    -CONFIGURE_ARGS+=       --enable-cups --without-ppds
    +#CONFIGURE_ARGS+=      --enable-cups --without-ppds
    +CONFIGURE_ARGS+=       --enable-cups
     .else
     CONFIGURE_ARGS+=       --disable-cups
     .endif

If I did not enable CUPS for the port, or if I left "--without-ppds"
active, libreoffice would complain about not finding a default
printer and spadmin would complain about a read-only filesystem.


-- 
G. Paul Ziemba
FreeBSD unix:
 4:11PM  up 9 days, 19:14, 11 users, load averages: 1.62, 1.69, 1.60
Comment 6 dfilter service freebsd_committer 2014-02-26 17:27:58 UTC
Author: jkim
Date: Wed Feb 26 17:27:51 2014
New Revision: 346218
URL: http://svnweb.freebsd.org/changeset/ports/346218
QAT: https://qat.redports.org/buildarchive/r346218/

Log:
  - Unconditionally install generic PPD files. [1]
  - Update configure options and remove defunct ones.
  
  PR:		ports/167309, ports/167441 [1]

Modified:
  head/editors/libreoffice/Makefile

Modified: head/editors/libreoffice/Makefile
==============================================================================
--- head/editors/libreoffice/Makefile	Wed Feb 26 17:24:35 2014	(r346217)
+++ head/editors/libreoffice/Makefile	Wed Feb 26 17:27:51 2014	(r346218)
@@ -2,7 +2,7 @@
 
 .include "${.CURDIR}/Makefile.common"
 
-PORTREVISION=	0
+PORTREVISION=	1
 
 COMMENT=	Full integrated office productivity suite
 
@@ -101,7 +101,6 @@ CONFIGURE_ARGS+=	--disable-dependency-tr
 			--with-os-version=${OSVERSION} \
 			--with-parallelism=${MAKE_JOBS_NUMBER} \
 			--with-solver-and-workdir-root=${WRKDIR} \
-			--with-unix-wrapper="libreoffice" \
 			--with-vendor="FreeBSD ports ${PKGVERSION}"
 
 CONFIGURE_ARGS+=	--disable-epm \
@@ -111,7 +110,6 @@ CONFIGURE_ARGS+=	--disable-epm \
 			--disable-kdeab \
 			--disable-linkoo \
 			--disable-mergelibs \
-			--disable-zenity \
 			--enable-cairo-canvas \
 			--enable-graphite \
 			--enable-python=system \
@@ -156,14 +154,13 @@ CONFIGURE_ARGS+=	--disable-epm \
 			--with-system-orcus \
 			--with-system-poppler \
 			--with-system-redland \
-			--with-system-stdlibs \
 			--with-system-ucpp \
 			--with-system-vigra \
 			--with-system-zlib \
 			--without-afms \
 			--without-fonts \
 			--without-myspell-dicts \
-			--without-system-mozilla
+			--without-system-npapi-headers
 
 OPTIONS_DEFINE=	CUPS DEBUG GNOME GTK2 GTK3 JAVA KDE4 MMEDIA PGSQL SDK \
 		SYSTRAY TEST VERBOSE WEBDAV
@@ -182,7 +179,7 @@ WEBDAV_DESC=	Enable webdav protocol
 
 .if ${PORT_OPTIONS:MCUPS}
 LIB_DEPENDS+=		libcups.so:${PORTSDIR}/print/cups-client
-CONFIGURE_ARGS+=	--enable-cups --without-ppds
+CONFIGURE_ARGS+=	--enable-cups
 .else
 CONFIGURE_ARGS+=	--disable-cups
 .endif
@@ -264,8 +261,8 @@ JAVA_VERSION=	1.6
 BUILD_DEPENDS+=	ant:${PORTSDIR}/devel/apache-ant \
 		${JAVAJARDIR}/junit.jar:${PORTSDIR}/java/junit
 
-CONFIGURE_ARGS+=	--enable-ext-report-builder \
-			--enable-ext-wiki-publisher \
+CONFIGURE_ARGS+=	--enable-ext-wiki-publisher \
+			--enable-report-builder \
 			--enable-scripting-beanshell \
 			--enable-scripting-javascript \
 			--with-ant-home=${LOCALBASE}/share/java/apache-ant/ \
_______________________________________________
svn-ports-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/svn-ports-all
To unsubscribe, send any mail to "svn-ports-all-unsubscribe@freebsd.org"
Comment 7 Jung-uk Kim freebsd_committer 2014-02-26 17:45:20 UTC
State Changed
From-To: open->closed

It should be fixed with r346218.  Thanks!