Bug 168717

Summary: editors/libreoffice: does not compile
Product: Ports & Packages Reporter: O. Hartmann <ohartmann>
Component: Individual Port(s)Assignee: FreeBSD Office Team <office>
Status: Closed FIXED    
Severity: Affects Only Me    
Priority: Normal    
Version: Latest   
Hardware: Any   
OS: Any   
Attachments:
Description Flags
Makefile.diff none

Description O. Hartmann 2012-06-05 16:20:10 UTC
Port editors/libreoffice doesn't compile. Using CLANG, the ports fail in several stages of compiling submodules. Repeatedly first in "vcl", then in "framework", then in "sfx2" and finally in "tail_build". The fail is always the same, independent from chosen configuration options.

While the failing submodules "vcl" through "sfx2" can be managed and repaired by follwoing the instructions given, the port fails compiling in module "tail_build":

[ build RES ] scen-US
R=/usr/ports/editors/libreoffice/work && S=$R/libreoffice-core-3.5.2.2 && O=$S/solver/unxfbsd.pro && W=$S/workdir/unxfbsd.pro &&  mkdir -p $W/ResTarget/ $O/bin $W/ResTarget/ && RESPONSEFILE=`mktemp -t gbuild.XXXXXX` && echo "-r -p -lgen-US -fs=$W/ResTarget/scen-US.res -lip= -lip= -lip=$S/default_images/sc/imglst -lip= -lip= -lip=$S/default_images/sc/res -lip=$S/default_images/sc -lip=$S/default_images/res/en-US -lip=$S/default_images/res -subMODULE=$S/default_images/ -subGLOBALRES=$S/default_images/res -oil=$W/ResTarget/ $W/SrsTarget/sc/res.srs" > ${RESPONSEFILE} && LD_LIBRARY_PATH="$O/lib" SOLARBINDIR=$O/bin $O/bin/rsc @${RESPONSEFILE} && rm -f ${RESPONSEFILE}
R=/usr/ports/editors/libreoffice/work && S=$R/libreoffice-core-3.5.2.2 && O=$S/solver/unxfbsd.pro && W=$S/workdir/unxfbsd.pro &&  mkdir -p $O/bin/ &&  cp -f $W/ResTarget/scen-US.res $O/bin/scen-US.res && touch -r $W/ResTarget/scen-US.res $O/bin/scen-US.res && mkdir -p $O/res/img/ &&  cp -f $W/ResTarget//scen-US.ilst $O/res/img/scen-US.ilst && touch -r $W/ResTarget//scen-US.ilst $O/res/img/scen-US.ilst
R=/usr/ports/editors/libreoffice/work && S=$R/libreoffice-core-3.5.2.2 && O=$S/solver/unxfbsd.pro && W=$S/workdir/unxfbsd.pro &&  mkdir -p $W/AllLangRes/ && touch $W/AllLangRes/sc
gmake: *** No rule to make target `/usr/ports/editors/libreoffice/work/libreoffice-core-3.5.2.2/workdir/unxfbsd.pro/CxxObject/vbahelper/source/vbahelper/vbashaperange.o', needed by `/usr/ports/editors/libreoffice/work/libreoffice-core-3.5.2.2/workdir/unxfbsd.pro/LinkTarget/Library/libvbahelperlo.so'.  Stop.
[root@telesto /usr/ports/editors/libreoffice/work/libreoffice-core-3.5.2.2/tail_build]#


While exiting and restart compiling with simply "make" in the ports folder or via "portmaster -C editors/libreoffice", the failure is sticky to "tail_build" or, in some rare cases, the build starts to loop forever - on a fast box for more than 48 hours!

How-To-Repeat: On a up to date box with up to date ports tree try compiling editors/libreoffice.
Comment 1 Edwin Groothuis freebsd_committer 2012-06-05 21:41:58 UTC
Responsible Changed
From-To: freebsd-ports-bugs->office

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 2 hiroto.kagotani 2012-06-08 16:27:10 UTC
Could you test the attached patch?
I can solve the problem using the patch, but someone not.

-- 
Hiroto Kagotani
<hiroto.kagotani@gmail.com>
Comment 3 jb.1234abcd 2012-06-15 06:23:27 UTC
[root@localhost /usr/ports/editors/libreoffice]# make
...
Making:    guesslang.lib
Making:    libguesslanglo.so
lingucomponent deliver
Module 'lingucomponent' delivered successfully. 12 files copied, 2 files unchang
ed

-----------------------------------------------------------------------
        Oh dear - something failed during the build - sorry !
  For more help with debugging build errors, please see the section in:
            http://wiki.documentfoundation.org/Development

  internal build errors:

ERROR: error 65280 occurred while making /usr/ports/editors/libreoffice/work/lib
reoffice-core-3.5.2.2/vcl/prj

 it seems that the error is inside 'vcl', please re-run build
 inside this module to isolate the error and/or test your fix:
-----------------------------------------------------------------------

/usr/local/bin/bash
cd /usr/ports/editors/libreoffice/work/libreoffice-core-3.5.2.2
source ./Env.Host.sh
cd vcl
gmake clean # optional
gmake -r

when the problem is isolated and fixed exit and re-run 'make' from the top-level
gmake[1]: *** [build] Error 1
gmake[1]: Leaving directory `/usr/ports/editors/libreoffice/work/libreoffice-cor
e-3.5.2.2'
gmake: *** [source-env-and-recurse] Error 2
*** Error code 1

Stop in /usr/ports/editors/libreoffice.
*** Error code 1

Stop in /usr/ports/editors/libreoffice.
[root@localhost /usr/ports/editors/libreoffice]#
Comment 4 jb.1234abcd 2012-06-15 17:03:31 UTC
/usr/local/bin/bash
cd /usr/ports/editors/libreoffice/work/libreoffice-core-3.5.2.2
source ./Env.Host.sh
cd vcl
gmake clean # optional
gmake -r

when the problem is isolated and fixed exit and re-run 'make' from the top-level
gmake[1]: *** [build] Error 1
gmake[1]: Leaving directory
`/usr/ports/editors/libreoffice/work/libreoffice-core-3.5.2.2'
gmake: *** [source-env-and-recurse] Error 2
*** Error code 1

Stop in /usr/ports/editors/libreoffice.
*** Error code 1

OK.
I did as instructed above (up to 'gmake -r', and I got a clean compile.
...
[ build MOD ] vcl
R=/usr/ports/editors/libreoffice/work && S=$R/libreoffice-core-3.5.2.2
&& O=$S/solver/unxfbsdi.pro && W=$S/workdir/unxfbsdi.pro &&  mkdir -p
$W/Module/ && touch $W/Module/vcl
[ build ALL ] top level modules: bootstrap src.downloaded vcl
[ build ALL ] loaded modules: vcl

[ build CHK ] vcl
R=/usr/ports/editors/libreoffice/work && S=$R/libreoffice-core-3.5.2.2
&& O=$S/solver/unxfbsdi.pro && W=$S/workdir/unxfbsdi.pro &&  mkdir -p
$W/Module/check/ && touch $W/Module/check/vcl
[ build CHK ] loaded modules: vcl

[root@localhost
/usr/ports/editors/libreoffice/work/libreoffice-core-3.5.2.2/vcl]#

It seems to be a clean compile. So, what is the problem ?
If I do it all  ('make') from the top level (as I have done it many
times), it fails as documented here.
What next ?
Comment 5 jb.1234abcd 2012-06-15 18:33:01 UTC
I continued the previous "vlc error" step with 'make' in higher level dir:
[root@localhost /usr/ports/editors/libreoffice]# make
...
cppcanvas deliver
Module 'cppcanvas' delivered successfully. 0 files copied, 0 files unchanged

-----------------------------------------------------------------------
        Oh dear - something failed during the build - sorry !
  For more help with debugging build errors, please see the section in:
            http://wiki.documentfoundation.org/Development

  internal build errors:

ERROR: error 65280 occurred while making /usr/ports/editors/libreoffice/work/lib
reoffice-core-3.5.2.2/framework/prj

 it seems that the error is inside 'framework', please re-run build
 inside this module to isolate the error and/or test your fix:
-----------------------------------------------------------------------

/usr/local/bin/bash
cd /usr/ports/editors/libreoffice/work/libreoffice-core-3.5.2.2
source ./Env.Host.sh
cd framework
gmake clean # optional
gmake -r

when the problem is isolated and fixed exit and re-run 'make' from the top-level
gmake[1]: *** [build] Error 1
gmake[1]: Leaving directory `/usr/ports/editors/libreoffice/work/libreoffice-cor
e-3.5.2.2'
gmake: *** [source-env-and-recurse] Error 2
*** Error code 1

Stop in /usr/ports/editors/libreoffice.
*** Error code 1

Stop in /usr/ports/editors/libreoffice.
[root@localhost /usr/ports/editors/libreoffice]#

So, it continued compilations, and this time it died inside 'framework'.
I followed up according to instructions and it seems I got a clean compile
(as previously inside 'vcl'):
...
[ build ALL ] top level modules: bootstrap src.downloaded framework
[ build ALL ] loaded modules: framework

[ build CHK ] framework
R=/usr/ports/editors/libreoffice/work && S=$R/libreoffice-core-3.5.2.2
&& O=$S/solver/unxfbsdi.pro && W=$S/workdir/unxfbsdi.pro &&  mkdir -p
$W/Module/check/ && touch $W/Module/check/framework
[ build CHK ] loaded modules: framework

[root@localhost
/usr/ports/editors/libreoffice/work/libreoffice-core-3.5.2.2/framework]#

So I continu with 'make' in top-level dir.
jb
Comment 6 jb.1234abcd 2012-06-15 19:04:13 UTC
Next similar error inside 'sfx2':
[ build DEP ] SRS:sfx/res
[ build SRS ] sfx/res
[ build RES ] sfxen-US
gmake[2]: *** No rule to make target `/usr/ports/editors/libreoffice/work/libreo
ffice-core-3.5.2.2/workdir/unxfbsdi.pro/CxxObject/sfx2/source/doc/guisaveas.o',
needed by `/usr/ports/editors/libreoffice/work/libreoffice-core-3.5.2.2/workdir/
unxfbsdi.pro/LinkTarget/Library/libsfxlo.so'.  Stop.
dmake:  Error code 2, while making 'all'

-----------------------------------------------------------------------
        Oh dear - something failed during the build - sorry !
  For more help with debugging build errors, please see the section in:
            http://wiki.documentfoundation.org/Development

  internal build errors:

ERROR: error 65280 occurred while making /usr/ports/editors/libreoffice/work/lib
reoffice-core-3.5.2.2/sfx2/prj

 it seems that the error is inside 'sfx2', please re-run build
...

I followed instructions and compilation inside 'sfx2' seems to be clean:
...
[ build CHK ] sfx2
R=/usr/ports/editors/libreoffice/work && S=$R/libreoffice-core-3.5.2.2
&& O=$S/solver/unxfbsdi.pro && W=$S/workdir/unxfbsdi.pro &&  mkdir -p
$W/Module/check/ && touch $W/Module/check/sfx2
[ build CHK ] loaded modules: sfx2

[root@localhost
/usr/ports/editors/libreoffice/work/libreoffice-core-3.5.2.2/sfx2]#

So I continued with 'make' from top-level dir.
jb
Comment 7 jb.1234abcd 2012-06-16 11:56:43 UTC
Next I continued in top-level dir.
This time it died inside 'tail_build':
...
gmake[2]: *** No rule to make target `/usr/ports/editors/libreoffice/work/libreo
ffice-core-3.5.2.2/workdir/unxfbsdi.pro/CxxObject/filter/source/config/cache/bas
econtainer.o', needed by `/usr/ports/editors/libreoffice/work/libreoffice-core-3
.5.2.2/workdir/unxfbsdi.pro/LinkTarget/Library/libfilterconfiglo.so'.  Stop.
gmake[2]: *** Waiting for unfinished jobs....
clang++: warning: argument unused during compilation: '-rpath=/usr/lib:/usr/loca
l/lib'
dmake:  Error code 2, while making 'all'

-----------------------------------------------------------------------
        Oh dear - something failed during the build - sorry !
  For more help with debugging build errors, please see the section in:
            http://wiki.documentfoundation.org/Development

  internal build errors:

ERROR: error 65280 occurred while making /usr/ports/editors/libreoffice/work/lib
reoffice-core-3.5.2.2/tail_build/prj

 it seems that the error is inside 'tail_build', please re-run build
 inside this module to isolate the error and/or test your fix:
-----------------------------------------------------------------------

/usr/local/bin/bash
cd /usr/ports/editors/libreoffice/work/libreoffice-core-3.5.2.2
source ./Env.Host.sh
cd tail_build
gmake clean # optional
gmake -r

So, I followed with compilation inside 'tail_build'.
Unfortunately, unlike previous inside module builds, it died:
...
[root@localhost /usr/ports/editors/libreoffice/work/libreoffice-core-3.5.2.2/tai
l_build]# gmake -r
...
[ build LNK ] CppunitTest/libtest_lotuswordpro_test_lotuswordpro.so
R=/usr/ports/editors/libreoffice/work && S=$R/libreoffice-core-3.5.2.2 && O=$S/s
olver/unxfbsdi.pro && W=$S/workdir/unxfbsdi.pro &&  mkdir -p $W/LinkTarget/Cppun
itTest/ && clang++ -shared -Wl,-z,noexecstack   -Wl,-rpath-link,/lib:/usr/lib -W
l,-z,combreloc   -L$S/solenv/unxfbsdi/lib -L$O/lib -L$S/solenv/unxfbsdi/lib -L/u
sr/local/lib  -Wl,--hash-style=sysv  -Wl,--dynamic-list-cpp-new -Wl,--dynamic-li
st-cpp-typeinfo -Wl,-Bsymbolic-functions  -Wl,--strip-all   $W/CxxObject/lotuswo
rdpro/qa/cppunit/test_lotuswordpro.o     -Wl,--start-group  -Wl,--end-group  -L/
usr/local/lib -lcppunit    -lcomphelpgcc3 -luno_cppu -luno_cppuhelpergcc3 -luno_
sal -ltest -lunotest -lvcllo -o $W/LinkTarget/CppunitTest/libtest_lotuswordpro_t
est_lotuswordpro.so
TEMPFILE=/tmp/gbuild.XXXXXX.PzdEQBnY &&  mv ${TEMPFILE} /usr/ports/editors/libre
office/work/libreoffice-core-3.5.2.2/workdir/unxfbsdi.pro/LinkTarget/CppunitTest
/libtest_lotuswordpro_test_lotuswordpro.so.objectlist
[ build CUT ] lotuswordpro_test_lotuswordpro
R=/usr/ports/editors/libreoffice/work && S=$R/libreoffice-core-3.5.2.2 && O=$S/s
olver/unxfbsdi.pro && W=$S/workdir/unxfbsdi.pro &&  mkdir -p $W/CppunitTest/ &&
(LD_LIBRARY_PATH="$O/lib":$O/lib/sqlite   DBGSV_ERROR_OUT=shell STAR_RESOURCEPAT
H=$O/bin/   $O/bin/cppunit/cppunittester $W/LinkTarget/CppunitTest/libtest_lotus
wordpro_test_lotuswordpro.so --headless --protector unoexceptionprotector.so uno
exceptionprotector "-env:CONFIGURATION_LAYERS=xcsxcu:file://$O/xml/registry"   "
-env:UNO_TYPES= file://$O/bin/udkapi.rdb  file://$O/bin/types.rdb"  "-env:UNO_SE
RVICES=file://$O/xml/ure/services.rdb  file://$O/xml/component/lotuswordpro/util
/lwpfilter.component  file://$O/xml/configmgr.component  file://$O/xml/ucb1.comp
onent  file://$O/xml/ucpfile1.component"   -env:URE_INTERNAL_LIB_DIR=file://$O/l
ib  -env:LO_LIB_DIR=file://$O/lib > $W/CppunitTest/lotuswordpro_test_lotuswordpr
o.test.log 2>&1 || (cat $W/CppunitTest/lotuswordpro_test_lotuswordpro.test.log &
& echo; echo "Error: a unit test failed, please do one of:"; echo; echo "export
DEBUGCPPUNIT=TRUE            # for exception catching"; echo "export GDBCPPUNITT
RACE=\"gdb --args\" # for interactive debugging"; echo "export VALGRIND=memcheck
            # for memory checking" ; echo "and retry." && false))
Segmentation fault (core dumped)
File tested,Test Result,Execution Time (ms)
file:///usr/ports/editors/libreoffice/work/libreoffice-core-3.5.2.2/lotuswordpro
/qa/cppunit/data/pass/A14.lwp,Signal 11 during cups initialization called, ignor
ing cups

Error: a unit test failed, please do one of:

export DEBUGCPPUNIT=TRUE            # for exception catching
export GDBCPPUNITTRACE="gdb --args" # for interactive debugging
export VALGRIND=memcheck            # for memory checking
and retry.
gmake: *** [/usr/ports/editors/libreoffice/work/libreoffice-core-3.5.2.2/workdir
/unxfbsdi.pro/CppunitTest/lotuswordpro_test_lotuswordpro.test] Error 1
[root@localhost /usr/ports/editors/libreoffice/work/libreoffice-core-3.5.2.2/tai
l_build]#

It died with Signal 11 segmentation fault.
That's it.
jb
Comment 8 jb.1234abcd 2012-06-16 12:25:57 UTC
Next, debugging result.

[root@localhost /usr/ports/editors/libreoffice/work/libreoffice-core-3.5.2.2/tai
l_build]# export DEBUGCPPUNIT=TRUE
[root@localhost /usr/ports/editors/libreoffice/work/libreoffice-core-3.5.2.2/tai
l_build]# gmake -r
...
[ build CUT ] lotuswordpro_test_lotuswordpro
R=/usr/ports/editors/libreoffice/work && S=$R/libreoffice-core-3.5.2.2
&& O=$S/solver/unxfbsdi.pro && W=$S/workdir/unxfbsdi.pro &&  mkdir -p
$W/CppunitTest/ && (LD_LIBRARY_PATH="$O/lib":$O/lib/sqlite
DBGSV_ERROR_OUT=shell STAR_RESOURCEPATH=$O/bin/ gdb -nx
--command=$S/solenv/bin/gdbtrycatchtrace-stdout -return-child-result
--args  $O/bin/cppunit/cppunittester
$W/LinkTarget/CppunitTest/libtest_lotuswordpro_test_lotuswordpro.so
--headless --protector unoexceptionprotector.so unoexceptionprotector
"-env:CONFIGURATION_LAYERS=xcsxcu:file://$O/xml/registry"
"-env:UNO_TYPES= file://$O/bin/udkapi.rdb  file://$O/bin/types.rdb"
"-env:UNO_SERVICES=file://$O/xml/ure/services.rdb
file://$O/xml/component/lotuswordpro/util/lwpfilter.component
file://$O/xml/configmgr.component  file://$O/xml/ucb1.component
file://$O/xml/ucpfile1.component"
-env:URE_INTERNAL_LIB_DIR=file://$O/lib  -env:LO_LIB_DIR=file://$O/lib
> $W/CppunitTest/lotuswordpro_test_lotuswordpro.test.log 2>&1 || (cat
$W/CppunitTest/lotuswordpro_test_lotuswordpro.test.log && echo; echo
"Error: a unit test failed, please do one of:"; echo; echo "export
DEBUGCPPUNIT=TRUE            # for exception catching"; echo "export
GDBCPPUNITTRACE=\"gdb --args\" # for interactive debugging"; echo
"export VALGRIND=memcheck            # for memory checking" ; echo
"and retry." && false))
GNU gdb (GDB) 7.4.1 [GDB v7.4.1 for FreeBSD]
Copyright (C) 2012 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "i386-portbld-freebsd9.0".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>...
Reading symbols from
/usr/ports/editors/libreoffice/work/libreoffice-core-3.5.2.2/solver/unxfbsdi.pro/bin/cppunit/cppunittester...(no
debugging symbols found)...done.
Catchpoint 1 (throw)
Catchpoint 2 (catch)
[New LWP 101699]
[New Thread 28404300 (LWP 101699)]
[New Thread 28405200 (LWP 100757)]
File tested,Test Result,Execution Time (ms)
file:///usr/ports/editors/libreoffice/work/libreoffice-core-3.5.2.2/lotuswordpro/qa/cppunit/data/pass/A14.lwp,[New
Thread 2c544e00 (LWP 101580)]

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 28404300 (LWP 101699)]
0x28114d57 in rtl_uString_acquire () from
/usr/ports/editors/libreoffice/work/libreoffice-core-3.5.2.2/solver/unxfbsdi.pro/lib/libuno_sal.so.3
#0  0x28114d57 in rtl_uString_acquire () from
/usr/ports/editors/libreoffice/work/libreoffice-core-3.5.2.2/solver/unxfbsdi.pro/lib/libuno_sal.so.3
#1  0x00000160 in ?? ()
#2  0xbfbf9768 in ?? ()
#3  0x2c012510 in SvpSalInstance::GetDefaultPrinter() () from
/usr/ports/editors/libreoffice/work/libreoffice-core-3.5.2.2/solver/unxfbsdi.pro/lib/libvclplug_svplo.so
#4  0x28f6618e in Printer::GetDefaultPrinterName() () from
/usr/ports/editors/libreoffice/work/libreoffice-core-3.5.2.2/solver/unxfbsdi.pro/lib/libvcllo.so
#5  0x28f66b6d in Printer::Printer() () from
/usr/ports/editors/libreoffice/work/libreoffice-core-3.5.2.2/solver/unxfbsdi.pro/lib/libvcllo.so
#6  0x2c8ba0ec in LwpPageLayout::GetWidthAndHeight(double&, double&)
() from /usr/ports/editors/libreoffice/work/libreoffice-core-3.5.2.2/solver/unxfbsdi.pro/lib/liblwpftlo.so
#7  0x2c8ba804 in LwpPageLayout::RegisterStyle() () from
/usr/ports/editors/libreoffice/work/libreoffice-core-3.5.2.2/solver/unxfbsdi.pro/lib/liblwpftlo.so
#8  0x2c8a382d in LwpHeadLayout::RegisterStyle() () from
/usr/ports/editors/libreoffice/work/libreoffice-core-3.5.2.2/solver/unxfbsdi.pro/lib/liblwpftlo.so
#9  0x2c87e638 in LwpFoundry::RegisterAllLayouts() () from
/usr/ports/editors/libreoffice/work/libreoffice-core-3.5.2.2/solver/unxfbsdi.pro/lib/liblwpftlo.so
#10 0x2c86b855 in LwpDocument::RegisterLayoutStyles() () from
/usr/ports/editors/libreoffice/work/libreoffice-core-3.5.2.2/solver/unxfbsdi.pro/lib/liblwpftlo.so
#11 0x2c86b507 in LwpDocument::RegisterStyle() () from
/usr/ports/editors/libreoffice/work/libreoffice-core-3.5.2.2/solver/unxfbsdi.pro/lib/liblwpftlo.so
#12 0x2c86d60e in LwpDocSock::RegisterStyle() () from
/usr/ports/editors/libreoffice/work/libreoffice-core-3.5.2.2/solver/unxfbsdi.pro/lib/liblwpftlo.so
#13 0x2c86b54f in LwpDocument::RegisterStyle() () from
/usr/ports/editors/libreoffice/work/libreoffice-core-3.5.2.2/solver/unxfbsdi.pro/lib/liblwpftlo.so
#14 0x2c85a388 in Lwp9Reader::ParseDocument() () from
/usr/ports/editors/libreoffice/work/libreoffice-core-3.5.2.2/solver/unxfbsdi.pro/lib/liblwpftlo.so
#15 0x2c85a11c in Lwp9Reader::Read() () from
/usr/ports/editors/libreoffice/work/libreoffice-core-3.5.2.2/solver/unxfbsdi.pro/lib/liblwpftlo.so
#16 0x2c875750 in ReadWordproFile(SvStream&,
com::sun::star::uno::Reference<com::sun::star::xml::sax::XDocumentHandler>&)
() from /usr/ports/editors/libreoffice/work/libreoffice-core-3.5.2.2/solver/unxfbsdi.pro/lib/liblwpftlo.so
#17 0x2c857b30 in
LotusWordProImportFilter::importImpl(com::sun::star::uno::Sequence<com::sun::star::beans::PropertyValue>
const&) () from
/usr/ports/editors/libreoffice/work/libreoffice-core-3.5.2.2/solver/unxfbsdi.pro/lib/liblwpftlo.so
#18 0x2c857d5b in non-virtual thunk to
LotusWordProImportFilter::filter(com::sun::star::uno::Sequence<com::sun::star::beans::PropertyValue>
const&) () from
/usr/ports/editors/libreoffice/work/libreoffice-core-3.5.2.2/solver/unxfbsdi.pro/lib/liblwpftlo.so
#19 0x283ee27d in ?? () from
/usr/ports/editors/libreoffice/work/libreoffice-core-3.5.2.2/workdir/unxfbsdi.pro/LinkTarget/CppunitTest/libtest_lotuswordpro_test_lotuswordpro.so
#20 0x28c46208 in test::FiltersTest::recursiveScan(rtl::OUString
const&, rtl::OUString const&, rtl::OUString const&,
test::filterStatus) () from
/usr/ports/editors/libreoffice/work/libreoffice-core-3.5.2.2/solver/unxfbsdi.pro/lib/libunotest.so
#21 0x28c46d15 in test::FiltersTest::testDir(rtl::OUString const&,
rtl::OUString const&, rtl::OUString const&) () from
/usr/ports/editors/libreoffice/work/libreoffice-core-3.5.2.2/solver/unxfbsdi.pro/lib/libunotest.so
#22 0x283edbc0 in ?? () from
/usr/ports/editors/libreoffice/work/libreoffice-core-3.5.2.2/workdir/unxfbsdi.pro/LinkTarget/CppunitTest/libtest_lotuswordpro_test_lotuswordpro.so
#23 0x283edcdc in ?? () from
/usr/ports/editors/libreoffice/work/libreoffice-core-3.5.2.2/workdir/unxfbsdi.pro/LinkTarget/CppunitTest/libtest_lotuswordpro_test_lotuswordpro.so
#24 0x280c0927 in CppUnit::TestCaseMethodFunctor::operator()() const
() from /usr/local/lib/libcppunit-1.12.so.1
#25 0x283b1517 in ?? () from
/usr/ports/editors/libreoffice/work/libreoffice-core-3.5.2.2/solver/unxfbsdi.pro/lib/unoexceptionprotector.so
#26 0x280ba9f3 in
CppUnit::ProtectorChain::ProtectFunctor::operator()() const () from
/usr/local/lib/libcppunit-1.12.so.1
#27 0x280abf5a in CppUnit::DefaultProtector::protect(CppUnit::Functor
const&, CppUnit::ProtectorContext const&) () from
/usr/local/lib/libcppunit-1.12.so.1
#28 0x280ba9f3 in
CppUnit::ProtectorChain::ProtectFunctor::operator()() const () from
/usr/local/lib/libcppunit-1.12.so.1
#29 0x280ba6e7 in CppUnit::ProtectorChain::protect(CppUnit::Functor
const&, CppUnit::ProtectorContext const&) () from
/usr/local/lib/libcppunit-1.12.so.1
#30 0x280ca803 in CppUnit::TestResult::protect(CppUnit::Functor
const&, CppUnit::Test*, std::string const&) () from
/usr/local/lib/libcppunit-1.12.so.1
#31 0x280c033f in CppUnit::TestCase::run(CppUnit::TestResult*) () from
/usr/local/lib/libcppunit-1.12.so.1
#32 0x280c121f in
CppUnit::TestComposite::doRunChildTests(CppUnit::TestResult*) () from
/usr/local/lib/libcppunit-1.12.so.1
#33 0x280c115a in CppUnit::TestComposite::run(CppUnit::TestResult*) ()
from /usr/local/lib/libcppunit-1.12.so.1
#34 0x280c121f in
CppUnit::TestComposite::doRunChildTests(CppUnit::TestResult*) () from
/usr/local/lib/libcppunit-1.12.so.1
#35 0x280c115a in CppUnit::TestComposite::run(CppUnit::TestResult*) ()
from /usr/local/lib/libcppunit-1.12.so.1
#36 0x280cc980 in
CppUnit::TestRunner::WrappingSuite::run(CppUnit::TestResult*) () from
/usr/local/lib/libcppunit-1.12.so.1
#37 0x280ca00a in CppUnit::TestResult::runTest(CppUnit::Test*) () from
/usr/local/lib/libcppunit-1.12.so.1
#38 0x280cc730 in CppUnit::TestRunner::run(CppUnit::TestResult&,
std::string const&) () from /usr/local/lib/libcppunit-1.12.so.1
#39 0x0804aae4 in ?? ()
#40 0x0804acbe in ?? ()
#41 0x283b1854 in ?? () from
/usr/ports/editors/libreoffice/work/libreoffice-core-3.5.2.2/solver/unxfbsdi.pro/lib/unoexceptionprotector.so
#42 0x0804a75f in main ()
A debugging session is active.

	Inferior 1 [process 66008] will be killed.

Quit anyway? (y or n) [answered Y; input not from terminal]

Error: a unit test failed, please do one of:

export DEBUGCPPUNIT=TRUE            # for exception catching
export GDBCPPUNITTRACE="gdb --args" # for interactive debugging
export VALGRIND=memcheck            # for memory checking
and retry.
gmake: *** [/usr/ports/editors/libreoffice/work/libreoffice-core-3.5.2.2/workdir/unxfbsdi.pro/CppunitTest/lotuswordpro_test_lotuswordpro.test]
Error 1
[root@localhost
/usr/ports/editors/libreoffice/work/libreoffice-core-3.5.2.2/tail_build]#

jb
Comment 9 jb.1234abcd 2012-06-16 12:51:17 UTC
One more debug output attempt.

[root@localhost /usr/ports/editors/libreoffice/work/libreoffice-core-3.5.2.2/tai
l_build]# export VALGRIND=memcheck
[root@localhost /usr/ports/editors/libreoffice/work/libreoffice-core-3.5.2.2/tai
l_build]# gmake -r
...
[ build CUT ] lotuswordpro_test_lotuswordpro
R=/usr/ports/editors/libreoffice/work && S=$R/libreoffice-core-3.5.2.2 && O=$S/s
olver/unxfbsdi.pro && W=$S/workdir/unxfbsdi.pro &&  mkdir -p $W/CppunitTest/ &&
(LD_LIBRARY_PATH="$O/lib":$O/lib/sqlite G_SLICE=always-malloc GLIBCXX_FORCE_NEW=
1 DBGSV_ERROR_OUT=shell STAR_RESOURCEPATH=$O/bin/  valgrind --tool=memcheck --nu
m-callers=50 $O/bin/cppunit/cppunittester $W/LinkTarget/CppunitTest/libtest_lotu
swordpro_test_lotuswordpro.so --headless --protector unoexceptionprotector.so un
oexceptionprotector "-env:CONFIGURATION_LAYERS=xcsxcu:file://$O/xml/registry"
"-env:UNO_TYPES= file://$O/bin/udkapi.rdb  file://$O/bin/types.rdb"  "-env:UNO_S
ERVICES=file://$O/xml/ure/services.rdb  file://$O/xml/component/lotuswordpro/uti
l/lwpfilter.component  file://$O/xml/configmgr.component  file://$O/xml/ucb1.com
ponent  file://$O/xml/ucpfile1.component"   -env:URE_INTERNAL_LIB_DIR=file://$O/
lib  -env:LO_LIB_DIR=file://$O/lib > $W/CppunitTest/lotuswordpro_test_lotuswordp
ro.test.log 2>&1 || (cat $W/CppunitTest/lotuswordpro_test_lotuswordpro.test.log
&& echo; echo "Error: a unit test failed, please do one of:"; echo; echo "export
 DEBUGCPPUNIT=TRUE            # for exception catching"; echo "export GDBCPPUNIT
TRACE=\"gdb --args\" # for interactive debugging"; echo "export VALGRIND=memchec
k            # for memory checking" ; echo "and retry." && false))
Killed
==76298== Memcheck, a memory error detector
==76298== Copyright (C) 2002-2011, and GNU GPL'd, by Julian Seward et al.
... < many blank lines >
unxfbsdi.pro/lib
==76298==
==76298== Invalid read of size 4
... < many blank lines >
==76298==  overflow in your program's main thread (unlikely but
==76298==  possible), you can try to increase the size of the
==76298==  main thread stack using the --main-stacksize= flag.
==76298==
==76298== HEAP SUMMARY:
==76298==     in use at exit: 4,543,775 bytes in 119,988 blocks
==76298==   total heap usage: 169,357 allocs, 49,369 frees, 19,954,753 bytes all
ocated
==76298==
==76298== LEAK SUMMARY:
==76298==    definitely lost: 12,272 bytes in 2 blocks
==76298==    indirectly lost: 520 bytes in 2 blocks
==76298==      possibly lost: 76,540 bytes in 1,049 blocks
==76298==    still reachable: 4,454,443 bytes in 118,935 blocks
==76298==         suppressed: 0 bytes in 0 blocks
==76298== Rerun with --leak-check=full to see details of leaked memory
==76298==
==76298== For counts of detected and suppressed errors, rerun with: -v
==76298== ERROR SUMMARY: 4 errors from 4 contexts (suppressed: 0 from 0)

Error: a unit test failed, please do one of:

export DEBUGCPPUNIT=TRUE            # for exception catching
export GDBCPPUNITTRACE="gdb --args" # for interactive debugging
export VALGRIND=memcheck            # for memory checking
and retry.
gmake: *** [/usr/ports/editors/libreoffice/work/libreoffice-core-3.5.2.2/workdir
/unxfbsdi.pro/CppunitTest/lotuswordpro_test_lotuswordpro.test] Error 1
[root@localhost /usr/ports/editors/libreoffice/work/libreoffice-core-3.5.2.2/tai
l_build]#

I guess that's all I could do.
jb
Comment 10 vsjcfm 2012-06-29 17:39:49 UTC
I have a same problem on 8.3-RELEASE.
Now testing makefile patch.

Also, libreoffice builds by multiple threads regardless of MAKE_JOBS_UNSAFE
Comment 11 O. Hartmann 2012-06-29 23:31:39 UTC
Someone on the German site http://www.bsdforen.de suggested/instructed
to delete the port devel/boost-lib and sibblings before running an
another attempt to compile the port editors/libreoffice.

I deinstalled boost-lib and boost-jam which has been installed by a
couple of necessary ports (for instance, blender, strigi, povray,
visionworkbench, abiword et ceterum).

After temporaryly deleting the boost-lib-port, editors/libreoffice
compiled well on FreeBSD 10-CURRENT/amd64 with CLANG! I will check this
next week also on FreeBSD 9-STABLE/amd64 as well.

Don't forget to reinstall devel/boost-lib and devel/boost-jam (if
installed and deleted).

Regards,
oh
Comment 12 Chris Rees freebsd_committer 2012-06-30 08:50:31 UTC
State Changed
From-To: open->closed

Original problem solved-- please try removing boost.
Comment 13 vsjcfm 2012-06-30 09:19:23 UTC
Why'd you closed this pr?
Removing boost\* _is not_ a resolution, _it is_ a workaround.
I think that correct way is check and patch configure scripts for
right inclusion dirs order. Is it impossible?

By the way, what's the proper way to remove & reinstall package
_without rebuilding_? (In case of ports, not binary package.)
Comment 14 vsjcfm 2012-06-30 09:31:10 UTC
Also, patching Makefile resolved problems with "vcl", "framework" and
"sfx2" modules. But not in tail_build.
Now i'm testing workaround (removing boost).
I'll report test results a few hours later. ;)
Comment 15 Chris Rees freebsd_committer 2012-06-30 10:06:48 UTC
I know it sounds crazy and I'm sorry, but building ports is only
officially supported on a clean system.

If you don't want to remove boost, you'll need to make a package in a
jail or chroot using poudriere/Tinderbox.

Chris
Comment 16 vsjcfm 2012-06-30 10:43:23 UTC
Fortunately, i'm building libreoffice in chroot (it's a copy for
updating without breaking primary system). So i've used pkg_create. It
seems like libreoffice will build fine.
Will be CONFLICTS_BUILD added to libreoffice/Makefile?
Comment 17 vsjcfm 2012-06-30 11:35:04 UTC
libreoffice built successfully without boost installed.
Comment 18 jb.1234abcd 2012-07-01 21:25:36 UTC
$ uname -a
FreeBSD localhost.localdomain 9.0-RELEASE-p3 FreeBSD 9.0-RELEASE-p3 #0: Tue Jun
12 01:47:53 UTC 2012     root@i386-builder.daemonology.net:/usr/obj/usr/src/sys/
GENERIC  i386

# cat /var/log/portmaster.log
...
Sun Jun 10 23:43:01 CEST 2012
        Upgrade of boost-jam-1.45.0 to boost-jam-1.48.0
...
Mon Jun 11 00:07:43 CEST 2012
        Upgrade of boost-libs-1.45.0_1 to boost-libs-1.48.0
...

$ ls -d /var/db/pkg/boost-*
/var/db/pkg/boost-jam-1.48.0    /var/db/pkg/boost-libs-1.48.0

# pkg_delete /var/db/pkg/boost-*

# cd /usr/ports/editors/libreoffice
[root@localhost /usr/ports/editors/libreoffice]# make clean
===>  Cleaning for libreoffice-3.5.4
[root@localhost /usr/ports/editors/libreoffice]# make
...
=> Attempting to fetch http://ftp.rediris.es/mirror/TDF/libreoffice/src/3.5.4/li
breoffice-core-3.5.4.2.tar.xz
...
===>   libreoffice-3.5.4 depends on file: /usr/local/lib/libboost_regex.a - not
found
===>    Verifying install for /usr/local/lib/libboost_regex.a in /usr/ports/deve
l/boost-libs
...
=> Attempting to fetch http://heanet.dl.sourceforge.net/project/boost/boost/1.48
.0/boost_1_48_0.tar.bz2
boost_1_48_0.tar.bz2                          100% of   46 MB  240 kBps 00m00s
===>  Extracting for boost-libs-1.48.0
...
===>   boost-libs-1.48.0 depends on executable: bjam - not found
===>    Verifying install for bjam in /usr/ports/devel/boost-jam
===>  Extracting for boost-jam-1.48.0
...
LibreOffice build succesfully finished.
...
[root@localhost /usr/ports/editors/libreoffice]# make install
...
===>   Registering installation for libreoffice-3.5.4
[root@localhost /usr/ports/editors/libreoffice]#

NOTE:
As seen above, the boost-lib and boost-jam are required for libreoffice
compilation.
I see missing '+REQUIRED_ BY' file in their package dirs:
 /var/db/pkg/boost-libs-1.48.0/
+COMMENT        +CONTENTS       +DESC           +DISPLAY        +MTREE_DIRS
# ls /var/db/pkg/boost-jam-1.48.0/
+COMMENT        +CONTENTS       +DESC           +MTREE_DIRS

So, what was the trick with boost removal ?
If none, then what was the fix (this should be stated before closing the PR).
jb
Comment 19 Chris Rees freebsd_committer 2012-07-01 21:26:55 UTC
On 1 July 2012 21:25, J B <jb.1234abcd@gmail.com> wrote:
> $ uname -a
> FreeBSD localhost.localdomain 9.0-RELEASE-p3 FreeBSD 9.0-RELEASE-p3 #0: Tue Jun
> 12 01:47:53 UTC 2012     root@i386-builder.daemonology.net:/usr/obj/usr/src/sys/
> GENERIC  i386
>
> # cat /var/log/portmaster.log
> ...
> Sun Jun 10 23:43:01 CEST 2012
>         Upgrade of boost-jam-1.45.0 to boost-jam-1.48.0
> ...
> Mon Jun 11 00:07:43 CEST 2012
>         Upgrade of boost-libs-1.45.0_1 to boost-libs-1.48.0
> ...
>
> $ ls -d /var/db/pkg/boost-*
> /var/db/pkg/boost-jam-1.48.0    /var/db/pkg/boost-libs-1.48.0
>
> # pkg_delete /var/db/pkg/boost-*
>
> # cd /usr/ports/editors/libreoffice
> [root@localhost /usr/ports/editors/libreoffice]# make clean
> ===>  Cleaning for libreoffice-3.5.4
> [root@localhost /usr/ports/editors/libreoffice]# make
> ...
> => Attempting to fetch http://ftp.rediris.es/mirror/TDF/libreoffice/src/3.5.4/li
> breoffice-core-3.5.4.2.tar.xz
> ...
> ===>   libreoffice-3.5.4 depends on file: /usr/local/lib/libboost_regex.a - not
> found
> ===>    Verifying install for /usr/local/lib/libboost_regex.a in /usr/ports/deve
> l/boost-libs
> ...
> => Attempting to fetch http://heanet.dl.sourceforge.net/project/boost/boost/1.48
> .0/boost_1_48_0.tar.bz2
> boost_1_48_0.tar.bz2                          100% of   46 MB  240 kBps 00m00s
> ===>  Extracting for boost-libs-1.48.0
> ...
> ===>   boost-libs-1.48.0 depends on executable: bjam - not found
> ===>    Verifying install for bjam in /usr/ports/devel/boost-jam
> ===>  Extracting for boost-jam-1.48.0
> ...
> LibreOffice build succesfully finished.
> ...
> [root@localhost /usr/ports/editors/libreoffice]# make install
> ...
> ===>   Registering installation for libreoffice-3.5.4
> [root@localhost /usr/ports/editors/libreoffice]#
>
> NOTE:
> As seen above, the boost-lib and boost-jam are required for libreoffice
> compilation.
> I see missing '+REQUIRED_ BY' file in their package dirs:
>  /var/db/pkg/boost-libs-1.48.0/
> +COMMENT        +CONTENTS       +DESC           +DISPLAY        +MTREE_DIRS
> # ls /var/db/pkg/boost-jam-1.48.0/
> +COMMENT        +CONTENTS       +DESC           +MTREE_DIRS
>
> So, what was the trick with boost removal ?
> If none, then what was the fix (this should be stated before closing the PR).

The trick is to remove boost.  Libreoffice uses its own bundled version.

Chris
Comment 20 jb.1234abcd 2012-07-01 23:16:37 UTC
> The trick is to remove boost.  Libreoffice uses its own bundled version.
>
> Chris

But it seems that libreoffice and the other ports/packages require the same
boost-* packages versions. So, libreoffice should not require to
remove them, only to install the same from its bundle you say (?), which
actually is a download from a distinct site as shown in my build log:
> => Attempting to fetch http://heanet.dl.sourceforge.net/project/boost/boost/1.48
> .0/boost_1_48_0.tar.bz2
> boost_1_48_0.tar.bz2                          100% of   46 MB  240 kBps 00m00s
> ===>  Extracting for boost-libs-1.48.0
> ...

The missing "REQUIRED_BY' file should be there too and include libreoffice and
the other ports/packages for the integrity of packages database, and thus any
package management utility like portmaster.

I just installed povray-3.7.0.r3_2 and here you go,
the boost-libs package database was updated:
# cat /var/db/pkg/boost-libs-1.48.0/+REQUIRED_BY
povray-3.7.0.r3_2

So should libreoffice.
Please reopen this PR until libreoffice build and packaging gets fixed.
jb