Bug 171571

Summary: [new ports] print/texlive
Product: Ports & Packages Reporter: kamikaze
Component: Individual Port(s)Assignee: Hiroki Sato <hrs>
Status: Closed FIXED    
Severity: Affects Only Me    
Priority: Normal    
Version: Latest   
Hardware: Any   
OS: Any   
Attachments:
Description Flags
file.shar
none
shar-ports-print-texlive.txt
none
print.diff.txt none

Description kamikaze 2012-09-12 14:10:07 UTC
This is a port of the TeX Live 2012 distribution.

This port installs the entire distribution apart from asymptote. I will add a math/texlive-asymptote port once this gets committed.

There are other ongoing efforts to port TeX Live, that offer more fine grained control over the parts of the distribution to be installed (e.g. http://code.google.com/p/freebsd-texlive/).

I think my approach is easier to maintain. I don't care which port gets adopted. However I think it is time to get TeX Live into the ports tree and to deprecate teTeX in the forseeable future.

I'm also including a patch with graphics poppler, because the pkgconf file has an incomplete include dir where loading "poppler/poppler-config.h" fails. It either means includes get installed into the wrong directory or there is an upstream problem with the pkgconf file.
Changing pkgconf is the smaller fix, so I choose that way.

Fix: diff -Nur ports/graphics/poppler.orig/Makefile ports/graphics/poppler/Makefile
--- ports/graphics/poppler.orig/Makefile	2012-08-14 08:18:28.000000000 +0200
+++ ports/graphics/poppler/Makefile	2012-08-14 08:08:18.000000000 +0200
@@ -8,7 +8,7 @@
 
 PORTNAME=	poppler
 PORTVERSION=	0.18.4
-PORTREVISION?=	1
+PORTREVISION?=	2
 CATEGORIES=	graphics print
 MASTER_SITES=	http://poppler.freedesktop.org/
 
diff -Nur ports/graphics/poppler.orig/files/patch-poppler.pc.cmake ports/graphics/poppler/files/patch-poppler.pc.cmake
--- ports/graphics/poppler.orig/files/patch-poppler.pc.cmake	1970-01-01 01:00:00.000000000 +0100
+++ ports/graphics/poppler/files/patch-poppler.pc.cmake	2012-08-14 08:21:21.000000000 +0200
@@ -0,0 +1,8 @@
+--- poppler.pc.cmake.orig	2012-08-14 08:18:05.000000000 +0200
++++ poppler.pc.cmake	2012-08-14 08:19:08.000000000 +0200
+@@ -8,4 +8,4 @@
+ Version: @POPPLER_VERSION@
+ 
+ Libs: -L${libdir} -lpoppler
+-Cflags: -I${includedir}/poppler
++Cflags: -I${includedir}/poppler -I${includedir}
diff -Nur ports/graphics/poppler.orig/files/patch-poppler.pc.in ports/graphics/poppler/files/patch-poppler.pc.in
--- ports/graphics/poppler.orig/files/patch-poppler.pc.in	1970-01-01 01:00:00.000000000 +0100
+++ ports/graphics/poppler/files/patch-poppler.pc.in	2012-08-14 08:20:44.000000000 +0200
@@ -0,0 +1,8 @@
+--- poppler.pc.in.orig	2012-08-14 08:17:29.000000000 +0200
++++ poppler.pc.in	2012-08-14 08:17:50.000000000 +0200
+@@ -8,4 +8,4 @@
+ Version: @VERSION@
+ 
+ Libs: -L${libdir} -lpoppler
+-Cflags: -I${includedir}/poppler
++Cflags: -I${includedir}/poppler -I${includedir}


Patch attached with submission follows:
Comment 1 Edwin Groothuis freebsd_committer 2012-09-12 14:10:25 UTC
Class Changed
From-To: sw-bug->change-request

Fix category (new ports should be change-requests) (via the GNATS Auto 
Assign Tool)
Comment 2 Boris Samorodov freebsd_committer 2012-09-21 11:49:58 UTC
Responsible Changed
From-To: freebsd-ports-bugs->bsam

take.
Comment 3 Boris Samorodov freebsd_committer 2012-09-23 12:51:16 UTC
State Changed
From-To: open->suspended

Depens on PR/171877.
Comment 4 David Naylor 2012-10-10 18:55:28 UTC
I have also been working on ports for texlive (although the effort has stalled 
of late).  Please see github.com/DragonSA/texlive for my work.  

I, also, want to see texlive in ports and don't really care who's port it is, 
as long as It Works (tm).  
Comment 5 kamikaze 2012-10-13 18:22:29 UTC
PR/171877 has been resolved.

What I've seen here and on the @ports mailing list is that a number
of people have created texlive ports. Some with vastly different
technical approaches, i.e. fine grained controlled vs. easily maintainable.

What all port creators seem to have in common is that we do not really
care whether it's our own port that gets committed, as long as texlive
gets into the ports tree.

There's no reason to "pool our resources and work on this together",
the work is done and you cannot go left and right at the same time.
You won't hurt any ones feelings by selecting someone else's port.

I think we'd all appreciate if you just decided which port looks
most mature to you and committed it.


Yours impatiently,
Kami :P

-- 
A: Because it fouls the order in which people normally read text.
Q: Why is top-posting such a bad thing?
A: Top-posting.
Q: What is the most annoying thing on usenet and in e-mail?
Comment 6 Boris Samorodov 2012-10-18 21:20:05 UTC
Hi and sorry for a delay.

I think that the consensus was that:
a) a drop-in replacement is preferred;
b) Hiroki Sato (the tex ports maintainer) is working on it.

So I think that we may wait for a while.

Hiroki-san, should I switch this PR to you?
-- 
WBR, Boris Samorodov (bsam)
FreeBSD Committer, http://www.FreeBSD.org The Power To Serve
Comment 7 Hiroki Sato freebsd_committer 2012-10-20 15:11:31 UTC
----Security_Multipart(Sat_Oct_20_23_11_31_2012_542)--
Content-Type: Text/Plain; charset=us-ascii
Content-Transfer-Encoding: 7bit

Boris Samorodov <bsam@passap.ru> wrote
  in <50806475.2070404@passap.ru>:

bs> Hi and sorry for a delay.
bs>
bs> I think that the consensus was that:
bs> a) a drop-in replacement is preferred;
bs> b) Hiroki Sato (the tex ports maintainer) is working on it.
bs>
bs> So I think that we may wait for a while.
bs>
bs> Hiroki-san, should I switch this PR to you?

 Yes, please.  Thank you!

-- Hiroki

----Security_Multipart(Sat_Oct_20_23_11_31_2012_542)--
Content-Type: application/pgp-signature
Content-Transfer-Encoding: 7bit

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.11 (FreeBSD)

iEYEABECAAYFAlCCsRMACgkQTyzT2CeTzy2bpwCgiwI/fbaAtgax3lzLJI0lnvio
TAsAoN2wbQktZ0/ZSLI2WcrVryU343md
=I36Z
-----END PGP SIGNATURE-----

----Security_Multipart(Sat_Oct_20_23_11_31_2012_542)----
Comment 8 Boris Samorodov freebsd_committer 2012-10-22 12:34:14 UTC
Responsible Changed
From-To: bsam->hrs

Hiroki-san is working on upgrading the ports tree from teTeX to Texlive 
and will take care ot the PR.
Comment 9 kamikaze 2013-02-06 02:58:47 UTC
I haven't given up on texlive yet. I use this to write my master
thesis and if there's no official texlive by the time I'm done with
it I'll go about fixing all the odd ends (i.e. do what it takes to
get rid of teTeX in the ports) and run a huge regression test with my
port.

I actually don't expect this to be more than a days work and a couple
of days waiting for Tinderbox to do its thing.

The attached shar has an improved post-install target in the
texlive-base port, that fixes some symlinking errors that occur due
to the little hack I apply to prevent texlive-base from overwriting
files provided by texlive-texmf.

Regards

-- 
A: Because it fouls the order in which people normally read text.
Q: Why is top-posting such a bad thing?
A: Top-posting.
Q: What is the most annoying thing on usenet and in e-mail? 
Comment 10 Boris Samorodov 2013-02-06 04:41:35 UTC
I use the following patch and portmaster seems to DTRT with
dependencies upon teTeX-* ports.

-- 
WBR, Boris Samorodov (bsam)
FreeBSD Committer, http://www.FreeBSD.org The Power To Serve
Comment 11 Steve Wills freebsd_committer 2013-02-16 15:04:26 UTC
State Changed
From-To: suspended->open

Reopen since PR 171877 was committed
Comment 12 Chris Rees 2013-02-16 17:37:00 UTC
Minor comment, please remove
ports/print/texlive-base/files/patch-configure ; its existence is
needless since configure is auto-generated from configure.ac.  Perhaps
you need to add USE_AUTOTOOLS=autoconf to the Makefile.

Chris
Comment 13 dfilter service freebsd_committer 2013-05-06 01:44:36 UTC
Author: hrs
Date: Mon May  6 00:44:22 2013
New Revision: 317452
URL: http://svnweb.freebsd.org/changeset/ports/317452

Log:
  TeXLive mega commit.  The following ports have been added:
  
    * Meta port
     - print/texlive-full: meta port to install all of the TeXLive components
  
    * Libraries
     - devel/tex-kpathsea: kpathsea library
     - devel/tex-web2c: WEB2C toolchain and TeX engines
     - print/tex-ptexenc: character code conversion library for pTeX
  
    * Base part of the TeXLive
     - print/texlive-base: binary programs in TeXLive
     - print/texlive-texmf: macro and font data in TeXLive
     - print/texlive-infra: tlmgr dependency (Perl modules)
  
    * TeX Formats
     - print/tex-formats: TeX, LaTeX, PDFTeX, AMSTeX, ConTeXT, CSLaTeX,
         EplainTeX, METAFONT, MLTeX, PDFTeX, TeXsis
     - print/tex-aleph: Aleph/Lambda
     - print/tex-xetex: XeTeX
     - print/tex-luatex: LuaTeX
     - print/tex-jadetex: JadeTeX
     - print/tex-xmltex: XMLTeX
     - japanese/tex-ptex: pTeX
  
    * DVI ware
     - print/tex-xdvik: XDvi
  
  Mk/bsd.tex.mk is added for common part and USE_TEX knob [1].
  
  Approved by:	portmgr (old version) [1]
  PR:		ports/171571
  PR:		ports/176399 [1]

Added:
  head/Mk/bsd.tex.mk   (contents, props changed)
  head/devel/tex-kpathsea/
  head/devel/tex-kpathsea/Makefile   (contents, props changed)
  head/devel/tex-kpathsea/distinfo   (contents, props changed)
  head/devel/tex-kpathsea/files/
  head/devel/tex-kpathsea/files/patch-texmf.cnf   (contents, props changed)
  head/devel/tex-kpathsea/pkg-descr   (contents, props changed)
  head/devel/tex-kpathsea/pkg-plist   (contents, props changed)
  head/devel/tex-web2c/
  head/devel/tex-web2c/Makefile   (contents, props changed)
  head/devel/tex-web2c/distinfo   (contents, props changed)
  head/devel/tex-web2c/pkg-descr   (contents, props changed)
  head/devel/tex-web2c/pkg-plist   (contents, props changed)
  head/japanese/tex-ptex/
  head/japanese/tex-ptex/Makefile   (contents, props changed)
  head/japanese/tex-ptex/distinfo   (contents, props changed)
  head/japanese/tex-ptex/files/
  head/japanese/tex-ptex/files/patch-Makefile.in   (contents, props changed)
  head/japanese/tex-ptex/files/patch-web2c-Makefile.in   (contents, props changed)
  head/japanese/tex-ptex/pkg-descr   (contents, props changed)
  head/japanese/tex-ptex/pkg-plist   (contents, props changed)
  head/print/tex-aleph/
  head/print/tex-aleph/Makefile   (contents, props changed)
  head/print/tex-aleph/distinfo   (contents, props changed)
  head/print/tex-aleph/files/
  head/print/tex-aleph/files/patch-Makefile.in   (contents, props changed)
  head/print/tex-aleph/files/patch-web2c-Makefile.in   (contents, props changed)
  head/print/tex-aleph/pkg-descr   (contents, props changed)
  head/print/tex-aleph/pkg-plist   (contents, props changed)
  head/print/tex-formats/
  head/print/tex-formats/Makefile   (contents, props changed)
  head/print/tex-formats/pkg-descr   (contents, props changed)
  head/print/tex-jadetex/
     - copied from r313372, head/print/jadetex/
  head/print/tex-luatex/
  head/print/tex-luatex/Makefile   (contents, props changed)
  head/print/tex-luatex/distinfo   (contents, props changed)
  head/print/tex-luatex/files/
  head/print/tex-luatex/files/patch-Makefile.in   (contents, props changed)
  head/print/tex-luatex/files/patch-web2c-Makefile.in   (contents, props changed)
  head/print/tex-luatex/pkg-descr   (contents, props changed)
  head/print/tex-luatex/pkg-plist   (contents, props changed)
  head/print/tex-ptexenc/
  head/print/tex-ptexenc/Makefile   (contents, props changed)
  head/print/tex-ptexenc/distinfo   (contents, props changed)
  head/print/tex-ptexenc/files/
  head/print/tex-ptexenc/files/patch-ptexenc.c   (contents, props changed)
  head/print/tex-ptexenc/pkg-descr   (contents, props changed)
  head/print/tex-ptexenc/pkg-plist   (contents, props changed)
  head/print/tex-xdvik/
     - copied from r316307, head/print/xdvik/
  head/print/tex-xdvik/files/patch-texk-xdvik-Makefile.in   (contents, props changed)
  head/print/tex-xdvik/files/patch-texk-xdvik-dvi-init.c   (contents, props changed)
  head/print/tex-xdvik/files/patch-texk-xdvik-texmf-XDvi   (contents, props changed)
  head/print/tex-xetex/
  head/print/tex-xetex/Makefile   (contents, props changed)
  head/print/tex-xetex/distinfo   (contents, props changed)
  head/print/tex-xetex/files/
  head/print/tex-xetex/files/patch-Makefile.in   (contents, props changed)
  head/print/tex-xetex/pkg-descr   (contents, props changed)
  head/print/tex-xetex/pkg-plist   (contents, props changed)
  head/print/tex-xmltex/
     - copied from r313372, head/print/xmltex/
  head/print/texlive-base/
  head/print/texlive-base/Makefile   (contents, props changed)
  head/print/texlive-base/distinfo   (contents, props changed)
  head/print/texlive-base/files/
  head/print/texlive-base/files/patch-texk-tetex-fmtutil   (contents, props changed)
  head/print/texlive-base/files/patch-texk-tetex-fmtutil.cnf   (contents, props changed)
  head/print/texlive-base/pkg-descr   (contents, props changed)
  head/print/texlive-base/pkg-plist   (contents, props changed)
  head/print/texlive-full/
  head/print/texlive-full/Makefile   (contents, props changed)
  head/print/texlive-full/pkg-descr   (contents, props changed)
  head/print/texlive-infra/
  head/print/texlive-infra/Makefile   (contents, props changed)
  head/print/texlive-infra/distinfo   (contents, props changed)
  head/print/texlive-infra/pkg-descr   (contents, props changed)
  head/print/texlive-infra/pkg-plist   (contents, props changed)
  head/print/texlive-texmf/
  head/print/texlive-texmf/Makefile   (contents, props changed)
  head/print/texlive-texmf/distinfo   (contents, props changed)
  head/print/texlive-texmf/pkg-descr   (contents, props changed)
  head/print/texlive-texmf/pkg-plist   (contents, props changed)
Deleted:
  head/print/tex-jadetex/files/
  head/print/tex-xdvik/files/pkg-install.in
  head/print/tex-xmltex/files/
Modified:
  head/Mk/bsd.port.mk
  head/UPDATING
  head/devel/Makefile
  head/japanese/Makefile
  head/print/Makefile
  head/print/tex-jadetex/Makefile
  head/print/tex-jadetex/distinfo
  head/print/tex-jadetex/pkg-descr
  head/print/tex-jadetex/pkg-plist
  head/print/tex-xdvik/Makefile
  head/print/tex-xdvik/distinfo
  head/print/tex-xdvik/pkg-plist
  head/print/tex-xmltex/Makefile
  head/print/tex-xmltex/distinfo
  head/print/tex-xmltex/pkg-descr
  head/print/tex-xmltex/pkg-plist   (contents, props changed)

Modified: head/Mk/bsd.port.mk
==============================================================================
--- head/Mk/bsd.port.mk	Mon May  6 00:42:27 2013	(r317451)
+++ head/Mk/bsd.port.mk	Mon May  6 00:44:22 2013	(r317452)
@@ -509,6 +509,9 @@ FreeBSD_MAINTAINER=	portmgr@FreeBSD.org
 # USE_XORG			- Set to a list of X.org module dependencies.
 #				  Implies inclusion of bsd.xorg.mk.
 ##
+# USE_TEX			- A list of the TeX dependencies the port has.
+#
+##
 # USE_RC_SUBR	- If set, the ports startup/shutdown script uses the common
 #				  routines found in /etc/rc.subr.
 #				  If this is set to a list of files, these files will be
@@ -1463,6 +1466,10 @@ PKGCOMPATDIR?=		${LOCALBASE}/lib/compat/
 .include "${PORTSDIR}/Mk/bsd.qt.mk"
 .endif
 
+.if defined(USE_TEX)
+.include "${PORTSDIR}/Mk/bsd.tex.mk"
+.endif
+
 .if defined(USE_DRUPAL)
 .include "${PORTSDIR}/Mk/bsd.drupal.mk"
 .endif

Added: head/Mk/bsd.tex.mk
==============================================================================
--- /dev/null	00:00:00 1970	(empty, because file is newly added)
+++ head/Mk/bsd.tex.mk	Mon May  6 00:44:22 2013	(r317452)
@@ -0,0 +1,508 @@
+# $FreeBSD$
+#
+# bsd.tex.mk - Common part for TeX related ports
+#
+TEX_MAINTAINER=	hrs@FreeBSD.org
+
+#
+# For full teTeX dependency:
+# USE_TEX=	tetex
+#
+# For full TeXLive dependency:
+# USE_TEX=	texlive
+#
+# The other valid keywords:
+#
+#  tetex-base:	teTeX base
+#  tetex-texmf:	teTeX texmf tree
+#
+#  web2c:	WEB2C toolchain and TeX engines
+#  kpathsea:	kpathsea library
+#  ptexenc:	character code conversion library for pTeX
+#
+#  base:	TeXLive base
+#  texmf:	TeXLive texmf tree
+#  infra:	tlmgr dependency (Perl modules)
+#
+#  dvipsk:	dvipsk (not implemented yet)
+#  xdvik:	XDvi
+#
+#  formats:	TeX, LaTeX, PDFTeX, AMSTeX, ConTeXT, CSLaTeX, EplainTeX,
+#		METAFONT, MLTeX, PDFTeX, TeXsis
+#  aleph:	Aleph
+#  jadetex:	JadeTeX
+#  luatex:	LuaTeX
+#  ptex:	pTeX
+#  xetex:	XeTeX
+#  xmltex:	XMLTeX
+#
+#  texhash:	directory search hash regeneration
+#  updmap:	font map regeneration
+#  fmtutil:	format regeneration
+#
+.if defined(MASTER_SITES) && !empty(MASTER_SITES)
+DIST_SUBDIR?=	TeX
+.endif
+
+TEXMFDIR?=	share/texmf
+TEXMFDISTDIR?=	share/texmf-dist
+TEXMFLOCALDIR?=	share/texmf-local
+TEXMFVARDIR?=	share/texmf-var
+TEXMFCONFIGDIR?=share/texmf-config
+FMTUTIL_CNF?=	${TEXMFCONFIGDIR}/web2c/fmtutil.cnf
+TEXHASHDIRS?=	${TEXMFDIR} ${TEXMFDISTDIR} ${TEXMFLOCALDIR} ${TEXMFVARDIR} ${TEXMFCONFIGDIR}
+
+.for V in TEXMFDIR TEXMFDISTDIR TEXMFLOCALDIR TEXMFVARDIR TEXMFCONFIGDIR FMTUTIL_CNF
+PLIST_SUB+=	$V="${$V}"
+.endfor
+
+CONFLICTS_TEXLIVE= \
+	texlive-[0-9]* tex-web2c-[0-9]* \
+	tex-kpathsea-[0-9]* tex-xdvik-[0-9]* \
+	tex-dvipsk-[0-9]* tex-dvipdfmx-[0-9]*
+CONFLICTS_TETEX= \
+	teTeX-[0-9]* *-teTeX-[0-9]* \
+	teTeX-*-[0-9]* *-teTeX-*-[0-9]* \
+	latex2e-[0-9]*
+
+.if !empty(USE_TEX:Mtetex-texmf) || !empty(USE_TEX:Mtetex)
+_USE_TETEX_TEXMF=	${LOCALBASE}/${TEXMFDISTDIR}/LICENSE.texmf:${PORTSDIR}/print/teTeX-texmf
+CONFLICTS_INSTALL+=	${CONFLICTS_TEXLIVE}
+.endif
+.if !empty(USE_TEX:Mtetex-base) || !empty(USE_TEX:Mtetex)
+_USE_TETEX_BASE=	mktexlsr:${PORTSDIR}/print/teTeX-base
+CONFLICTS_INSTALL+=	${CONFLICTS_TEXLIVE}
+.endif
+
+.if !empty(USE_TEX:Mweb2c) || !empty(USE_TEX:Mtexlive)
+_USE_TEX_WEB2C=		weave:${PORTSDIR}/devel/tex-web2c
+CONFLICTS_INSTALL+=	${CONFLICTS_TETEX}
+.endif
+.if !empty(USE_TEX:Mjadetex) || !empty(USE_TEX:Mtexlive)
+_USE_TEX_JADETEX=	jadetex:${PORTSDIR}/print/tex-jadetex
+CONFLICTS_INSTALL+=	${CONFLICTS_TETEX}
+.endif
+.if !empty(USE_TEX:Mxmltex) || !empty(USE_TEX:Mtexlive)
+_USE_TEX_XMLTEX=	xmltex:${PORTSDIR}/print/tex-xmltex
+CONFLICTS_INSTALL+=	${CONFLICTS_TETEX}
+.endif
+.if !empty(USE_TEX:Mluatex) || !empty(USE_TEX:Mtexlive)
+_USE_TEX_LUATEX=	luatex:${PORTSDIR}/print/tex-luatex
+CONFLICTS_INSTALL+=	${CONFLICTS_TETEX}
+.endif
+.if !empty(USE_TEX:Mxetex) || !empty(USE_TEX:Mtexlive)
+_USE_TEX_XETEX=		xetex:${PORTSDIR}/print/tex-xetex
+CONFLICTS_INSTALL+=	${CONFLICTS_TETEX}
+.endif
+.if !empty(USE_TEX:Maleph) || !empty(USE_TEX:Mtexlive)
+_USE_TEX_ALEPH=		aleph:${PORTSDIR}/print/tex-aleph
+CONFLICTS_INSTALL+=	${CONFLICTS_TETEX}
+.endif
+.if !empty(USE_TEX:Mptex) || !empty(USE_TEX:Mtexlive)
+_USE_TEX_PTEX=		ptex:${PORTSDIR}/japanese/tex-ptex
+CONFLICTS_INSTALL+=	${CONFLICTS_TETEX}
+.endif
+.if !empty(USE_TEX:Mkpathsea) || !empty(USE_TEX:Mtexlive)
+_USE_TEX_KPATHSEA=	kpathsea:${PORTSDIR}/devel/tex-kpathsea
+CONFLICTS_INSTALL+=	${CONFLICTS_TETEX}
+.endif
+.if !empty(USE_TEX:Mptexenc) || !empty(USE_TEX:Mtexlive)
+_USE_TEX_PTEXENC=	ptexenc:${PORTSDIR}/print/tex-ptexenc
+CONFLICTS_INSTALL+=	${CONFLICTS_TETEX}
+.endif
+.if !empty(USE_TEX:Mdvipsk) || !empty(USE_TEX:Mtexlive)
+# XXX
+#_USE_TEX_DVIPSK=	dvips:${PORTSDIR}/print/tex-dvipsk
+#CONFLICTS_INSTALL+=	${CONFLICTS_TETEX}
+.endif
+.if !empty(USE_TEX:Mxdvik) || !empty(USE_TEX:Mtexlive)
+_USE_TEX_XDVIK=		xdvi:${PORTSDIR}/print/tex-xdvik
+CONFLICTS_INSTALL+=	${CONFLICTS_TETEX}
+.endif
+.if !empty(USE_TEX:Mbase) || !empty(USE_TEX:Mtexlive)
+_USE_TEXLIVE_BASE=	tlmgr:${PORTSDIR}/print/texlive-base
+CONFLICTS_INSTALL+=	${CONFLICTS_TETEX}
+.endif
+.if !empty(USE_TEX:Mtexmf) || !empty(USE_TEX:Mtexlive)
+_USE_TEXLIVE_TEXMF=	${LOCALBASE}/${TEXMFDISTDIR}/README:${PORTSDIR}/print/texlive-texmf
+CONFLICTS_INSTALL+=	${CONFLICTS_TETEX}
+.endif
+.if !empty(USE_TEX:Mformats) || !empty(USE_TEX:Mtexlive)
+_USE_TEX_FORMATS=	${LOCALBASE}/${TEXMFVARDIR}/web2c/tex/tex.fmt:${PORTSDIR}/print/tex-formats
+CONFLICTS_INSTALL+=	${CONFLICTS_TETEX}
+.endif
+.if !empty(USE_TEX:Minfra) || !empty(USE_TEX:Mtexlive)
+_USE_TEXLIVE_INFRA=	${SITE_PERL}/TeXLive/TLConfig.pm:${PORTSDIR}/print/texlive-infra
+CONFLICTS_INSTALL+=	${CONFLICTS_TETEX}
+.endif
+
+.for D in TEXLIVE_BASE TEX_WEB2C TEXLIVE_TEXMF TEXLIVE_INFRA \
+	TEX_FORMATS TEX_ALEPH TEX_JADETEX TEX_XMLTEX TEX_LUATEX \
+	TEX_XETEX TEX_PTEX TEX_XDVIK TEX_DVIPSK
+RUN_DEPENDS+=	${_USE_${D}}
+.endfor
+.for D in TETEX_TEXMF TETEX_BASE TEXLIVE_BASE TEX_WEB2C TEXLIVE_TEXMF \
+	TEX_FORMATS TEX_ALEPH TEX_JADETEX TEX_XMLTEX TEX_LUATEX \
+	TEX_XETEX TEX_PTEX
+BUILD_DEPENDS+=	${_USE_${D}}
+.endfor
+.for D in TEX_KPATHSEA TEX_PTEXENC
+LIB_DEPENDS+=	${_USE_${D}}
+.endfor
+
+.ORDER: do-texhash do-fmtutil do-updmap
+
+.if !empty(USE_TEX:Mtexhash) || !empty(USE_TEX:Mfmtutil) || !empty(USE_TEX:Mupdmap)
+.PHONY:	do-texhash
+do-texhash:
+	@for D in ${TEXHASHDIRS:S,^,${PREFIX}/,}; do \
+		if [ -r $$D/ls-R ]; then ${LOCALBASE}/bin/mktexlsr $$D; fi; \
+	done
+	@${ECHO_CMD} "@exec for D in ${TEXHASHDIRS:S,^,${PREFIX}/,}; do " \
+		"if [ -r \$$D/ls-R ]; then " \
+			"${LOCALBASE}/bin/mktexlsr \$$D; " \
+		"fi; done" >> ${TMPPLIST}
+	@${ECHO_CMD} "@unexec for D in ${TEXHASHDIRS:S,^,${PREFIX}/,}; do " \
+		"if [ -r \$$D/ls-R ]; then " \
+			"${LOCALBASE}/bin/mktexlsr \$$D; " \
+		"fi; done" >> ${TMPPLIST}
+
+post-install: do-texhash
+.endif
+
+.if !empty(USE_TEX:Mfmtutil)
+.PHONY:	do-fmtutil
+post-install: do-fmtutil
+.for F in ${TEX_FORMATS}
+do-fmtutil: do-fmtutil-$F post-install-$F
+do-fmtutil-$F:
+	@${TEST} -n '${TEX_FORMAT_${F:U}}'
+	@${TEST} -r ${LOCALBASE}/${FMTUTIL_CNF}
+	@exec < ${LOCALBASE}/${FMTUTIL_CNF} && \
+		${RM} ${LOCALBASE}/${FMTUTIL_CNF} && \
+		(${GREP} -v "\#$F\$$"; \
+			${PRINTF} "%s\t\#$F\n" ${TEX_FORMAT_${F:U}}) \
+			> ${LOCALBASE}/${FMTUTIL_CNF}
+	@${PRINTF} "%s\t\#$F\n" ${TEX_FORMAT_${F:U}} | \
+		while read format dum; do \
+		${SETENV} PATH=${PATH}:${LOCALBASE}/bin \
+			TEXMFMAIN=${LOCALBASE}/${TEXMFDIR} \
+			${LOCALBASE}/bin/fmtutil-sys --byfmt $$format; \
+		done
+	@${ECHO_CMD} "@exec exec < ${LOCALBASE}/${FMTUTIL_CNF} && " \
+		"${RM} ${LOCALBASE}/${FMTUTIL_CNF} && " \
+		"(${GREP} -v \"\#$F\$$\"; ${PRINTF} \"%%s\t\#$F\n\" " \
+		"${TEX_FORMAT_${F:U}:S,",\\",g}) " \
+		"> ${LOCALBASE}/${FMTUTIL_CNF}" >> ${TMPPLIST}
+	@${ECHO_CMD} "@unexec exec < ${LOCALBASE}/${FMTUTIL_CNF} && " \
+		"${RM} ${LOCALBASE}/${FMTUTIL_CNF} && " \
+		"${GREP} -v \"\#$F\$$\" " \
+		"> ${LOCALBASE}/${FMTUTIL_CNF}" >> ${TMPPLIST}
+PLIST_FILES+=	${TEX_FORMAT_${F:U}_FILES}
+PLIST_DIRSTRY+=	${TEX_FORMAT_${F:U}_DIRS}
+.endfor
+PLIST_DIRSTRY+=	${TEXMFVARDIR}/web2c \
+		${TEXMFVARDIR}
+.endif
+
+.if !empty(USE_TEX:Mupdmap)
+.PHONY:	do-updmap
+do-updmap:
+	${SETENV} PATH=${PATH}:${LOCALBASE}/bin \
+		TEXMFMAIN=${LOCALBASE}/${TEXMFDIR} \
+		${LOCALBASE}/bin/updmap-sys
+post-install: do-updmap
+	@${ECHO_CMD} "@exec ${SETENV} PATH=${PATH}:${LOCALBASE}/bin " \
+		"TEXMFMAIN=${LOCALBASE}/${TEXMFDIR} " \
+		"${LOCALBASE}/bin/updmap-sys"  >> ${TMPPLIST}
+	@${ECHO_CMD} "@unexec ${SETENV} PATH=${PATH}:${LOCALBASE}/bin " \
+		"TEXMFMAIN=${LOCALBASE}/${TEXMFDIR} " \
+		"${LOCALBASE}/bin/updmap-sys"  >> ${TMPPLIST}
+.endif
+
+TEX_FORMAT_ALEPH?= \
+	"aleph aleph - *aleph.ini" \
+	"lamed aleph language.dat *lambda.ini"
+TEX_FORMAT_ALEPH_FILES=	\
+	${TEXMFVARDIR}/web2c/aleph/aleph.log \
+	${TEXMFVARDIR}/web2c/aleph/aleph.fmt \
+	${TEXMFVARDIR}/web2c/aleph/lamed.log \
+	${TEXMFVARDIR}/web2c/aleph/lamed.fmt \
+	bin/lamed
+TEX_FORMAT_ALEPH_DIRS=	\
+	${TEXMFVARDIR}/web2c/aleph
+post-install-aleph:
+	${LN} -sf aleph ${PREFIX}/bin/lamed
+
+TEX_FORMAT_AMSTEX?= \
+	"amstex pdftex - -translate-file=cp227.tcx *amstex.ini"
+TEX_FORMAT_AMSTEX_FILES= \
+	${TEXMFVARDIR}/web2c/pdftex/amstex.log \
+	${TEXMFVARDIR}/web2c/pdftex/amstex.fmt \
+	bin/amstex
+TEX_FORMAT_AMSTEX_DIRS= \
+	${TEXMFVARDIR}/web2c/pdftex
+post-install-amstex:
+	${LN} -fs pdftex ${PREFIX}/bin/amstex
+
+TEX_FORMAT_CONTEXT?= \
+	"cont-en pdftex cont-usr.tex -8bit *cont-en.ini"
+# XXX
+#	"metafun mpost - metafun.mp"
+TEX_FORMAT_CONTEXT_FILES=	\
+	${TEXMFVARDIR}/web2c/pdftex/cont-en.log \
+	${TEXMFVARDIR}/web2c/pdftex/cont-en.fmt
+#	bin/metafun
+TEX_FORMAT_CONTEXT_DIRS= \
+	${TEXMFVARDIR}/web2c/pdftex
+post-install-context:
+	@${DO_NADA}
+#	${LN} -sf mpost ${PREFIX}/bin/metafun
+
+TEX_FORMAT_CSLATEX?= \
+	"cslatex pdftex - -etex -translate-file=cp227.tcx cslatex.ini" \
+	"pdfcslatex pdftex - -etex -translate-file=cp227.tcx cslatex.ini"
+TEX_FORMAT_CSLATEX_FILES= \
+	${TEXMFVARDIR}/web2c/pdftex/cslatex.log \
+	${TEXMFVARDIR}/web2c/pdftex/cslatex.fmt \
+	${TEXMFVARDIR}/web2c/pdftex/pdfcslatex.log \
+	${TEXMFVARDIR}/web2c/pdftex/pdfcslatex.fmt \
+	bin/cslatex \
+	bin/pdfcslatex
+TEX_FORMAT_CSLATEX_DIRS= \
+	${TEXMFVARDIR}/web2c/pdftex
+post-install-cslatex:
+	${LN} -sf pdftex ${PREFIX}/bin/cslatex
+	${LN} -sf pdftex ${PREFIX}/bin/pdfcslatex
+
+TEX_FORMAT_EPLAIN?= \
+	"eplain pdftex language.dat -translate-file=cp227.tcx *eplain.ini"
+TEX_FORMAT_EPLAIN_FILES= \
+	${TEXMFVARDIR}/web2c/pdftex/eplain.log \
+	${TEXMFVARDIR}/web2c/pdftex/eplain.fmt \
+	bin/eplain
+TEX_FORMAT_EPLAIN_DIRS= \
+	${TEXMFVARDIR}/web2c/pdftex
+post-install-eplain:
+	${LN} -sf pdftex ${PREFIX}/bin/eplain
+
+TEX_FORMAT_JADETEX?= \
+	"jadetex pdftex language.dat *jadetex.ini" \
+	"pdfjadetex pdftex language.dat *pdfjadetex.ini"
+TEX_FORMAT_JADETEX_FILES= \
+	${TEXMFVARDIR}/web2c/pdftex/jadetex.log \
+	${TEXMFVARDIR}/web2c/pdftex/jadetex.fmt \
+	${TEXMFVARDIR}/web2c/pdftex/pdfjadetex.log \
+	${TEXMFVARDIR}/web2c/pdftex/pdfjadetex.fmt \
+	bin/jadetex \
+	bin/pdfjadetex
+TEX_FORMAT_JADETEX_DIRS= \
+	${TEXMFVARDIR}/web2c/pdftex
+post-install-jadetex:
+	${LN} -sf pdftex ${PREFIX}/bin/jadetex
+	${LN} -sf pdftex ${PREFIX}/bin/pdfjadetex
+
+TEX_FORMAT_LATEX-BIN?= \
+	"latex pdftex language.dat -translate-file=cp227.tcx *latex.ini" \
+	"pdflatex pdftex language.dat -translate-file=cp227.tcx *pdflatex.ini"
+TEX_FORMAT_LATEX-BIN_FILES= \
+	${TEXMFVARDIR}/web2c/pdftex/latex.log \
+	${TEXMFVARDIR}/web2c/pdftex/latex.fmt \
+	${TEXMFVARDIR}/web2c/pdftex/pdflatex.log \
+	${TEXMFVARDIR}/web2c/pdftex/pdflatex.fmt \
+	bin/latex \
+	bin/pdflatex
+TEX_FORMAT_LATEX-BIN_DIRS= \
+	${TEXMFVARDIR}/web2c/pdftex
+post-install-latex-bin:
+	${LN} -sf pdftex ${PREFIX}/bin/latex
+	${LN} -sf pdftex ${PREFIX}/bin/pdflatex
+
+TEX_FORMAT_LUATEX?= \
+	"luatex luatex language.def,language.dat.lua luatex.ini" \
+	"dviluatex luatex language.def,language.dat.lua dviluatex.ini" \
+	"dvilualatex luatex language.dat,language.dat.lua dvilualatex.ini" \
+	"lualatex luatex language.dat,language.dat.lua lualatex.ini"
+TEX_FORMAT_LUATEX_FILES= \
+	${TEXMFVARDIR}/web2c/luatex/dviluatex.log \
+	${TEXMFVARDIR}/web2c/luatex/dviluatex.fmt \
+	${TEXMFVARDIR}/web2c/luatex/dvilualatex.log \
+	${TEXMFVARDIR}/web2c/luatex/dvilualatex.fmt \
+	${TEXMFVARDIR}/web2c/luatex/luatex.log \
+	${TEXMFVARDIR}/web2c/luatex/luatex.fmt \
+	${TEXMFVARDIR}/web2c/luatex/lualatex.log \
+	${TEXMFVARDIR}/web2c/luatex/lualatex.fmt \
+	bin/dviluatex \
+	bin/dvilualatex \
+	bin/lualatex
+TEX_FORMAT_LUATEX_DIRS=	\
+	${TEXMFVARDIR}/web2c/luatex
+post-install-luatex:
+	${LN} -sf luatex ${PREFIX}/bin/dviluatex
+	${LN} -sf luatex ${PREFIX}/bin/dvilualatex
+	${LN} -sf luatex ${PREFIX}/bin/lualatex
+
+TEX_FORMAT_METAFONT?= \
+	"mf mf-nowin - -translate-file=cp227.tcx mf.ini"
+TEX_FORMAT_METAFONT_FILES= \
+	${TEXMFVARDIR}/web2c/metafont/mf.log \
+	${TEXMFVARDIR}/web2c/metafont/mf.base
+TEX_FORMAT_METAFONT_DIRS= \
+	${TEXMFVARDIR}/web2c/metafont
+post-install-metafont:
+	@${DO_NADA}
+
+TEX_FORMAT_MEX?= \
+	"mex pdftex mexconf.tex -translate-file=cp227.tcx *mex.ini" \
+	"pdfmex pdftex mexconf.tex -translate-file=cp227.tcx *pdfmex.ini" \
+	"utf8mex pdftex mexconf.tex -enc *utf8mex.ini"
+TEX_FORMAT_MEX_FILES= \
+	${TEXMFVARDIR}/web2c/pdftex/mex.log \
+	${TEXMFVARDIR}/web2c/pdftex/mex.fmt \
+	${TEXMFVARDIR}/web2c/pdftex/pdfmex.log \
+	${TEXMFVARDIR}/web2c/pdftex/pdfmex.fmt \
+	${TEXMFVARDIR}/web2c/pdftex/utf8mex.log \
+	${TEXMFVARDIR}/web2c/pdftex/utf8mex.fmt \
+	bin/mex \
+	bin/pdfmex \
+	bin/utf8mex
+TEX_FORMAT_MEX_DIRS= \
+	${TEXMFVARDIR}/web2c/pdftex
+post-install-mex:
+	${LN} -sf pdftex ${PREFIX}/bin/mex
+	${LN} -sf pdftex ${PREFIX}/bin/pdfmex
+	${LN} -sf pdftex ${PREFIX}/bin/utf8mex
+
+TEX_FORMAT_MLTEX?= \
+	"mllatex pdftex language.dat -translate-file=cp227.tcx -mltex mllatex.ini" \
+	"mltex pdftex - -translate-file=cp227.tcx -mltex mltex.ini"
+TEX_FORMAT_MLTEX_FILES=	\
+	${TEXMFVARDIR}/web2c/pdftex/mllatex.log \
+	${TEXMFVARDIR}/web2c/pdftex/mllatex.fmt \
+	${TEXMFVARDIR}/web2c/pdftex/mltex.log \
+	${TEXMFVARDIR}/web2c/pdftex/mltex.fmt \
+	bin/mltex \
+	bin/mllatex
+TEX_FORMAT_MLTEX_DIRS= \
+	${TEXMFVARDIR}/web2c/pdftex
+post-install-mltex:
+	${LN} -sf pdftex ${PREFIX}/bin/mltex
+	${LN} -sf pdftex ${PREFIX}/bin/mllatex
+
+TEX_FORMAT_MPTOPDF?= \
+	"mptopdf pdftex - -translate-file=cp227.tcx mptopdf.tex"
+TEX_FORMAT_MPTOPDF_FILES= \
+	${TEXMFVARDIR}/web2c/pdftex/mptopdf.log \
+	${TEXMFVARDIR}/web2c/pdftex/mptopdf.fmt \
+	bin/mptopdf
+TEX_FORMAT_MPTOPDF_DIRS= \
+	${TEXMFVARDIR}/web2c/pdftex
+post-install-mptopdf:
+	${LN} -sf pdftex ${PREFIX}/bin/mptopdf
+
+TEX_FORMAT_PDFTEX?= \
+	"pdftex pdftex language.def -translate-file=cp227.tcx *pdfetex.ini" \
+	"etex pdftex language.def -translate-file=cp227.tcx *etex.ini" \
+	"pdfetex pdftex language.def -translate-file=cp227.tcx *pdfetex.ini"
+TEX_FORMAT_PDFTEX_FILES= \
+	${TEXMFVARDIR}/web2c/pdftex/pdftex.log \
+	${TEXMFVARDIR}/web2c/pdftex/pdftex.fmt \
+	${TEXMFVARDIR}/web2c/pdftex/etex.log \
+	${TEXMFVARDIR}/web2c/pdftex/etex.fmt \
+	${TEXMFVARDIR}/web2c/pdftex/pdfetex.log \
+	${TEXMFVARDIR}/web2c/pdftex/pdfetex.fmt \
+	bin/pdfetex
+TEX_FORMAT_PDFTEX_DIRS= \
+	${TEXMFVARDIR}/web2c/pdftex
+post-install-pdftex:
+	${LN} -sf pdftex ${PREFIX}/bin/pdfetex
+
+TEX_FORMAT_PTEX?= \
+	"ptex ptex - ptex.ini" \
+	"ptex eptex language.def *eptex.ini" \
+	"platex eptex language.dat *platex.ini"
+TEX_FORMAT_PTEX_FILES= \
+	${TEXMFVARDIR}/web2c/ptex/ptex.log \
+	${TEXMFVARDIR}/web2c/ptex/ptex.fmt \
+	${TEXMFVARDIR}/web2c/eptex/ptex.log \
+	${TEXMFVARDIR}/web2c/eptex/ptex.fmt \
+	${TEXMFVARDIR}/web2c/eptex/platex.log \
+	${TEXMFVARDIR}/web2c/eptex/platex.fmt \
+	bin/platex
+TEX_FORMAT_PTEX_DIRS= \
+	${TEXMFVARDIR}/web2c/ptex \
+	${TEXMFVARDIR}/web2c/eptex
+post-install-ptex:
+	${LN} -sf eptex ${PREFIX}/bin/platex
+
+TEX_FORMAT_TEX?= \
+	"tex tex - tex.ini"
+TEX_FORMAT_TEX_FILES= \
+	${TEXMFVARDIR}/web2c/tex/tex.log \
+	${TEXMFVARDIR}/web2c/tex/tex.fmt
+TEX_FORMAT_TEX_DIRS= \
+	${TEXMFVARDIR}/web2c/tex
+post-install-tex:
+	@${DO_NADA}
+
+TEX_FORMAT_TEXSIS?= \
+	"texsis pdftex - -translate-file=cp227.tcx texsis.ini"
+TEX_FORMAT_TEXSIS_FILES= \
+	${TEXMFVARDIR}/web2c/pdftex/texsis.log \
+	${TEXMFVARDIR}/web2c/pdftex/texsis.fmt \
+	bin/texsis
+TEX_FORMAT_TEXSIS_DIRS= \
+	${TEXMFVARDIR}/web2c/pdftex
+post-install-texsis:
+	${LN} -sf pdftex ${PREFIX}/bin/texsis
+
+TEX_FORMAT_UPTEX?= \
+	"uptex uptex - uptex.ini" \
+	"euptex euptex language.def *euptex.ini" \
+	"uplatex euptex language.dat *uplatex.ini"
+TEX_FORMAT_UPTEX_FILES=	\
+	${TEXMFVARDIR}/web2c/euptex/euptex.log \
+	${TEXMFVARDIR}/web2c/euptex/euptex.fmt \
+	${TEXMFVARDIR}/web2c/uptex/uptex.log \
+	${TEXMFVARDIR}/web2c/uptex/uptex.fmt \
+	${TEXMFVARDIR}/web2c/euptex/uplatex.log \
+	${TEXMFVARDIR}/web2c/euptex/uplatex.fmt \
+	bin/uplatex
+TEX_FORMAT_UPTEX_DIRS=	\
+	${TEXMFVARDIR}/web2c/euptex \
+	${TEXMFVARDIR}/web2c/uptex
+post-install-uptex:
+	${LN} -sf euptex ${PREFIX}/bin/uplatex
+
+TEX_FORMAT_XETEX?= \
+	"xetex xetex language.def -etex xetex.ini" \
+	"xelatex xetex language.dat -etex xelatex.ini" \
+	"cont-en xetex cont-usr.tex -8bit *cont-en.ini"
+TEX_FORMAT_XETEX_FILES=	\
+	${TEXMFVARDIR}/web2c/xetex/xetex.log \
+	${TEXMFVARDIR}/web2c/xetex/xetex.fmt \
+	${TEXMFVARDIR}/web2c/xetex/xelatex.log \
+	${TEXMFVARDIR}/web2c/xetex/xelatex.fmt \
+	${TEXMFVARDIR}/web2c/xetex/cont-en.log \
+	${TEXMFVARDIR}/web2c/xetex/cont-en.fmt \
+	bin/xelatex
+TEX_FORMAT_XETEX_DIRS=	\
+	${TEXMFVARDIR}/web2c/xetex
+post-install-xetex:
+	${LN} -sf xetex ${PREFIX}/bin/xelatex
+
+TEX_FORMAT_XMLTEX?= \
+	"xmltex pdftex language.dat *xmltex.ini" \
+	"pdfxmltex pdftex language.dat *pdfxmltex.ini"
+TEX_FORMAT_XMLTEX_FILES= \
+	${TEXMFVARDIR}/web2c/pdftex/xmltex.log \
+	${TEXMFVARDIR}/web2c/pdftex/xmltex.fmt \
+	${TEXMFVARDIR}/web2c/pdftex/pdfxmltex.log \
+	${TEXMFVARDIR}/web2c/pdftex/pdfxmltex.fmt \
+	bin/xmltex \
+	bin/pdfxmltex
+TEX_FORMAT_XMLTEX_DIRS= \
+	${TEXMFVARDIR}/web2c/pdftex
+post-install-xmltex:
+	${LN} -sf pdftex ${PREFIX}/bin/xmltex
+	${LN} -sf pdftex ${PREFIX}/bin/pdfxmltex

Modified: head/UPDATING
==============================================================================
--- head/UPDATING	Mon May  6 00:42:27 2013	(r317451)
+++ head/UPDATING	Mon May  6 00:44:22 2013	(r317452)
@@ -5,6 +5,51 @@ they are unavoidable.
 You should get into the habit of checking this file for changes each time
 you update your ports collection, before attempting any port upgrades.
 
+20130506:
+  AFFECTS: users of TeX
+  AUTHOR: hrs@FreeBSD.org
+
+  TeXLive ports have been imported.  Although most of ports still depend
+  on teTeX at this moment, they will be converted to use TeXLive.
+
+  The directory layout of them is as follows.  Please use print/texlive-full
+  if you are not familiar with how each component works.  Finer-grained
+  ports will be added (specifically, meta ports for smaller installation
+  and so on).  Note that the full installation needs around 3GB of disk space.
+
+  teTeX-based ports and TeXLive are mutually exclusive.  This means TeXLive
+  ports cannot be installed when teTeX is already installed.  You need
+  to remove all of the TeX-related packages based on teTeX to try TeXLive.
+  Migration procedure will be announced when conversion of the port
+  dependency is completed.
+
+  * Meta port
+   - print/texlive-full: meta port to install all of the TeXLive components
+
+  * Libraries
+   - devel/tex-kpathsea: kpathsea library
+   - devel/tex-web2c: WEB2C toolchain and TeX engines
+   - print/tex-ptexenc: character code conversion library for pTeX
+
+  * Base part of the TeXLive
+   - print/texlive-base: binary programs in TeXLive
+   - print/texlive-texmf: macro and font data in TeXLive
+   - print/texlive-infra: tlmgr dependency (Perl modules)
+   - print/tex-formats:
+
+  * TeX Formats
+   - print/tex-formats: TeX, LaTeX, PDFTeX, AMSTeX, ConTeXT, CSLaTeX,
+       EplainTeX, METAFONT, MLTeX, PDFTeX, TeXsis
+   - print/tex-aleph: Aleph/Lambda
+   - print/tex-xetex: XeTeX
+   - print/tex-luatex: LuaTeX
+   - print/tex-jadetex: JadeTeX
+   - print/tex-xmltex: XMLTeX
+   - japanese/tex-ptex: pTeX
+
+  * DVI ware
+   - print/tex-xdvik: XDvi
+ 
 20130503:
   AFFECTS: users of security/libgcrypt and any port that depends on it
   AUTHOR: ehaupt@FreeBSD.org

Modified: head/devel/Makefile
==============================================================================
--- head/devel/Makefile	Mon May  6 00:42:27 2013	(r317451)
+++ head/devel/Makefile	Mon May  6 00:44:22 2013	(r317452)
@@ -4308,6 +4308,8 @@
     SUBDIR += tdl
     SUBDIR += terminality
     SUBDIR += tevent
+    SUBDIR += tex-kpathsea
+    SUBDIR += tex-web2c
     SUBDIR += thrift
     SUBDIR += thunar-vcs-plugin
     SUBDIR += tide

Added: head/devel/tex-kpathsea/Makefile
==============================================================================
--- /dev/null	00:00:00 1970	(empty, because file is newly added)
+++ head/devel/tex-kpathsea/Makefile	Mon May  6 00:44:22 2013	(r317452)
@@ -0,0 +1,27 @@
+# $FreeBSD$
+
+PORTNAME=	kpathsea
+PORTVERSION=	6.1.0
+CATEGORIES=	devel
+MASTER_SITES=	ftp://tug.org/historic/systems/texlive/2012/
+PKGNAMEPREFIX=	tex-
+DISTNAME=	texlive-20120701-source
+
+MAINTAINER=	hrs@FreeBSD.org
+COMMENT=	Path searching library for TeX
+
+USE_XZ=		yes
+USE_TEX=	yes
+USE_GMAKE=	yes
+USE_LDCONFIG=	yes
+EXTRACT_AFTER_ARGS=	${EXTRACT_FILES}
+EXTRACT_FILES=	${DISTNAME}/build-aux \
+		${DISTNAME}/texk/kpathsea
+WRKSRC=		${WRKDIR}/${DISTNAME}/texk/kpathsea
+GNU_CONFIGURE=	yes
+
+INFO=	kpathsea
+MAN1=	kpseaccess.1 kpsereadlink.1 kpsestat.1 kpsewhich.1 mktexlsr.1 \
+	mktexmf.1 mktexpk.1 mktextfm.1 texhash.1
+
+.include <bsd.port.mk>

Added: head/devel/tex-kpathsea/distinfo
==============================================================================
--- /dev/null	00:00:00 1970	(empty, because file is newly added)
+++ head/devel/tex-kpathsea/distinfo	Mon May  6 00:44:22 2013	(r317452)
@@ -0,0 +1,2 @@
+SHA256 (TeX/texlive-20120701-source.tar.xz) = 9666617d5dac3e82578e696835cc9f251ee0a56d162d86dff08659ac5dcb6c81
+SIZE (TeX/texlive-20120701-source.tar.xz) = 131904044

Added: head/devel/tex-kpathsea/files/patch-texmf.cnf
==============================================================================
--- /dev/null	00:00:00 1970	(empty, because file is newly added)
+++ head/devel/tex-kpathsea/files/patch-texmf.cnf	Mon May  6 00:44:22 2013	(r317452)
@@ -0,0 +1,47 @@
+--- texmf.cnf.orig	2012-05-13 08:34:52.000000000 +0900
++++ texmf.cnf	2013-03-03 03:22:42.000000000 +0900
+@@ -51,7 +51,7 @@
+ % Redistributors will probably want $SELFAUTODIR/share, i.e., /usr/share.
+ % Kpathsea sets SELFAUTOLOC (the directory with the binary),
+ % SELFAUTODIR (its parent), and SELFAUTOPARENT (its grandparent).
+-TEXMFROOT = $SELFAUTOPARENT
++TEXMFROOT = $SELFAUTODIR/share
+ 
+ % The tree containing runtime files related to the specific
+ % distribution and version.
+@@ -61,7 +61,7 @@
+ TEXMFDIST = $TEXMFROOT/texmf-dist
+ 
+ % Local additions to the distribution trees.
+-TEXMFLOCAL = $TEXMFROOT/../texmf-local
++TEXMFLOCAL = $TEXMFROOT/texmf-local
+ 
+ % TEXMFSYSVAR, where *-sys store cached runtime data.
+ TEXMFSYSVAR = $TEXMFROOT/texmf-var
+@@ -698,7 +698,7 @@
+ pool_size = 3250000
+ % Minimum pool space after TeX's own strings; must be at least
+ % 25000 less than pool_size, but doesn't need to be nearly that large.
+-string_vacancies = 90000
++string_vacancies = 150000
+ % Maximum number of strings.
+ max_strings = 500000
+ % min pool space left after loading .fmt
+@@ -708,7 +708,7 @@
+ % expansion works by writing material into the buffer and reparsing the
+ % line.  As a consequence, certain constructs require the buffer to be
+ % very large, even though most documents can be handled with a small value.
+-buf_size = 200000
++buf_size = 300000
+ 
+ % Hyphenation trie.  The maximum possible is 4194303 (ssup_trie_size in
+ % the sources), but we don't need that much.  The value here suffices
+@@ -719,7 +719,7 @@
+ 
+ hyph_size = 8191        % prime number of hyphenation exceptions, >610, <32767.
+                         % http://primes.utm.edu/curios/page.php/8191.html
+-nest_size = 500         % simultaneous semantic levels (e.g., groups)
++nest_size = 2500        % simultaneous semantic levels (e.g., groups)
+ max_in_open = 15        % simultaneous input files and error insertions, 
+                         % also applies to MetaPost
+ param_size = 10000      % simultaneous macro parameters, also applies to MP

Added: head/devel/tex-kpathsea/pkg-descr
==============================================================================
--- /dev/null	00:00:00 1970	(empty, because file is newly added)
+++ head/devel/tex-kpathsea/pkg-descr	Mon May  6 00:44:22 2013	(r317452)
@@ -0,0 +1,5 @@
+Kpathsea is a library to do path searching.  It is used in the Web2C
+implementation of TeX and friends.  The library's fundamental purpose
+is to return a filename from a list of directories specified by the
+user, similar to what shells do when looking up program names to
+execute.

Added: head/devel/tex-kpathsea/pkg-plist
==============================================================================
--- /dev/null	00:00:00 1970	(empty, because file is newly added)
+++ head/devel/tex-kpathsea/pkg-plist	Mon May  6 00:44:22 2013	(r317452)
@@ -0,0 +1,69 @@
+@comment $FreeBSD$
+bin/kpseaccess
+bin/kpsereadlink
+bin/kpsestat
+bin/kpsewhich
+bin/mktexlsr
+bin/mktexmf
+bin/mktexpk
+bin/mktextfm
+bin/texhash
+include/kpathsea/absolute.h
+include/kpathsea/c-auto.h
+include/kpathsea/c-ctype.h
+include/kpathsea/c-dir.h
+include/kpathsea/c-errno.h
+include/kpathsea/c-fopen.h
+include/kpathsea/c-limits.h
+include/kpathsea/c-memstr.h
+include/kpathsea/c-minmax.h
+include/kpathsea/c-namemx.h
+include/kpathsea/c-pathch.h
+include/kpathsea/c-pathmx.h
+include/kpathsea/c-proto.h
+include/kpathsea/c-stat.h
+include/kpathsea/c-std.h
+include/kpathsea/c-unistd.h
+include/kpathsea/cnf.h
+include/kpathsea/concatn.h
+include/kpathsea/config.h
+include/kpathsea/debug.h
+include/kpathsea/expand.h
+include/kpathsea/getopt.h
+include/kpathsea/hash.h
+include/kpathsea/knj.h
+include/kpathsea/kpathsea.h
+include/kpathsea/lib.h
+include/kpathsea/line.h
+include/kpathsea/magstep.h
+include/kpathsea/mingw32.h
+include/kpathsea/paths.h
+include/kpathsea/pathsearch.h
+include/kpathsea/proginit.h
+include/kpathsea/progname.h
+include/kpathsea/readable.h
+include/kpathsea/str-list.h
+include/kpathsea/str-llist.h
+include/kpathsea/systypes.h
+include/kpathsea/tex-file.h
+include/kpathsea/tex-glyph.h
+include/kpathsea/tex-hush.h
+include/kpathsea/tex-make.h
+include/kpathsea/types.h
+include/kpathsea/variable.h
+include/kpathsea/version.h
+include/kpathsea/win32lib.h
+@dirrm include/kpathsea
+lib/libkpathsea.a
+lib/libkpathsea.la
+lib/libkpathsea.so
+lib/libkpathsea.so.7
+%%TEXMFDIR%%/web2c/mktex.opt
+%%TEXMFDIR%%/web2c/mktexdir
+%%TEXMFDIR%%/web2c/mktexdir.opt
+%%TEXMFDIR%%/web2c/mktexnam
+%%TEXMFDIR%%/web2c/mktexnam.opt
+%%TEXMFDIR%%/web2c/mktexupd
+%%TEXMFDIR%%/web2c/texmf.cnf
+@dirrmtry %%TEXMFDIR%%/web2c
+@dirrmtry %%TEXMFDIR%%

Added: head/devel/tex-web2c/Makefile
==============================================================================
--- /dev/null	00:00:00 1970	(empty, because file is newly added)
+++ head/devel/tex-web2c/Makefile	Mon May  6 00:44:22 2013	(r317452)
@@ -0,0 +1,70 @@
+# $FreeBSD$
+
+PORTNAME=	web2c
+PORTVERSION=	20120701
+CATEGORIES=	devel
+MASTER_SITES=	ftp://tug.org/historic/systems/texlive/2012/
+PKGNAMEPREFIX=	tex-
+DISTNAME=	texlive-${PORTVERSION}-source
+
+MAINTAINER=	hrs@FreeBSD.org
+COMMENT=	TeX implementation translating WEB to C
+
+LIB_DEPENDS=	openjpeg:${PORTSDIR}/graphics/openjpeg \
+		png15:${PORTSDIR}/graphics/png \
+		zzip:${PORTSDIR}/devel/zziplib
+
+USE_XZ=		yes
+USE_GMAKE=	yes
+USE_TEX=	kpathsea
+EXTRACT_AFTER_ARGS=	${EXTRACT_FILES}
+EXTRACT_FILES=	${DISTNAME}/build-aux \
+		${DISTNAME}/libs/obsdcompat \
+		${DISTNAME}/libs/xpdf \
+		${DISTNAME}/texk/web2c
+WRKSRC=		${WRKDIR}/${DISTNAME}/texk/web2c
+GNU_CONFIGURE=	yes
+CONFIGURE_ENV=	OBSDCOMPAT_INCLUDES=-I${WRKSRC}/../../libs/obsdcompat
+CONFIGURE_ARGS= --disable-luatex \
+		--disable-xetex \
+		--disable-aleph \
+		--disable-ptex \
+		--disable-eptex \
+		--disable-uptex \
+		--disable-euptex \
+		--with-x=no \
+		--without-mf-x-toolkit \
+		--with-system-icu \
+		--with-icu-includes=${LOCALBASE}/include \
+		--with-icu-libdir=${LOCALBASE}/lib \
+		--with-system-kpathsea \
+		--with-kpathsea-includes=${LOCALBASE}/include \
+		--with-kpathsea-libdir=${LOCALBASE}/lib \
+		--with-system-libpng \
+		--with-libpng-includes=${LOCALBASE}/include \
+		--with-libpng-libdir=${LOCALBASE}/lib \
+		--with-system-zlib \
+		--with-system-zziplib
+CFLAGS+=	-I${LOCALBASE}/include
+MAKE_JOBS_SAFE=	yes
+
+INFO=	web2c
+NO_MANCOMPRESS=	yes
+MAN1=	ctie.1 cweb.1 tangle.1 tie.1 bibtex.1 dvicopy.1 dvitomp.1	\
+	dvitype.1 gftodvi.1 gftopk.1 gftype.1 mft.1 patgen.1 pktogf.1	\
+	pktype.1 pltotf.1 pooltype.1 tftopl.1 vftovp.1 vptovf.1		\
+	weave.1 tex.1 mf.1 mpost.1 pdftex.1 pdftosrc.1 ttf2afm.1	\
+	amstex.1	\
+	eplain.1 latex.1 pdfetex.1
+MLINKS=	cweb.1 ctangle.1 \
+	cweb.1 cweave.1 \
+	mf.1 mf-nowin.1 \
+	pdftex.1 pdflatex.1
+
+pre-configure:
+	for D in libs/obsdcompat libs/xpdf; do \
+		cd ${WRKDIR}/${DISTNAME}/$$D && \
+		${SETENV} ${CONFIGURE_ENV} ${SH} ${CONFIGURE_SCRIPT} ${CONFIGURE_ARGS}; \
+	done
+
+.include <bsd.port.mk>

Added: head/devel/tex-web2c/distinfo
==============================================================================
--- /dev/null	00:00:00 1970	(empty, because file is newly added)
+++ head/devel/tex-web2c/distinfo	Mon May  6 00:44:22 2013	(r317452)
@@ -0,0 +1,2 @@
+SHA256 (TeX/texlive-20120701-source.tar.xz) = 9666617d5dac3e82578e696835cc9f251ee0a56d162d86dff08659ac5dcb6c81
+SIZE (TeX/texlive-20120701-source.tar.xz) = 131904044

Added: head/devel/tex-web2c/pkg-descr
==============================================================================
--- /dev/null	00:00:00 1970	(empty, because file is newly added)
+++ head/devel/tex-web2c/pkg-descr	Mon May  6 00:44:22 2013	(r317452)
@@ -0,0 +1,3 @@
+Web2c, a system which converts TeX, Metafont, and other related WEB programs
+to C.  By itself, it is not a complete, ready-to-run, TeX distribution, nor
+is it a general-purpose Pascal-to-C or WEB-to-C translator.

Added: head/devel/tex-web2c/pkg-plist
==============================================================================
--- /dev/null	00:00:00 1970	(empty, because file is newly added)
+++ head/devel/tex-web2c/pkg-plist	Mon May  6 00:44:22 2013	(r317452)
@@ -0,0 +1,30 @@
+@comment $FreeBSD$
+bin/tangle
+bin/ctangle
+bin/bibtex
+bin/dvicopy
+bin/dvitype
+bin/gftodvi
+bin/gftopk
+bin/gftype
+bin/mft
+bin/patgen
+bin/pktogf
+bin/pktype
+bin/pltotf
+bin/pooltype
+bin/tftopl
+bin/vftovp
+bin/vptovf
+bin/weave
+bin/ctie
+bin/cweave
+bin/tie
+bin/tex
+bin/mf
+bin/mf-nowin
+bin/mpost
+bin/pdftex
+bin/ttf2afm
+bin/pdftosrc
+bin/synctex

Modified: head/japanese/Makefile
==============================================================================
--- head/japanese/Makefile	Mon May  6 00:42:27 2013	(r317451)
+++ head/japanese/Makefile	Mon May  6 00:44:22 2013	(r317452)
@@ -315,6 +315,7 @@
     SUBDIR += teTeX
     SUBDIR += tegaki-recognize
     SUBDIR += tegaki-zinnia-japanese
+    SUBDIR += tex-ptex
     SUBDIR += texfamily
     SUBDIR += texfamily-vfn2a
     SUBDIR += texinfo

Added: head/japanese/tex-ptex/Makefile
==============================================================================
--- /dev/null	00:00:00 1970	(empty, because file is newly added)
+++ head/japanese/tex-ptex/Makefile	Mon May  6 00:44:22 2013	(r317452)
@@ -0,0 +1,102 @@
+# $FreeBSD$
+
+PORTNAME=	ptex
+PORTVERSION=	3.3
+DISTVERSION=	20120701
+CATEGORIES=	japanese print
+MASTER_SITES=	ftp://tug.org/historic/systems/texlive/2012/
+PKGNAMEPREFIX=	tex-
+DISTNAME=	texlive-${DISTVERSION}-source
+DISTFILES=	${DISTNAME}${EXTRACT_SUFX} \
+		${DISTNAME_TEXMF}${EXTRACT_SUFX}
+EXTRACT_ONLY=	texlive-${DISTVERSION}-source${EXTRACT_SUFX}
+
+MAINTAINER=	hrs@FreeBSD.org
+COMMENT=	ASCII Japanese pTeX
+
+USE_XZ=		yes
+USE_GMAKE=	yes
+USE_TEX=	kpathsea web2c ptexenc texmf formats fmtutil
+EXTRACT_AFTER_ARGS=	${EXTRACT_FILES:S,^,${DISTNAME}/,}
+EXTRACT_FILES=	\
+	build-aux \
+	libs/obsdcompat \
+	libs/xpdf \
+	texk/web2c
+EXTRACT_AFTER_ARGS_TEXMF= \
+	| ${TAR} -xf - -C ${PREFIX}/share \
+		--strip-components 1 --no-same-permission --no-same-owner \
+		${EXTRACT_FILES_TEXMF:S,^,${DISTNAME_TEXMF}/,}
+DISTNAME_TEXMF=	texlive-${DISTVERSION}-texmf
+EXTRACT_FILES_TEXMF= \
+	texmf-dist/doc/ptex \
+	texmf-dist/doc/platex \
+	texmf-dist/doc/uptex \
+	texmf-dist/doc/uplatex \
+	texmf-dist/doc/fonts/japanese-otf \
+	texmf-dist/doc/fonts/japanese-otf-uptex \
+	texmf-dist/doc/fonts/jfontmaps \
+	texmf-dist/fonts/source/ptex \
+	texmf-dist/fonts/ovp/public/japanese-otf-uptex \
+	texmf-dist/fonts/vf/ptex \
+	texmf-dist/fonts/vf/uptex \
+	texmf-dist/fonts/vf/public/japanese-otf \
+	texmf-dist/fonts/vf/public/japanese-otf-uptex \
+	texmf-dist/fonts/type1/ptex \
+	texmf-dist/fonts/tfm/ptex \
+	texmf-dist/fonts/tfm/uptex \
+	texmf-dist/fonts/tfm/public/japanese-otf-uptex \
+	texmf-dist/fonts/tfm/public/japanese-otf \
+	texmf-dist/fonts/ofm/public/japanese-otf \
+	texmf-dist/source/fonts/uptex \
+	texmf-dist/source/fonts/japanese-otf-uptex \
+	texmf-dist/source/fonts/japanese-otf \
+	texmf-dist/source/platex \
+	texmf-dist/source/uplatex \
+	texmf-dist/tex/ptex \
+	texmf-dist/tex/uptex \
+	texmf-dist/tex/platex \
+	texmf-dist/tex/uplatex \
+	texmf-dist/tex/generic/hyph-utf8/patterns/ptex \
+	texmf-dist/fonts/map/dvipdfmx/ptex \
+	texmf-dist/fonts/map/dvipdfmx/uptex \
+	texmf-dist/fonts/map/dvipdfmx/japanese-otf-uptex \
+	texmf-dist/fonts/map/dvipdfmx/japanese-otf \
+	texmf-dist/fonts/map/dvipdfmx/jfontmaps \
+	texmf/fonts/map/dvipdfmx/updmap/kanjix.map \
+	texmf-dist/fonts/cmap/uptex
+WRKSRC=		${WRKDIR}/${DISTNAME}/texk/web2c
+GNU_CONFIGURE=	yes
+CONFIGURE_ENV=	OBSDCOMPAT_INCLUDES=-I${WRKSRC}/../../libs/obsdcompat
+EXCLUDE_ENGINES= aleph etex luatex pdftex mf mf-nowin xetex
+#		--disable-web-progs \
+CONFIGURE_ARGS=	${EXCLUDE_ENGINES:S/^/--disable-/} \
+		--enable-ptex \
+		--enable-eptex \
+		--enable-uptex \
+		--enable-euptex \
+		--disable-mp \
+		--enable-web2c \
+		--enable-web-progs \
+		--with-system-kpathsea \
+		--with-kpathsea-includes=${LOCALBASE}/include \
+		--with-kpathsea-libdir=${LOCALBASE}/lib \
+		--with-system-ptexenc \
+		--with-ptexenc-includes=${LOCALBASE}/include \
+		--with-ptexenc-libdir=${LOCALBASE}/lib \
+		--with-system-zlib
+CFLAGS+=	-I${LOCALBASE}/include
+MAKE_JOBS_UNSAFE=	yes
+TEX_FORMATS=	ptex uptex
+
+pre-configure:
+	for D in libs/obsdcompat libs/xpdf; do \
+		cd ${WRKDIR}/${DISTNAME}/$$D && \
+		${SETENV} ${CONFIGURE_ENV} ${SH} ${CONFIGURE_SCRIPT} ${CONFIGURE_ARGS}; \
+	done
+
+pre-su-install:
+	${CAT} ${DISTDIR}/${DIST_SUBDIR}/texlive-${DISTVERSION}-texmf${EXTRACT_SUFX} \
+		${EXTRACT_AFTER_ARGS_TEXMF}
+
+.include <bsd.port.mk>

Added: head/japanese/tex-ptex/distinfo
==============================================================================
--- /dev/null	00:00:00 1970	(empty, because file is newly added)
+++ head/japanese/tex-ptex/distinfo	Mon May  6 00:44:22 2013	(r317452)
@@ -0,0 +1,4 @@
+SHA256 (TeX/texlive-20120701-source.tar.xz) = 9666617d5dac3e82578e696835cc9f251ee0a56d162d86dff08659ac5dcb6c81

*** DIFF OUTPUT TRUNCATED AT 1000 LINES ***
_______________________________________________
svn-ports-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/svn-ports-all
To unsubscribe, send any mail to "svn-ports-all-unsubscribe@freebsd.org"
Comment 14 Hiroki Sato freebsd_committer 2013-05-06 02:20:11 UTC
State Changed
From-To: open->closed

TeXLive ports have been committed.