Bug 171899

Summary: editors/openoffice-3-devel: Openoffice 3.4.1 build failure
Product: Ports & Packages Reporter: russo
Component: Individual Port(s)Assignee: FreeBSD Office Team <office>
Status: Closed FIXED    
Severity: Affects Only Me    
Priority: Normal    
Version: Latest   
Hardware: Any   
OS: Any   

Description russo 2012-09-23 22:30:12 UTC
Trying to portupgrade openoffice from 3.4.0_3 to 3.4.1, getting failure with the following output:

.. cd /users/scratch/usr/ports/editors/openoffice-3/work/aoo-3.4.1/main/instsetoo_native/unxfbsdi.pro/URE/archive/install/en-US_inprogress_temp.11429;  tar -cf - . | gzip > /users/scratch/usr/ports/editors/openoffice-3/work/aoo-3.4.1/main/instsetoo_native/unxfbsdi.pro/URE/archive/install/en-US_inprogress/Apache_OpenOffice_incubating-URE_3.4.1_FreeBSD_install-arc_en-US.tar.gz ...
------------------------------------
.. languages en-US ... 
.. analyzing files ...
.. removing /users/scratch/usr/ports/editors/openoffice-3/work/aoo-3.4.1/main/instsetoo_native/unxfbsdi.pro/URE/archive/install/en-US_inprogress_temp.11429 ...
.. cleaning the output tree ...
.. removing directory /tmp/ooopackaging/i_114291348427558 ...
.. checking log file /users/scratch/usr/ports/editors/openoffice-3/work/aoo-3.4.1/main/instsetoo_native/unxfbsdi.pro/URE/archive/logging/en-US/log_AOO341_en-US.log

***********************************************************
Successful packaging process!
***********************************************************
.. creating log file log_AOO341_en-US.log 
Sun Sep 23 13:12:42 2012 (00:04 min.)
preparing 0 extension blobs for language en-US:
preparing 0 bundled extensions for language en-US:
    
ERROR: The following files could not be found: 
ERROR: File not found: fc_local.conf
ERROR: File not found: Arimo-Bold.ttf
ERROR: File not found: Arimo-BoldItalic.ttf
ERROR: File not found: Arimo-Italic.ttf
ERROR: File not found: Arimo-Regular.ttf
ERROR: File not found: Cousine-Bold.ttf
ERROR: File not found: Cousine-BoldItalic.ttf
ERROR: File not found: Cousine-Italic.ttf
ERROR: File not found: Cousine-Regular.ttf
ERROR: File not found: GenBasB.ttf
ERROR: File not found: GenBasBI.ttf
ERROR: File not found: GenBasI.ttf
ERROR: File not found: GenBasR.ttf
ERROR: File not found: GenBkBasB.ttf
ERROR: File not found: GenBkBasBI.ttf
ERROR: File not found: GenBkBasI.ttf
ERROR: File not found: GenBkBasR.ttf
ERROR: File not found: SymbolNeu.ttf
ERROR: File not found: Tinos-Bold.ttf
ERROR: File not found: Tinos-BoldItalic.ttf
ERROR: File not found: Tinos-Italic.ttf
ERROR: File not found: Tinos-Regular.ttf
.. cleaning the output tree ...
.. removing directory /tmp/ooopackaging/i_114301348427558 ...

**************************************************
ERROR: ERROR: Missing files
in function: remove_Files_Without_Sourcedirectory
**************************************************

**************************************************
ERROR: Saved logfile: /users/scratch/usr/ports/editors/openoffice-3/work/aoo-3.4.1/main/instsetoo_native/unxfbsdi.pro/OpenOffice/archive/logging/en-US/log_AOO341_en-US.log
**************************************************
Sun Sep 23 13:12:42 2012 (00:04 min.)
dmake:  Error code 255, while making 'openoffice_en-US.archive'

1 module(s): 
        instsetoo_native
need(s) to be rebuilt

Reason(s):

ERROR: error 65280 occurred while making /users/scratch/usr/ports/editors/openoffice-3/work/aoo-3.4.1/main/instsetoo_native/util

When you have fixed the errors in that module you can resume the build by running:

        build --from instsetoo_native

*** [do-build] Error code 1

Stop in /usr/ports/editors/openoffice-3.
*** [build] Error code 1

Stop in /usr/ports/editors/openoffice-3.
** Command failed [exit code 1]: /usr/bin/script -qa /tmp/portupgrade20120923-22046-v2z7r6-0 env UPGRADE_TOOL=portupgrade UPGRADE_PORT=apache-openoffice-3.4.0_3 UPGRADE_PORT_VER=3.4.0_3 make
** Fix the problem and try again.


I'd attach the referenced log file log_AOO341_en-US.log, but it is too large.

How-To-Repeat: Try to build openoffice-3.4.1
Comment 1 Tom Russo 2012-09-24 18:08:45 UTC
The issue is that "croscorefonts" was not installed for 3.4.0, and it was
not pulled in as a dependency when trying to portupgrade.   Doing a "make
depends" in the ports/editors/openoffice-3 directory before the portupgrade
was required.
Comment 2 Mark Linimon freebsd_committer freebsd_triage 2012-10-05 04:36:41 UTC
Responsible Changed
From-To: freebsd-ports-bugs->openoffice

Over to maintainer(s).
Comment 3 Baptiste Daroussin freebsd_committer 2012-10-08 12:40:01 UTC
Responsible Changed
From-To: openoffice->freebsd-office

Over to maintainer.
Comment 4 Mark Linimon freebsd_committer freebsd_triage 2013-03-10 02:05:41 UTC
Responsible Changed
From-To: freebsd-office->office

Canonicalize assignment.
Comment 5 Mark Linimon freebsd_committer freebsd_triage 2014-01-04 06:50:14 UTC
State Changed
From-To: open->closed

this PR applies to an older version of openoffice.  I'm sorry that 
we did not get to this in a timely fashion.