Bug 175528

Summary: [PATCH] fix install of graphics/gd
Product: Ports & Packages Reporter: Niclas Zeising <zeising>
Component: Individual Port(s)Assignee: Dirk Meyer <dinoex>
Status: Closed FIXED    
Severity: Affects Only Me    
Priority: Normal    
Version: Latest   
Hardware: Any   
OS: Any   
Attachments:
Description Flags
ports.gd.diff none

Description Niclas Zeising 2013-01-23 12:30:00 UTC
	The NOPROFILE option has been deprecated in favor of NO_PROFILE, but graphics/gd isn't updated.  This causes the Makefile to try to install a profiled library libgd_p.a, but this library doesn't exist and the build/install fails.

Fix: Attached patch fixes the issue, renaming NOPROFILE to NO_PROFILE.
How-To-Repeat: 	Build graphics/gd on a clean 10-current system.
Comment 1 Edwin Groothuis freebsd_committer 2013-01-23 12:30:14 UTC
Responsible Changed
From-To: freebsd-ports-bugs->dinoex

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 2 dfilter service freebsd_committer 2013-01-26 14:21:35 UTC
Author: dinoex
Date: Sat Jan 26 14:21:23 2013
New Revision: 311011
URL: http://svnweb.freebsd.org/changeset/ports/311011

Log:
  - fix build for 10-CURRENT
  PR:		175528
  Submitted by:	Matthias Andree

Modified:
  head/graphics/gd/files/Makefile.bsd

Modified: head/graphics/gd/files/Makefile.bsd
==============================================================================
--- head/graphics/gd/files/Makefile.bsd	Sat Jan 26 14:20:09 2013	(r311010)
+++ head/graphics/gd/files/Makefile.bsd	Sat Jan 26 14:21:23 2013	(r311011)
@@ -40,7 +40,7 @@ ${PROGS} ${TESTS}: ${SHLIB_NAME} lib${LI
 
 install:
 	mkdir -p ${PREFIX}/include
-	${MAKE} LIB=${LIB} LIBDIR=${PREFIX}/lib NOPROFILE=true \
+	${MAKE} LIB=${LIB} LIBDIR=${PREFIX}/lib NOPROFILE=true NO_PROFILE=true \
 		SHLIB_MAJOR=${SHLIB_MAJOR} SHLIB_MINOR=${SHLIB_MINOR} \
 		-f ${MAKEDIR}/bsd.lib.mk install
 	cd ${.CURDIR} && ${BSD_INSTALL_DATA} ${INCS} ${PREFIX}/include
_______________________________________________
svn-ports-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/svn-ports-all
To unsubscribe, send any mail to "svn-ports-all-unsubscribe@freebsd.org"
Comment 3 Dirk Meyer freebsd_committer 2013-01-26 14:22:01 UTC
State Changed
From-To: open->closed

Due to regressions on older FreeBSD systems, 
a diffrent fix was committed, thanks.