Bug 177379

Summary: package building for x11/gnome-applets fails
Product: Ports & Packages Reporter: Stephen Montgomery-Smith <stephen>
Component: Individual Port(s)Assignee: freebsd-gnome (Nobody) <gnome>
Status: Closed FIXED    
Severity: Affects Only Me    
Priority: Normal    
Version: Latest   
Hardware: Any   
OS: Any   
Attachments:
Description Flags
file.diff none

Description Stephen Montgomery-Smith freebsd_committer 2013-03-25 18:50:00 UTC
If making a package or deinstalling x11/gnome-applets, it is obvious that some
entries in PLIST_SUB were not set properly.

How-To-Repeat: cd /usr/ports/x11/gnome-applets && make package
Comment 1 Edwin Groothuis freebsd_committer 2013-03-25 18:50:07 UTC
Responsible Changed
From-To: freebsd-ports-bugs->gnome

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 2 dfilter service freebsd_committer 2013-03-25 19:08:56 UTC
Author: kwm
Date: Mon Mar 25 19:08:43 2013
New Revision: 315241
URL: http://svnweb.freebsd.org/changeset/ports/315241

Log:
  Make plist_SUB add not overwrite.
  
  PR:		ports/177379
  Submitted by:	stephen@

Modified:
  head/x11/gnome-applets/Makefile

Modified: head/x11/gnome-applets/Makefile
==============================================================================
--- head/x11/gnome-applets/Makefile	Mon Mar 25 18:44:20 2013	(r315240)
+++ head/x11/gnome-applets/Makefile	Mon Mar 25 19:08:43 2013	(r315241)
@@ -74,10 +74,10 @@ PLIST_SUB+=	PYTHON="@comment "
 
 .if ${ARCH} != "i386" && ${ARCH} != "amd64"
 CFLAGS+=	-fPIC
-PLIST_SUB=	BATTERY="@comment "
+PLIST_SUB+=	BATTERY="@comment "
 .else
 GCONF_SCHEMAS+=	battstat.schemas
-PLIST_SUB=	BATTERY=""
+PLIST_SUB+=	BATTERY=""
 .endif
 
 .if ${ARCH} != "i386" && ${ARCH} != "amd64"
_______________________________________________
svn-ports-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/svn-ports-all
To unsubscribe, send any mail to "svn-ports-all-unsubscribe@freebsd.org"
Comment 3 Koop Mast freebsd_committer 2013-03-25 19:09:04 UTC
State Changed
From-To: open->closed

Committed thanks! 
I was onder the impression that I had this already fixed. Thanks for the report.