Bug 178115

Summary: Laptop (Asus X55VD) locks up when configuring wifi (Ralink RT5390) from LiveCD mode of official install medium
Product: Base System Reporter: purpleritza
Component: wirelessAssignee: freebsd-bugs mailing list <bugs>
Status: Closed FIXED    
Severity: Affects Many People CC: kevlo, shuriku
Priority: Normal    
Version: 10.0-RELEASE   
Hardware: Any   
OS: Any   
URL: http://forums.freebsd.org/viewtopic.php?f=12&t=39259

Description purpleritza 2013-04-24 20:10:00 UTC
I bought a new lappy the other day and I thought to power it with FreeBSD but seems it has some sort of problem with my ral0 WiFi chip (Ralink's RT5390) as whenever I try to enable WiFi by creating a wlan0 device and up it from official install DVD's LiveCD mode, the console locks up and I can't even change terminal. Keyboard and screen also lock up; only way out is to hard reset the laptop.

I figured Ralink chips are well supported but this one is giving me a headache for some reason. I tried both amd64 9.1-RELEASE and 10-CURRENT but to no avail.

Here's dmesg output from within the LiveCD:

http://hastebin.com/xabevukora.textile

Also, pciconf -l -v output:
http://hastebin.com/qusaxetapo.textile

I'm trying to configure WiFi by following the Handbook:

Code:
# ifconfig wlan0 create wlandev ral0
wlan0: Ethernet address: a4:17:31:0f:47:94
Code:
# ifconfig wlan0 up scan
And this is the place where everything locks up, on bringing device up. Let me know if I could do anything else. 

Thanks in advance.

How-To-Repeat: bring device up by:

# ifconfig wlan0 up
Comment 1 purpleritza 2014-07-31 12:37:12 UTC
Any feedback on this one?

Thanks
Comment 2 Alexandr Krivulya 2014-07-31 13:30:34 UTC
Could you try most recent CURRENT amd64 image:
ftp://ftp.freebsd.org/pub/FreeBSD/snapshots/ISO-IMAGES/11.0/

There are a lot of improvements since 10-CURRENT

Does your laptop reachable via ethernet after lockup?
Comment 3 purpleritza 2014-08-14 19:06:56 UTC
Tried. Same thing. Laptop freezes, only hard reboot works.
Comment 4 Kevin Lo freebsd_committer 2014-10-29 15:55:09 UTC
RT5390 is not supported by FreeBSD but I'm planning to add it support.
Please stay tuned. :-)
Comment 5 purpleritza 2014-10-29 15:57:05 UTC
(In reply to Kevin Lo from comment #4)
> RT5390 is not supported by FreeBSD but I'm planning to add it support.
> Please stay tuned. :-)

I'd be grateful and be your tester, please update this bug.
Thanks a ton!
Comment 6 purpleritza 2015-02-21 15:50:11 UTC
There is support for RT5390 since r278551 in 11-CURRENT.
Proof: http://i.imgur.com/jRjVJke.png

Thanks a ton Kevin!
Comment 7 Kevin Lo freebsd_committer 2015-02-22 15:36:35 UTC
Thanks for the feedback and testing.