Bug 179191

Summary: New port: editors/gummi
Product: Ports & Packages Reporter: nukama
Component: Individual Port(s)Assignee: Wen Heping <wen>
Status: Closed FIXED    
Severity: Affects Only Me    
Priority: Normal    
Version: Latest   
Hardware: Any   
OS: Any   
Attachments:
Description Flags
file.shar none

Description nukama 2013-06-02 06:10:00 UTC
Gummi is a LaTeX editor. It was designed with simplicity in mind

WWW: http://gummi.midnightcoding.org/

Dependent on ports/179189

Fix: Patch attached with submission follows:
How-To-Repeat: https://redports.org/buildarchive/20130602024959-75306/
Comment 1 Wen Heping freebsd_committer 2013-06-03 02:35:52 UTC
Responsible Changed
From-To: freebsd-ports-bugs->wen

I'll take it.
Comment 2 dfilter service freebsd_committer 2013-06-27 09:32:13 UTC
Author: wen
Date: Thu Jun 27 08:32:04 2013
New Revision: 321872
URL: http://svnweb.freebsd.org/changeset/ports/321872

Log:
  Gummi is a LaTeX editor. It was designed with simplicity in mind.
  
  WWW: http://gummi.midnightcoding.org/
  
  PR:		179191
  Submitted by:	Hakisho Nukama <nukama@gmail.com>

Added:
  head/editors/gummi/
  head/editors/gummi/Makefile   (contents, props changed)
  head/editors/gummi/distinfo   (contents, props changed)
  head/editors/gummi/files/
  head/editors/gummi/files/patch-po__Makefile.in.in   (contents, props changed)
  head/editors/gummi/files/patch-src__update.c   (contents, props changed)
  head/editors/gummi/pkg-descr   (contents, props changed)
  head/editors/gummi/pkg-plist   (contents, props changed)
Modified:
  head/editors/Makefile

Modified: head/editors/Makefile
==============================================================================
--- head/editors/Makefile	Thu Jun 27 08:24:51 2013	(r321871)
+++ head/editors/Makefile	Thu Jun 27 08:32:04 2013	(r321872)
@@ -84,6 +84,7 @@
     SUBDIR += gnuserv
     SUBDIR += gobby
     SUBDIR += gphpedit
+    SUBDIR += gummi
     SUBDIR += gwrite
     SUBDIR += heme
     SUBDIR += hexcurse

Added: head/editors/gummi/Makefile
==============================================================================
--- /dev/null	00:00:00 1970	(empty, because file is newly added)
+++ head/editors/gummi/Makefile	Thu Jun 27 08:32:04 2013	(r321872)
@@ -0,0 +1,64 @@
+# Created by: Hakisho Nukama <Nukama@gmail.com>
+# $FreeBSD$
+
+PORTNAME=	gummi
+PORTVERSION=	0.6.5
+CATEGORIES=	editors
+MASTER_SITES=	http://dev.midnightcoding.org/attachments/download/301/
+
+MAINTAINER=	nukama+maintainer@gmail.com
+COMMENT=	Simple LaTex editor for GTK users
+
+LICENSE=	MIT
+
+BUILD_DEPENDS+=	msgfmt:${PORTSDIR}/devel/gettext
+LIB_DEPENDS+=	poppler-glib:${PORTSDIR}/graphics/poppler-glib \
+		gtkspell:${PORTSDIR}/textproc/gtkspell
+
+USE_GMAKE=	yes
+GNU_CONFIGURE=	yes
+USE_ICONV=	yes
+USE_XORG=	xdamage xft xcursor xcomposite
+USE_GNOME=	desktopfileutils gtksourceview2 glib20 intlhack
+USE_PKGCONFIG=	build
+INSTALLS_ICONS=	yes
+INSTALLS_OMF=	yes
+
+MAN1=		gummi.1
+
+OPTIONS_DEFINE=	TETEX LATEXMK RUBBER TEXCOUNT
+OPTIONS_DEFAULT=	TETEX
+
+TETEX_DESC=	Use pdfetex typesetter
+LATEXMK_DESC=	Use latexmk typesetter
+RUBBER_DESC=	Use rubber typesetter
+TEXCOUNT_DESC=	With texcount statistics
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
+USE_GETTEXT=	yes
+CONFIGURE_ARGS+=	--enable-nls
+PLIST_SUB+=	NLS=""
+.else
+CONFIGURE_ARGS+=	--disable-nls
+PLIST_SUB+=	NLS="@comment "
+.endif
+
+.if ${PORT_OPTIONS:MTETEX}
+RUN_DEPENDS+=	pdfetex:${PORTSDIR}/print/teTeX-base
+.endif
+
+.if ${PORT_OPTIONS:MLATEXMK}
+RUN_DEPENDS+=	latexmk:${PORTSDIR}/print/latexmk
+.endif
+
+.if ${PORT_OPTIONS:MRUBBER}
+RUN_DEPENDS+=	rubber:${PORTSDIR}/textproc/rubber
+.endif
+
+.if ${PORT_OPTIONS:MTEXCOUNT}
+#RUN_DEPENDS+=	${LOCALBASE}/bin/texcount.${PORTVERSION}:${PORTSDIR}/texproc/p5-texcount
+.endif
+
+.include <bsd.port.mk>

Added: head/editors/gummi/distinfo
==============================================================================
--- /dev/null	00:00:00 1970	(empty, because file is newly added)
+++ head/editors/gummi/distinfo	Thu Jun 27 08:32:04 2013	(r321872)
@@ -0,0 +1,2 @@
+SHA256 (gummi-0.6.5.tar.gz) = b23c2958376ea43c701a276ad19ceac5b50d9cb32a489a10897b25aa5004fffb
+SIZE (gummi-0.6.5.tar.gz) = 520902

Added: head/editors/gummi/files/patch-po__Makefile.in.in
==============================================================================
--- /dev/null	00:00:00 1970	(empty, because file is newly added)
+++ head/editors/gummi/files/patch-po__Makefile.in.in	Thu Jun 27 08:32:04 2013	(r321872)
@@ -0,0 +1,12 @@
+--- ./po/Makefile.in.in.orig	2012-01-29 20:42:39.060446287 +0000
++++ ./po/Makefile.in.in	2012-01-29 20:43:42.348435836 +0000
+@@ -34,7 +34,8 @@ datadir = @datadir@
+ datarootdir = @datarootdir@
+ libdir = @libdir@
+ DATADIRNAME = @DATADIRNAME@
+-itlocaledir = $(prefix)/$(DATADIRNAME)/locale
++sharedir = share
++itlocaledir = $(prefix)/$(sharedir)/locale
+ subdir = po
+ install_sh = @install_sh@
+ # Automake >= 1.8 provides @mkdir_p@.

Added: head/editors/gummi/files/patch-src__update.c
==============================================================================
--- /dev/null	00:00:00 1970	(empty, because file is newly added)
+++ head/editors/gummi/files/patch-src__update.c	Thu Jun 27 08:32:04 2013	(r321872)
@@ -0,0 +1,10 @@
+--- ./src/update.c.orig	2012-01-29 20:34:57.429446671 +0000
++++ ./src/update.c	2012-01-29 20:35:29.991443641 +0000
+@@ -31,6 +31,7 @@
+ 
+ #include <stdio.h>
+ #include <string.h>
++#include <netinet/in.h>
+ 
+ #ifndef WIN32
+ #   include <sys/socket.h>

Added: head/editors/gummi/pkg-descr
==============================================================================
--- /dev/null	00:00:00 1970	(empty, because file is newly added)
+++ head/editors/gummi/pkg-descr	Thu Jun 27 08:32:04 2013	(r321872)
@@ -0,0 +1,3 @@
+Gummi is a LaTeX editor. It was designed with simplicity in mind.
+
+WWW: http://gummi.midnightcoding.org/

Added: head/editors/gummi/pkg-plist
==============================================================================
--- /dev/null	00:00:00 1970	(empty, because file is newly added)
+++ head/editors/gummi/pkg-plist	Thu Jun 27 08:32:04 2013	(r321872)
@@ -0,0 +1,38 @@
+bin/gummi
+share/applications/gummi.desktop
+share/pixmaps/gummi.png
+lib/gummi/latex_dvi.sh
+%%DATADIR%%/ui/snippets.glade
+%%DATADIR%%/ui/gummi.glade
+%%DATADIR%%/ui/prefs.glade
+%%DATADIR%%/snippets/snippets.lang
+%%DATADIR%%/snippets/snippets.cfg
+%%DATADIR%%/misc/default.tex
+%%DATADIR%%/icons/gummi.png
+%%DATADIR%%/icons/icon.png
+%%NLS%%share/locale/ar/LC_MESSAGES/gummi.mo
+%%NLS%%share/locale/ca/LC_MESSAGES/gummi.mo
+%%NLS%%share/locale/cs/LC_MESSAGES/gummi.mo
+%%NLS%%share/locale/da/LC_MESSAGES/gummi.mo
+%%NLS%%share/locale/de/LC_MESSAGES/gummi.mo
+%%NLS%%share/locale/el/LC_MESSAGES/gummi.mo
+%%NLS%%share/locale/es/LC_MESSAGES/gummi.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/gummi.mo
+%%NLS%%share/locale/hu/LC_MESSAGES/gummi.mo
+%%NLS%%share/locale/it/LC_MESSAGES/gummi.mo
+%%NLS%%share/locale/nl/LC_MESSAGES/gummi.mo
+%%NLS%%share/locale/pl/LC_MESSAGES/gummi.mo
+%%NLS%%share/locale/pt/LC_MESSAGES/gummi.mo
+%%NLS%%share/locale/pt_BR/LC_MESSAGES/gummi.mo
+%%NLS%%share/locale/ro/LC_MESSAGES/gummi.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/gummi.mo
+%%NLS%%share/locale/sv/LC_MESSAGES/gummi.mo
+%%NLS%%share/locale/zh_CN/LC_MESSAGES/gummi.mo
+%%NLS%%share/locale/zh_TW/LC_MESSAGES/gummi.mo
+@dirrm %%DATADIR%%/icons
+@dirrm %%DATADIR%%/misc
+@dirrm %%DATADIR%%/snippets
+@dirrm %%DATADIR%%/ui
+@dirrm %%DATADIR%%
+@dirrm lib/gummi
+@dirrm share/applications
_______________________________________________
svn-ports-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/svn-ports-all
To unsubscribe, send any mail to "svn-ports-all-unsubscribe@freebsd.org"
Comment 3 Wen Heping freebsd_committer 2013-06-27 09:32:45 UTC
State Changed
From-To: open->closed

New port added. Thanks!