Bug 183713

Summary: net-im/libpurple lacking video-chat support
Product: Ports & Packages Reporter: kaltheat
Component: Individual Port(s)Assignee: Joe Marcus Clarke <marcus>
Status: Closed FIXED    
Severity: Affects Only Me    
Priority: Normal    
Version: Latest   
Hardware: Any   
OS: Any   

Description kaltheat 2013-11-06 12:10:00 UTC
I wanted to use "video-chat" with Pidgin 2.10.7 (libpurple 2.10.7) and couldn't.

I was able to create /dev/video0 with multimedia/webcamd and multimedia/cuse4bsd-kmod and use it with multimedia/mplayer.

With pidgin one can choose between 3 input-plugin options:
 - "Default"
 - "Test Input"
 - "Video4Linux"

With "Test Input" I'm able to initiate a video-chat through jabber/xmpp/jingle and I can get a video stream of my opponents webcam.

With "Video4Linux" the video-chat-UI crashes while being created.

If I remember correctly 'pidgin -d' reported that there was a gstreamer-error. I will provide more details on this error, as soon as I can test it again ...
Comment 1 Edwin Groothuis freebsd_committer 2013-11-06 12:10:07 UTC
Responsible Changed
From-To: freebsd-ports-bugs->marcus

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 2 kaltheat 2013-11-06 15:09:34 UTC
Here's the gstreamer error:
...
(16:05:46) jingle-rtp: jingle_rtp_codecs_changed_cb: session_id: video-session jingle_session: 0x80eead5e0
(16:05:46) mediamanager: gst pipeline error: Could not get/set settings from/on resource.
(16:05:46) mediamanager: Debug details: v4l_calls.c(89): gst_v4l_get_capabilities (): /GstPipeline:pipeline0/GstBin:vvconfig-videosrc/GstV4lSrc:vvconfig-videos
rc:
error getting capabilities Invalid argument of from device /dev/video0
(16:05:46) backend-fs2: gst error Could not get/set settings from/on resource.
debugging: v4l_calls.c(89): gst_v4l_get_capabilities (): /GstPipeline:pipeline0/GstBin:vvconfig-videosrc/GstV4lSrc:vvconfig-videosrc:
error getting capabilities Invalid argument of from device /dev/video0
(16:05:46) media: Error with your webcam
(16:05:46) media: Conference error
...
Comment 3 Joe Marcus Clarke freebsd_committer 2013-11-28 18:33:18 UTC
State Changed
From-To: open->closed

The immediate issue with pidgin was the missing gstreamer-plugins-v4l2 port. 
Other issues look to be 100% gstreamer-related, and not with pidgin.  Please 
open a PR under GNOME.  However, as I said in my follow-up email, it would be 
good to gather some data points of FreeBSD -> FreeBSD video calls to see 
if the problem is with the different Linux/FreeBSD plugins.
Comment 4 dfilter service freebsd_committer 2013-11-28 23:24:59 UTC
Author: marcus
Date: Thu Nov 28 23:24:52 2013
New Revision: 335128
URL: http://svnweb.freebsd.org/changeset/ports/335128

Log:
  Make sure gstreamer-plugins-v4l2 is installed if voice/video support is
  enabled.
  
  PR:		183713

Modified:
  head/net-im/libpurple/Makefile

Modified: head/net-im/libpurple/Makefile
==============================================================================
--- head/net-im/libpurple/Makefile	Thu Nov 28 22:36:37 2013	(r335127)
+++ head/net-im/libpurple/Makefile	Thu Nov 28 23:24:52 2013	(r335128)
@@ -119,6 +119,7 @@ CONFIGURE_ARGS+=--disable-gstreamer
 
 .if ${PORT_OPTIONS:MVV} && ${PORT_OPTIONS:MGSTREAMER}
 LIB_DEPENDS+=	gstfarsight-0.10.0:${PORTSDIR}/net-im/farsight2
+USE_GSTREAMER+=	gst_v4l2
 PLIST_SUB+=	VV=""
 .else
 CONFIGURE_ARGS+=--disable-vv
_______________________________________________
svn-ports-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/svn-ports-all
To unsubscribe, send any mail to "svn-ports-all-unsubscribe@freebsd.org"