Bug 185080

Summary: gifconfig_gifX in rc.conf(5) not used to greate the tunnel part of the gif(4) interface if cloned_interfaces is used to create the gif interface.
Product: Base System Reporter: kpaasial
Component: confAssignee: freebsd-bugs mailing list <bugs>
Status: Open ---    
Severity: Affects Only Me    
Priority: Normal    
Version: unspecified   
Hardware: Any   
OS: Any   

Description kpaasial 2013-12-22 06:30:00 UTC
I have this set up in rc.conf:

cloned_interfaces="gif0"
gifconfig_gif0="88.xxx.xxx.xxx 62.yyy.yyy.yyy"
ifconfig_gif0_ipv6="inet6 2001:14b8:aaa:bbb::2 2001:14b8:aaa:bbb::1 prefixlen 128

Im not using gif_interfaces=gif0 since its deprecated in FreeBSD 10 as per the warning messages spewed by the rc(8) scripts.

However this does not work properly The ifconfig gif0 tunnel 88.xxx.xxx.xxx 62.yyy.yyy.yyy does not get executed. It looks to me that the tunnel set up is only performed when gif0 is listed in gif_interfaces.

I can work around this by doing this instead of the 'gifconfig_gif0' line:

ifconfig_gif0= tunnel 88.xxx.xxx.xxx 62.yyy.yyy.yyy

Fix: 

Somewhere in /etc/network.subr the logic should be changed to also look into cloned_interfaces in addition to gif_interfaces for gifconfig_gifX -settings.
How-To-Repeat: Use cloned_interfaces="gif0"  and gifconfig_gif0="a.b.c.d e.f.g.h" in rc.conf(5) for configuring the tunnel part of the gif(4) interface. The tunnel part of the configuration is not applied to the gif interface.
Comment 1 Eitan Adler freebsd_committer freebsd_triage 2017-12-31 08:00:25 UTC
For bugs matching the following criteria:

Status: In Progress Changed: (is less than) 2014-06-01

Reset to default assignee and clear in-progress tags.

Mail being skipped