Bug 186872

Summary: [msk] Upgrade from 9.2 to 10, msk0 watchdog timeout [regression]
Product: Base System Reporter: Rusmir Dusko <nemysis>
Component: kernAssignee: freebsd-net mailing list <net>
Status: Closed Feedback Timeout    
Severity: Affects Only Me CC: eugen, pi
Priority: Normal    
Version: 10.0-RELEASE   
Hardware: Any   
OS: Any   

Description Rusmir Dusko freebsd_committer 2014-02-18 15:30:01 UTC
I have a clean install of PC-BSD 9.2 with ZFS.

I understand that 9.2 is supported til June 2014, and upgraded
to PC-BSD 10.0-RELEASE-p4.

FreeBSD and PC-BSD were working on this PC from 9.0 to 9.2.

Hardware details

Asus Crosshair IV Formula, AMD 890FX, AM3, CrossFireX

&#8203;http://www.freebsd.org/cgi/man.cgi?query=msk&sektion=4

Marvell Yukon 88E8059 Gigabit Ethernet

I bought this for ZFS performance enhancement.

Corsair Vengeance (2x, 8GB, DDR3-2000, DIMM)


I have seen that VirtualBox and nVidia drivers (.ko)
built in FreeBSD 9.2 are not compatible with FreeBSD 10,
but can't have a new build because of not having a working Internet connection.


Later checked messages with

pkg update -f
Updating repository catalogue
msk0: watchdog timeout
..
pkg: Unable to find catalogs


When i try to enable LAN ROM in BIOS, then PC freezes at times.


I have searched Internet and looked at 

&#8203;http://www.freebsd.org/doc/handbook/config-network-setup.html


This was before too problem with msk0, em0, re0 and soo on

&#8203;http://forums.freebsd.org/viewtopic.php?t=40701

&#8203;https://forums.freebsd.org/viewtopic.php?&t=10183

&#8203;http://lists.freebsd.org/pipermail/freebsd-current/2013-July/042853.html

&#8203;http://lists.freebsd.org/pipermail/freebsd-stable/2013-October/075599.html

&#8203;https://bugs.freenas.org/issues/1850

&#8203;http://zfsguru.com/forum/zfsgurudevelopment/542


Not helps

service netif restart && service routing restart

ifconfig msk0 polling

ifconfig msk0 -tso

sysctl -a | grep tcp.tso
net.inet.tcp.tso: 1

sysctl net.inet.tcp.tso=0

watchdog -t 0

I use FreeBSD/PC-BSD and no other Operational Systems, but tried coldboot for several hours.

Fix: 

Please fix this mistake

https://svnweb.freebsd.org/base/head/sys/dev/msk/if_msk.c?view=log
How-To-Repeat: Driver for ethernet msk0 not works more.
Comment 1 Mark Linimon freebsd_committer freebsd_triage 2014-02-24 06:55:38 UTC
Responsible Changed
From-To: freebsd-bugs->freebsd-net

Over to maintainer(s).
Comment 2 Kurt Jaeger freebsd_committer 2015-04-12 18:26:54 UTC
see

https://lists.freebsd.org/pipermail/freebsd-stable/2015-April/082226.html

for a suggested solution.
Comment 3 Eitan Adler freebsd_committer freebsd_triage 2018-05-28 19:41:18 UTC
batch change:

For bugs that match the following
-  Status Is In progress 
AND
- Untouched since 2018-01-01.
AND
- Affects Base System OR Documentation

DO:

Reset to open status.


Note:
I did a quick pass but if you are getting this email it might be worthwhile to double check to see if this bug ought to be closed.
Comment 4 Eugene Grosbein freebsd_committer 2018-05-28 21:33:13 UTC
Feedback timeout (4 years). Should be fixed since then.