Bug 187488

Summary: Freebsd 10 install kernel rebooting the machine.
Product: Base System Reporter: troyax
Component: amd64Assignee: Mark Linimon <linimon>
Status: Closed Overcome By Events    
Severity: Affects Some People CC: op
Priority: Normal    
Version: Unspecified   
Hardware: Any   
OS: Any   
See Also: https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=194063
Attachments:
Description Flags
file.txt none

Description troyax 2014-03-12 17:10:00 UTC
When booting an install image of Freebsd 10 from an USB key (created as explained on the handbook), as it starts to boot the kernel my laptop suddenly reboot (I can't even clearly saw the "boot prompt" - before the numbers).
But I could boot and install the 9.2 image without any problem; I joined my current (9.2) dmesg.boot (my laptop is a HP EliteBook Folio 9470m).

As a side note, I also tried OpenBSD 5.4 which ended in the same reboot scenario - I just add few numbers (2 or 3 blocks) on my screen before the reboot.

Fix: Patch attached with submission follows:
How-To-Repeat: Boot a Freebsd 10 kernel from an USB key (no CD/DVD reader) on a HP EliteBook Folio 9470m (or at least mine).
I would happily help with some tests, although I need my laptop to continue to work (so mainly image booting test - probably no installation at the moment).
Comment 1 troyax 2014-04-14 14:18:02 UTC
A work-around that worked on my laptop: change the USB image /boot/loader by the corresponding /boot/loader from a 9.2 release.

Troyax.
Comment 2 Eitan Adler freebsd_committer freebsd_triage 2018-05-28 19:47:34 UTC
batch change:

For bugs that match the following
-  Status Is In progress 
AND
- Untouched since 2018-01-01.
AND
- Affects Base System OR Documentation

DO:

Reset to open status.


Note:
I did a quick pass but if you are getting this email it might be worthwhile to double check to see if this bug ought to be closed.
Comment 3 Mark Linimon freebsd_committer freebsd_triage 2018-05-31 15:41:33 UTC
Unfortunately this PR was never addressed before these versions of FreeBSD went out of support.  Sorry.

If this is still a problem, please open a new PR.  Thanks.