Bug 190478

Summary: [PATCH] textproc/apache-solr: update to 4.8.1
Product: Ports & Packages Reporter: Larry Rosenman <ler>
Component: Individual Port(s)Assignee: Martin Wilke <miwi>
Status: Closed DUPLICATE    
Severity: Affects Only Me CC: miwi
Priority: ---    
Version: Latest   
Hardware: Any   
OS: Any   
Attachments:
Description Flags
apache-solr-4.8.1.patch none

Description Larry Rosenman freebsd_committer 2014-06-02 03:55:29 UTC
Created attachment 143284 [details]
apache-solr-4.8.1.patch

- Update to 4.8.1

Port maintainer (gaod@hychen.org) is cc'd.

Generated with FreeBSD Port Tools 1.02 (mode: update, diff: ports)
Comment 1 Larry Rosenman freebsd_committer 2014-06-02 23:29:25 UTC
Maintainer Approved:

Return-path: <gaod@hychen.org>
Envelope-to: ler@lerctr.org
Delivery-date: Mon, 02 Jun 2014 18:19:03 -0500
Received: from mail-vc0-f179.google.com ([209.85.220.179]:49823)
    by thebighonker.lerctr.org with esmtps (TLSv1:RC4-SHA:128)
    (Exim 4.82 (FreeBSD))
    (envelope-from <gaod@hychen.org>)
    id 1WrbVN-000MLv-M3
    for ler@lerctr.org; Mon, 02 Jun 2014 18:19:03 -0500
Received: by mail-vc0-f179.google.com with SMTP id ij19so1437717vcb.24
    for <ler@lerctr.org>; Mon, 02 Jun 2014 16:18:50 -0700 (PDT)
X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed;
    d=1e100.net; s=20130820;
    h=x-gm-message-state:mime-version:in-reply-to:references:from:date
    :message-id:subject:to:cc:content-type;
    bh=UbUxv0hbXDm0pB4Lu3rVLJQyLgMcQoaMmGDeZjccimo=;
    b=RzqQJXiuYR1LAN6O5OIkFa7dkENsSr5s1s7cRaO0PQV963cJ1Ca6DBm0OkAYr5R+XD
    kEHfGgqqevVs02pNJuvijHR9Ao125lh085+tMdj2QNsIqfXt24Vdlr1TsuRsNMvXo8q/
    PRs4db005AZ5tdCyN/C3+ptIGzyBhJxuGNaOz2u1Ct6wzG0ZjFDj7fBUZkcedRl3dkz7
    lmM78N4gFTtLzC8dCI4+TXnEnEDAWMv/QuQ6RsWI+7KyEwb7mHqEOPaWZkTSGp6MnDG4
    saxL8Ll216DFMRyzp7XFejDhN/O0hMe9bJpS82NDO+3qujBBuPzlR/AfuMef+N5PSR/3
    SMog==
X-Gm-Message-State: ALoCoQle80GsH/adFKP/OlUAxGbEkKPZc4T+z3sBtFh4cHjiWijkq5BYylJcxKl5O1uyX0Z28Fon
X-Received: by 10.220.82.133 with SMTP id b5mr33028576vcl.13.1401751129895;
    Mon, 02 Jun 2014 16:18:49 -0700 (PDT)
MIME-Version: 1.0
Received: by 10.221.27.2 with HTTP; Mon, 2 Jun 2014 16:18:29 -0700 (PDT)
In-Reply-To: <E1WqoNA-000GX2-Oq@borg.lerctr.org>
References: <E1WqoNA-000GX2-Oq@borg.lerctr.org>
From: Hung-Yi Chen <gaod@hychen.org>
Date: Mon, 2 Jun 2014 16:18:29 -0700
Message-ID: <CAAfCfaM5Cv4MnNPgpi1VnBbqwoPxTW-R2c4+rxfDsWywQYHEBA@mail.gmail.com>
Subject: Re: [PATCH] textproc/apache-solr: update to 4.8.1
To: Larry Rosenman <ler@lerctr.org>
Cc: FreeBSD-gnats-submit@freebsd.org
Content-Type: multipart/alternative; boundary=089e0163380a294ab104fae29e25
X-Spam-Score: -1.9 (-)
X-LERCTR-Spam-Score: -1.9 (-)
X-Spam-Report: SpamScore (-1.9/5.0) BAYES_00=-1.9,HTML_MESSAGE=0.001,RCVD_IN_MSPIKE_H3=-0.01,RCVD_IN_MSPIKE_WL=-0.01
X-LERCTR-Spam-Report: SpamScore (-1.9/5.0) BAYES_00=-1.9,HTML_MESSAGE=0.001,RCVD_IN_MSPIKE_H3=-0.01,RCVD_IN_MSPIKE_WL=-0.01
It's seems okay.

Please commit it, thanks.

2014-05-31 11:51 GMT-07:00 Larry Rosenman <ler@lerctr.org>:

>Submitter-Id:  current-users
>Originator:    Larry Rosenman
>Organization:  LERCTR Consulting
>Confidential:  no
>Synopsis:      [PATCH] textproc/apache-solr: update to 4.8.1
>Severity:      non-critical
>Priority:      low
>Category:      ports
>Class:         update
>Release:       FreeBSD 11.0-CURRENT amd64
>Environment:
System: FreeBSD borg.lerctr.org 11.0-CURRENT FreeBSD 11.0-CURRENT #35 r266471M: Tue May 20 11:25:08 CDT
>Description:
- Update to 4.8.1

Port maintainer (gaod@hychen.org) is cc'd.

Generated with FreeBSD Port Tools 1.02 (mode: update, diff: ports)
>How-To-Repeat:
>Fix:

--- apache-solr-4.8.1.patch begins here ---
diff -ruN /usr/ports/textproc/apache-solr/Makefile ./Makefile
--- /usr/ports/textproc/apache-solr/Makefile    2014-01-25 20:32:36.821226822 -0600
+++ ./Makefile  2014-05-31 02:52:44.655165312 -0500
@@ -2,7 +2,7 @@
 # $FreeBSD: head/textproc/apache-solr/Makefile 341120 2014-01-25 22:03:15Z mat $

 PORTNAME=      apache-solr
-PORTVERSION=   4.6.0
+PORTVERSION=   4.8.1
 CATEGORIES=    textproc java
 MASTER_SITES=  APACHE
 MASTER_SITE_SUBDIR=    lucene/solr/${PORTVERSION}
@@ -18,7 +18,7 @@

 USES=  shebangfix
 SHEBANG_FILES= example/etc/create-solrtest.keystore.sh
-JAVA_VERSION=  1.6+
+JAVA_VERSION=  1.7+
 NO_BUILD=      yes
 PLIST_SUB+=    PORTVERSION="${PORTVERSION}"
 USE_JAVA=      yes
diff -ruN /usr/ports/textproc/apache-solr/distinfo ./distinfo
--- /usr/ports/textproc/apache-solr/distinfo    2013-11-25 09:55:15.074565586 -0600
+++ ./distinfo  2014-05-31 02:11:12.742337750 -0500
@@ -1,2 +1,2 @@
-SHA256 (solr-4.6.0.tgz) = 2a4a6559665363236653bec749f580a5da973e1088227ceb1fca87802bd06a3f
-SIZE (solr-4.6.0.tgz) = 138704246
+SHA256 (solr-4.8.1.tgz) = ac814affbe4f7270cf98a5d4d70eb65579bff7c008ee96d74b4146b1060bf947
+SIZE (solr-4.8.1.tgz) = 152451311
diff -ruN /usr/ports/textproc/apache-solr/pkg-plist ./pkg-plist
--- /usr/ports/textproc/apache-solr/pkg-plist   2014-01-25 20:32:36.819226610 -0600
+++ ./pkg-plist 2014-05-31 02:57:42.453145778 -0500
@@ -6,27 +6,30 @@
 %%JAVAJARDIR%%/solr-dataimporthandler-%%PORTVERSION%%.jar
 %%JAVAJARDIR%%/solr-dataimporthandler-extras-%%PORTVERSION%%.jar
 %%JAVAJARDIR%%/solr-langid-%%PORTVERSION%%.jar
+%%JAVAJARDIR%%/solr-map-reduce-%%PORTVERSION%%.jar
+%%JAVAJARDIR%%/solr-morphlines-cell-%%PORTVERSION%%.jar
+%%JAVAJARDIR%%/solr-morphlines-core-%%PORTVERSION%%.jar
 %%JAVAJARDIR%%/solr-solrj-%%PORTVERSION%%.jar
 %%JAVAJARDIR%%/solr-test-framework-%%PORTVERSION%%.jar
 %%JAVAJARDIR%%/solr-uima-%%PORTVERSION%%.jar
 %%JAVAJARDIR%%/solr-velocity-%%PORTVERSION%%.jar
 %%JAVAJARDIR%%/solrj-lib/commons-io-2.1.jar
-%%JAVAJARDIR%%/solrj-lib/httpclient-4.2.6.jar
-%%JAVAJARDIR%%/solrj-lib/httpcore-4.2.5.jar
-%%JAVAJARDIR%%/solrj-lib/httpmime-4.2.6.jar
-%%JAVAJARDIR%%/solrj-lib/jcl-over-slf4j-1.6.6.jar
-%%JAVAJARDIR%%/solrj-lib/jul-to-slf4j-1.6.6.jar
+%%JAVAJARDIR%%/solrj-lib/httpclient-4.3.1.jar
+%%JAVAJARDIR%%/solrj-lib/httpcore-4.3.jar
+%%JAVAJARDIR%%/solrj-lib/httpmime-4.3.1.jar
+%%JAVAJARDIR%%/solrj-lib/jcl-over-slf4j-1.7.6.jar
+%%JAVAJARDIR%%/solrj-lib/jul-to-slf4j-1.7.6.jar
 %%JAVAJARDIR%%/solrj-lib/log4j-1.2.16.jar
 %%JAVAJARDIR%%/solrj-lib/noggit-0.5.jar
-%%JAVAJARDIR%%/solrj-lib/slf4j-api-1.6.6.jar
-%%JAVAJARDIR%%/solrj-lib/slf4j-log4j12-1.6.6.jar
+%%JAVAJARDIR%%/solrj-lib/slf4j-api-1.7.6.jar
+%%JAVAJARDIR%%/solrj-lib/slf4j-log4j12-1.7.6.jar
 %%JAVAJARDIR%%/solrj-lib/wstx-asl-3.2.7.jar
-%%JAVAJARDIR%%/solrj-lib/zookeeper-3.4.5.jar
+%%JAVAJARDIR%%/solrj-lib/zookeeper-3.4.6.jar
 %%JAVAJARDIR%%/test-framework/README.txt
 %%JAVAJARDIR%%/test-framework/lib/ant-1.8.2.jar
 %%JAVAJARDIR%%/test-framework/lib/junit-4.10.jar
-%%JAVAJARDIR%%/test-framework/lib/junit4-ant-2.0.13.jar
-%%JAVAJARDIR%%/test-framework/lib/randomizedtesting-runner-2.0.13.jar
+%%JAVAJARDIR%%/test-framework/lib/junit4-ant-2.1.3.jar
+%%JAVAJARDIR%%/test-framework/lib/randomizedtesting-runner-2.1.3.jar
 %%JAVAJARDIR%%/test-framework/lucene-libs/lucene-test-framework-%%PORTVERSION%%.jar
 @dirrmtry %%JAVAJARDIR%%/solrj-lib
 @dirrmtry %%JAVAJARDIR%%/test-framework/lib
--- apache-solr-4.8.1.patch ends here ---
Comment 2 Larry Rosenman freebsd_committer 2014-06-03 15:40:54 UTC
duplicate

*** This bug has been marked as a duplicate of bug 190449 ***