Bug 191733

Summary: editors/libreoffice fails postgresql-client check
Product: Ports & Packages Reporter: mikhail.rokhin
Component: Individual Port(s)Assignee: FreeBSD Office Team <office>
Status: Closed Overcome By Events    
Severity: Affects Many People CC: miwi, mrtnnbr, shuriku
Priority: ---    
Version: Latest   
Hardware: Any   
OS: Any   

Description mikhail.rokhin 2014-07-08 10:02:45 UTC
I have postgresql-client 9.0 and it claims that it needs 9.0+, but you have 9.0 and fails...

World of paralogic!))

11-current i386
Comment 1 John Marino freebsd_committer 2014-07-13 08:26:07 UTC
over to maintainer group...
Comment 2 Oleksandr Kryvulia 2014-07-18 10:45:50 UTC
The same error with postgresql-client 9.3 on CURRENT amd64:

 ===>>> This port is marked IGNORE
        ===>>> cannot install: the port wants postgresql-client version 9.0 9.1 9.2 9.3 9.4 and you have version 9.3 installed
Comment 3 Martin Neubauer 2014-07-20 08:45:55 UTC
I successfully built the port (on 10.0) after replacing the line

PGSQL_USES=     pgsql:90+

with

USE_PGSQL=      yes
WANT_PGSQL_VER= 90+

Although not tested, changing the same line to

USES+=     pgsql:90+

should likewise work, and might even be preferable.
Comment 4 Oleksandr Kryvulia 2014-07-21 09:14:38 UTC
(In reply to Martin Neubauer from comment #3)
> I successfully built the port (on 10.0) after replacing the line
> 
> PGSQL_USES=     pgsql:90+
> 
> with
> 
> USE_PGSQL=      yes
> WANT_PGSQL_VER= 90+
> 
> Although not tested, changing the same line to
> 
> USES+=     pgsql:90+
> 
> should likewise work, and might even be preferable.

With

USES+=     pgsql:90+

doesn't build, the same error.
Comment 5 Martin Neubauer 2014-07-21 10:40:11 UTC
> 
> With
> 
> USES+=     pgsql:90+
> 
> doesn't build, the same error.

So it looks like the new USES config mechanism isn't quite ironed out yet. For the time being, reverting the change by revision 359048 should get the build done (at least it did for me.)