Bug 192738

Summary: [PATCH] invalid depends for www/luakit
Product: Ports & Packages Reporter: serpent7776
Component: Individual Port(s)Assignee: John Marino <marino>
Status: Closed FIXED    
Severity: Affects Some People CC: marino
Priority: ---    
Version: Latest   
Hardware: Any   
OS: Any   
Attachments:
Description Flags
patch none

Description serpent7776 2014-08-17 12:43:22 UTC
Created attachment 145913 [details]
patch

www/luakit is declared to use lang/lua51, but is has run dependency on devel/luafilesystem which depends on lang/lua52. Changed dependency to devel/luafilesystem-51
Comment 1 John Marino freebsd_committer 2014-08-17 13:17:20 UTC
luakit has no maintainer, so no approval needed.
Comment 2 commit-hook freebsd_committer 2014-08-17 20:12:20 UTC
A commit references this bug:

Author: marino
Date: Sun Aug 17 20:11:46 UTC 2014
New revision: 365242
URL: http://svnweb.freebsd.org/changeset/ports/365242

Log:
  www/luakit: FIx invalid dependency declaration

  Luakit is declared to use lua51, but has a run dependency on luafilesystem
  which depends on lua52.  Switch to luafilesystem-51 to fix, and when in
  doubt, revbump.

  PR:		192738
  Submitted by:	maintainer (Serpent)

Changes:
  head/www/luakit/Makefile
Comment 3 John Marino freebsd_committer 2014-08-17 20:13:54 UTC
Thanks!