Bug 194135

Summary: x11-wm/xfce4: full screen vlc doesn't hide the panel bars
Product: Ports & Packages Reporter: Adrian Chadd <adrian>
Component: Individual Port(s)Assignee: freebsd-xfce mailing list <xfce>
Status: Closed FIXED    
Severity: Affects Only Me CC: lists, olivierd
Priority: ---    
Version: Latest   
Hardware: Any   
OS: Any   
Attachments:
Description Flags
Patch, which hides panel for maximized applications none

Description Adrian Chadd freebsd_committer 2014-10-04 06:56:41 UTC
Hi,

When running xfce as a desktop, VLC in full screen mode doesn't hide the top menu panel bar. It's the default "don't autohide the panel" setting.

I have to make the panel "autohide" in order for it to be a full screen VLC session.

Is this how it's supposed to be? 

Thanks!


-adrian
Comment 1 Mark Linimon freebsd_committer freebsd_triage 2014-10-17 20:42:09 UTC
Fix synopsis and assign.
Comment 2 Olivier Duchateau freebsd_committer 2014-10-19 16:24:13 UTC
Created attachment 148469 [details]
Patch, which hides panel for maximized applications

Could you test patch in attachment?

It must be applied to **x11-wm/xfce4-wm**.
Comment 3 Adrian Chadd freebsd_committer 2014-10-19 17:18:01 UTC
Comment on attachment 148469 [details]
Patch, which hides panel for maximized applications

Have you tried it locally? I'm unfortunately unable to build packages at the moment; I don't have a poudriere setup on any of the laptops and I just run 100% binary packages. :(

is there an easy way to just checkout and build the -one- package?
Comment 4 Olivier Duchateau freebsd_committer 2014-10-20 15:49:50 UTC
(In reply to Adrian Chadd from comment #3)
> Comment on attachment 148469 [details]
> Patch, which hides panel for maximized applications
> 
> Have you tried it locally? I'm unfortunately unable to build packages at the
> moment; I don't have a poudriere setup on any of the laptops and I just run
> 100% binary packages. :(

Unfortunately, I use xfwm4 4.11.2, but it affects also this release (and previous). I succeeded to reproduce behavior.

> 
> is there an easy way to just checkout and build the -one- package?
Comment 5 commit-hook freebsd_committer 2014-10-20 16:02:22 UTC
A commit references this bug:

Author: olivierd
Date: Mon Oct 20 16:01:37 UTC 2014
New revision: 371279
URL: https://svnweb.freebsd.org/changeset/ports/371279

Log:
  - Add patch, which hides panel for maximized applications
  - Remove @dirrm* in pkg-plist
  - Bump PORTREVISION

  PR:		194135
  Reported by:	adrian@
  Obtained from:	Xfce's BugZilla (bugs #8563, #10622)

Changes:
  head/x11-wm/xfce4-wm/Makefile
  head/x11-wm/xfce4-wm/files/patch-src__client.c
  head/x11-wm/xfce4-wm/pkg-plist
Comment 6 Olivier Duchateau freebsd_committer 2014-10-20 16:07:05 UTC
Committed, thanks
Comment 7 Norbert Augenstein 2014-10-21 20:28:55 UTC
Patch works for VLC only, not for Mplayer, Firefox(Flash) or Virtualbox VM in fullscreen. I have a dual Monitor setup.
Comment 8 Olivier Duchateau freebsd_committer 2014-10-22 19:23:57 UTC
(In reply to Norbert Augenstein from comment #7)
> Patch works for VLC only, not for Mplayer, Firefox(Flash) or Virtualbox VM
> in fullscreen. I have a dual Monitor setup.

Even with F11 key (usually it's shortcut for fullscreen mode)?

Patch is just workaround, not approved by upstream, and I can't see modification for this complaint.

I re-open this PR.
Comment 9 Olivier Duchateau freebsd_committer 2014-10-26 19:29:45 UTC
(In reply to Norbert Augenstein from comment #7)
> Patch works for VLC only, not for Mplayer, Firefox(Flash) or Virtualbox VM
> in fullscreen. I have a dual Monitor setup.

Do you try this command, which disable always-on-top behaviour panel?

xfconf-query -c xfce4-panel -p /panels/panel-<id>/disable-struts -t bool -n -s true

Where <id> is integer (usually 0 or 1).

If nothing change, you can revert value with:

xfconf-query -c xfce4-panel -p /panels/panel-<id>/disable-struts -T
Comment 10 Olivier Duchateau freebsd_committer 2015-03-13 17:51:37 UTC
Since revision r380565, I think this bug can be closed. Support of Qt applications with xfwm 4.12 is better. Otherwise xfce4-panel 4.12 provides new feature, calls "intelligently autohide" (see in preferences window).