Bug 194793

Summary: EFI boot loader panic: vm_fault: fault no nofault entry, addr: fffffe0000eb8000 (10.1-rc4) efi boot only
Product: Base System Reporter: North <nccs>
Component: kernAssignee: freebsd-bugs (Nobody) <bugs>
Status: Closed FIXED    
Severity: Affects Only Me    
Priority: ---    
Version: 10.1-RC4   
Hardware: amd64   
OS: Any   

Description North 2014-11-03 21:56:44 UTC
I have a asus g750jx i7-4700hq 16GB mem 1tb HD  gtx770 video
When I boot from EFI (only) I get the following Panic!!!!

panic: vm_fault: fault no nofault entry,  addr:   fffffe0000eb8000
cpuid=0
KDB stack backtrace:
#0  0xffffffff806db2f0 at +0x149900
#1  0xffffffff806a0415 at +0x10ea25
#2  0xffffffff809138be at +0x381ece
#3  0xffffffff80911d07 at +0x380317
#4  0xffffffff8095785c at +0x3c5e6c
#5  0xffffffff8095702a at +0x3c563a
#6  0xffffffff8093cf12 at +0x3ab522
#7  0xffffffff802b298c at ??+0


yet if I boot from my usb install release(10)
(esc)
and set currdev to disk1p10
unload
load kernel
boot 


And alls fine the system boots

The system boot fine from EFI before I updated to RC4
from 10.1 prerelease

make buildworld
make buildkernel
make installworld
make installkernel
all went well not problems
Comment 1 North 2015-01-20 22:57:50 UTC
update:

ONLY!! boots a custom slim down 10.1 prerelease kernel (unused network devices removed) 

Used of  GENERIC kernel of 10.1 rc4, 10.1 prerelease, 10.1-release fail with panic reboot.  

Downloaded new FreeBSD-10.1-RELEASE-amd64-uefi-memstick.img usb install image.

Boot from USB image fails with panic reboot (see below)


>> FreeBSD EFI boot block
   Loader path" /boot/loader.efi
Consoles: EFI console
Image base: 0x4b92900
EFI version: 2.31
EFI Firmare American Megatrends (rev 4.654)

FreeBSD/and64 EFI Loader, Revision 1.1
(root@releng1.nyi.freebsd.org, Tue Nov 11 20:57:24 UTC 2014)
Loading /boot/defaults/loader.conf
/boot/kernel/kernel text=0xf8f898 data=0x124a30+0x2055c0 syms=[0x8+0x1405e0+0x8+0x15b077]

Hit [Enter] to boot immediately, or any other key for command prompt.
Booting [/boot/kernel/kernel]...
Start @ 0xffff??????????
(painic reboot)


YET!! boot from MBR on same USB seems to work fine!!

Noted Differences between UEFI and MBR bootloaders


Consoles :internal video/keyboard  (not EFI console)

/boot/kernel/kernel  text, data amd syms are the same.

may be related to Bug 193646
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=193646
Comment 2 North 2015-01-31 18:02:41 UTC
Update:

WORKS!!!!!!

Problem seemed to be caused by the BIOS 
Update Bios from ver 208 to 209 and poof the labtop boots
now work from HD & USD release 10 or 10.1.

no more hangs or panics

problem CLOSED!!!!!!!
Comment 3 North 2015-01-31 18:10:52 UTC
p.s.
bios update description below from (asus.com)

BIOS 209 (G750JX)
Fix WHQL issue for win 8.1

Noticeļ¼šPlease check in the BIOS setup for the correct BIOS file name of your Notebook PC. Please refer to FAQ: 
BIOS Name of Notebook PC
http://support.asus.com.cn/faq/detail.aspx?SLanguage=en&p=3&m=ux42vs&s=471&hashedid=zmdncib4wrswqjrt&os=&no=e2df6235-08a1-4f4c-a6c1-ad53d00448bc