Bug 194920

Summary: hw.acpi.cpu.cx_lowest restricted to C1 on Bay Trail-M N2930 Jetway motherboards
Product: Base System Reporter: 89zjvobu
Component: kernAssignee: freebsd-bugs (Nobody) <bugs>
Status: Closed Works As Intended    
Severity: Affects Some People    
Priority: ---    
Version: 10.1-RC2   
Hardware: amd64   
OS: Any   
Attachments:
Description Flags
dmesg of boot -v, acpi and sysctl dump
none
dmesg of boot -v, acpi and sysctl dump none

Description 89zjvobu 2014-11-10 02:49:13 UTC
Created attachment 149236 [details]
dmesg of boot -v, acpi and sysctl dump

After booting  hw.acpi.cpu.cx_lowest is C1 and C2/C3 can not be enabled (tried all sorts of things). I became aware of the problem because of the high power usage/temperatures compare to other distributions.

So whatever I do, in the end I get:

dev.cpu.0.cx_supported: C1/1/1 C2/2/500 C3/3/5000
dev.cpu.0.cx_usage: 100.00% 0.00% 0.00% last 384us

powerd -v seems to work:
powerd: unable to determine AC line status
load  38%, current freq   62 MHz (18), wanted freq   62 MHz
load  21%, current freq   62 MHz (18), wanted freq   62 MHz
...

This is from an FreeBSD-10.1-RC4-amd64-memstick r273874 installed on a new dual-lan N2930 Bay Trail-M system from jetway (HBJC311U93-2930-B, HBJC311U93W-2930-B, BIOS A01, and other systems based on the NU93-F motherboard). Beside: States works fine with ipfire based on Linux Kernel 3.10

Attached find the boot-v dmesg, acpidump and sysctl -a output.
Comment 1 89zjvobu 2014-11-10 03:13:58 UTC
Created attachment 149237 [details]
dmesg of boot -v, acpi and sysctl dump

First attachment was accidently made with Win 2001 acpi option. Here the normal
boot data.