Bug 195606

Summary: Serial ports under emulators/virtualbox-ose do not works
Product: Ports & Packages Reporter: 214748mv
Component: Individual Port(s)Assignee: vbox
Status: New ---    
Severity: Affects Some People CC: w.schwarzenfeld
Priority: --- Flags: bugzilla: maintainer-feedback? (vbox)
Version: Latest   
Hardware: amd64   
OS: Any   

Description 214748mv 2014-12-03 13:26:24 UTC
I have tried to use a host device, /dev/cuau0, in a Windows VM as COM1 but with no luck. Probably the bug is “It is almost like the CTS pin is permanently active but the actual device is not really ready for data.” as mentioned by Anthony Takata in this mail: https://lists.freebsd.org/pipermail/freebsd-emulation/2014-October/011927.html . 
I have solved the problem via network as explayned here: https://lists.freebsd.org/pipermail/freebsd-emulation/2014-December/012066.html . 
This approach has a main disadvantage: the VM can not be suspended because when resumed lost the connection with the host TCP socket.
Comment 1 Bugzilla Automation freebsd_committer 2014-12-03 13:26:24 UTC
Auto-assigned to maintainer vbox@FreeBSD.org
Comment 2 Walter Schwarzenfeld freebsd_triage 2018-01-11 18:41:04 UTC
Is this still relevant? No maintainer feedback till now!