Bug 196160

Summary: [patch] Upgrade audio/beets to 1.3.9
Product: Ports & Packages Reporter: Stig Inge Lea Bjørnsen <silb>
Component: Individual Port(s)Assignee: Mark Felder <feld>
Status: Closed FIXED    
Severity: Affects Only Me CC: silb
Priority: --- Flags: bugzilla: maintainer-feedback? (feld)
Version: Latest   
Hardware: Any   
OS: Any   
Bug Depends on: 194927, 196154    
Bug Blocks:    
Attachments:
Description Flags
beets upgrade from 1.3.6 to 1.3.9 none

Description Stig Inge Lea Bjørnsen 2014-12-20 17:44:07 UTC
Created attachment 150812 [details]
beets upgrade from 1.3.6 to 1.3.9

* Add options for various new plugins, their dependencies are declared at [1]
  - ImageMagick is optional for the FetchArt and EmbedArt plugins [2][3]
* The project license is declared at [4]
* Depend on www/requests to avoid conflict with audio/py-discogs-client after #196154

[1] https://github.com/sampsyo/beets/blob/v1.3.9/setup.py
[2] http://docs.beets.io/en/v1.3.9/plugins/embedart.html#image-similarity-check
[2] http://docs.beets.io/en/v1.3.9/plugins/fetchart.html#image-resizing
[4] https://github.com/sampsyo/beets/blob/v1.3.9/LICENSE
Comment 1 Bugzilla Automation freebsd_committer 2014-12-20 17:44:07 UTC
Auto-assigned to maintainer feld@FreeBSD.org
Comment 2 commit-hook freebsd_committer 2014-12-21 16:15:55 UTC
A commit references this bug:

Author: feld
Date: Sun Dec 21 16:14:56 UTC 2014
New revision: 375167
URL: https://svnweb.freebsd.org/changeset/ports/375167

Log:
  Update to 1.3.9

  PR:		196160

Changes:
  head/audio/beets/Makefile
  head/audio/beets/distinfo