Bug 196468

Summary: Powerd hangs my AMD APU system
Product: Base System Reporter: ditf.robins
Component: kernAssignee: freebsd-bugs (Nobody) <bugs>
Status: New ---    
Severity: Affects Only Me CC: philipp
Priority: ---    
Version: 10.1-STABLE   
Hardware: amd64   
OS: Any   
Attachments:
Description Flags
crash dump log
none
powerd log none

Description ditf.robins 2015-01-03 20:18:13 UTC
Created attachment 151300 [details]
crash dump log

When powerd is running it always reboots (or hangs) my system after a while. I start powerd with "-a adaptive" or "-a hiadaptive" flags and it starts to scale cpu clock speed. After a while i walk away from my pc to watch some tv, eat dinner, etc., but when i return to my pc it always has rebooted. 

This has been an issue starting from 10.0-RELEASE (i'm no on 10.1-STABLE r276610 now).

CPU: AMD A8-5600K APU with Radeon(tm) HD Graphics (3593.35-MHz K8-class CPU)

I have added crash dump (core.txt.2) and powerd output from when the utility was started till the point it freezes (powerd.log).


How to reproduce: start powerd utility on AMD system and then let powerd to scale down cpu to minimum and then the pc reboots or hangs.
Comment 1 ditf.robins 2015-01-03 20:19:02 UTC
Created attachment 151301 [details]
powerd log
Comment 2 Philipp Häfelfinger 2017-06-28 05:55:18 UTC
I can reproduce the same behavior but with an intel system. It is reproducable on pfSense 2.4.0 Beta using FreeBSD 11.0-RELEASE-p10.

Hardware:
Asus P9D-E/4L S1150 XEON E3 C224
Intel Xeon E3-1231 v3 3.4GHz/8MB
2x Kingston ValueRAM 8GB (1x8) DDR3-1600 ECC CL11

When I activate powerd (using hiadaptive) the system seems to work as normal. But it will not stay online. After one to a maximum of four hours, the system will do a cold reboot.

As suggested in the pfsense report I tested my hardware and it looks like there is no problem with that.

Link to original post at pfsense: https://redmine.pfsense.org/issues/7641