Bug 196913

Summary: news/nget fails to build with GCC 4.9 (and other modern C++ compilers)
Product: Ports & Packages Reporter: Gerald Pfeifer <gerald>
Component: Individual Port(s)Assignee: freebsd-ports-bugs mailing list <ports-bugs>
Status: Closed FIXED    
Severity: Affects Some People    
Priority: ---    
Version: Latest   
Hardware: Any   
OS: Any   
Bug Depends on:    
Bug Blocks: 196712    

Description Gerald Pfeifer freebsd_committer 2015-01-19 23:55:13 UTC
This really prevents (proper) usage of USE_GCC=yes or clang, for that
matter.


g++49 -O2 -pipe -fstack-protector -Wl,-rpath=/usr/local/lib/gcc49 -fno-strict-aliasing  -Wl,-rpath=/usr/local/lib/gcc49 -Wall -MMD -MP -DHAVE_CONFIG_H -Iuulib   -c -o etree.o etree.cc
In file included from /usr/local/lib/gcc49/include/c++/backward/hash_map:60:0,
                 from _hash_map.h:28,
                 from cache.h:28,
                 from etree.cc:20:
/usr/local/lib/gcc49/include/c++/backward/backward_warning.h:32:2: warning: #warning This file includes at least one deprecated or antiquated header which may be removed without further notice at a future date. Please use a non-deprecated interface with equivalent functionality instead. For a listing of replacement headers and interfaces, consult the file backward_warning.h. To disable this warning use -Wno-deprecated. [-Wcpp]
 #warning \
  ^
etree.cc: In instantiation of 'pred<ClassType>* comparison(const string&, getterT, T2) [with ClassType = const c_nntp_file; getterT = long unsigned int (c_nntp_file::*)() const; T2 = long unsigned int; std::string = std::basic_string<char>]':
etree.cc:200:81:   required from here
etree.cc:87:80: error: no matching function for call to 'new_comparison(long unsigned int (c_nntp_file::*&)() const, long unsigned int&)'
  if      (opstr.compare("==")==0) return new_comparison<Op_eq,ClassType>(get, v);
Comment 1 commit-hook freebsd_committer 2015-01-19 23:59:01 UTC
A commit references this bug:

Author: gerald
Date: Mon Jan 19 23:58:40 UTC 2015
New revision: 377489
URL: https://svnweb.freebsd.org/changeset/ports/377489

Log:
  USE_GCC=any was a lie, nail down to GCC 4.8 as the latest version
  that will build this on FreeBSD 10 and later (without GCC). [1]

  On the way remove an instance of @dirrm from pkg-plist.

  PR:		196913 [1], 196712 [1]

Changes:
  head/news/nget/Makefile
  head/news/nget/pkg-plist
Comment 2 Mark Linimon freebsd_committer freebsd_triage 2015-03-01 15:59:33 UTC
Commited as 377489.