Bug 197928

Summary: [Maintainer] graphics/qgis: update to 2.8.0
Product: Ports & Packages Reporter: Rainer Hurling <rhurlin>
Component: Individual Port(s)Assignee: freebsd-ports-bugs mailing list <ports-bugs>
Status: Closed FIXED    
Severity: Affects Some People CC: rhurlin, wen
Priority: ---    
Version: Latest   
Hardware: Any   
OS: Any   
Attachments:
Description Flags
patch to update graphics/qgis to 2.8.0
none
Poudriere log: HEAD amd64, all options enabled
none
Poudriere log: HEAD amd64, all options disabled
none
Poudriere log: 93amd64, default options enabled
none
Poudriere log: 84i386, default options enabled
none
Update QGIS from 2.6.1 to 2.8.1 none

Description Rainer Hurling 2015-02-22 18:52:22 UTC
Created attachment 153327 [details]
patch to update graphics/qgis to 2.8.0

What this patch for graphics/qgis brings
- update from 2.6.1 to 2.8.0
- correct some plist options


New features for this minor QGIS version (from NEWS file):
- QGIS 2.8 as basis for a long term release (1 year).
- >1000 issues which were flagged by static analysis tools have been fixed.
- More responsive QGIS Browser thanks to multithreading support.
- Support for contextual WMS legend graphics.
- Custom prefixes for joins.
- Creation of memory layers is now a core feature.
- New field calculator bar in attribute table.
- DXF export improvements.
- Advanced digitizing tools.
- Improved snapping options and behaviour.
- Better simplify tool - support for on the fly reprojection enabled.
- Qt5 support (optional, not yet in FreeBSD).
- Spatial bookmark import/export.
- Composer user interface improvements.
- Grid overlay improvements for composer maps.
- Raster image fill type.
- Live heatmap renderer.
- Multiple styles per layer.
- Rotation of map canvas (disabled by default).
- Improved user interface for data defined symbology.
- New algorithms in processing.
- Expressions extendable with custom python functions.
- Comments now supported in expressions.
- QGIS server improvements.


--------------------------
Tested on Poudriere with HEADam64 (all options enabled and disabled), 93amd64 (default options) and 84i386 (default options).


--------------------------
'portlint -AC' gives:
WARN: /usr/ports/graphics/qgis/pkg-plist: [547]: enumerating info files in the plist is deprecated in favor of adding info files into the Makefile using the INFO macro.
WARN: Makefile: for new port, make $FreeBSD$ tag in comment section empty, to make SVN happy.
0 fatal errors and 2 warnings found.

The first warning is obsolet as always for QGIS, because that isn't an info file, but a Grass GIS command.
Comment 1 Rainer Hurling 2015-02-22 18:54:49 UTC
Created attachment 153328 [details]
Poudriere log: HEAD amd64, all options enabled
Comment 2 Rainer Hurling 2015-02-22 18:55:54 UTC
Created attachment 153329 [details]
Poudriere log: HEAD amd64, all options disabled
Comment 3 Rainer Hurling 2015-02-22 18:56:57 UTC
Created attachment 153330 [details]
Poudriere log: 93amd64, default options enabled
Comment 4 Rainer Hurling 2015-02-22 18:57:37 UTC
Created attachment 153331 [details]
Poudriere log: 84i386, default options enabled
Comment 5 Wen Heping freebsd_committer 2015-02-28 04:53:30 UTC
Hi,

   Upstream release 2.8.1 yesterday, would you reproduce the patch ?
   Thank you !

wen
Comment 6 Rainer Hurling 2015-02-28 10:12:12 UTC
Created attachment 153610 [details]
Update QGIS from 2.6.1 to 2.8.1

This patch should replace to one updating to 2.8.0. Thanks to wen@ for pointing out the 2.8.1 release.

The 2.8.0 release had a problem with its field calculator output.

-------
In case of commit, please take from the feature list in my initial comment above.


Again tested with Poudriere, with same results.

Also, portlint -AC gives same results as for 2.8.0. For a comment on them, please see above.
Comment 7 commit-hook freebsd_committer 2015-02-28 23:43:06 UTC
A commit references this bug:

Author: wen
Date: Sat Feb 28 23:42:19 UTC 2015
New revision: 380166
URL: https://svnweb.freebsd.org/changeset/ports/380166

Log:
  - Update to 2.8.1

  PR:		197928
  Submitted by:	Rainer Hurling<rhurlin@gwdg.de> (maintainer)

Changes:
  head/graphics/qgis/Makefile
  head/graphics/qgis/distinfo
  head/graphics/qgis/pkg-plist