Bug 198621

Summary: x11-wm/enlightenment 0.19.4 screenlock does not unlock.
Product: Ports & Packages Reporter: mzs_47
Component: Individual Port(s)Assignee: freebsd-enlightenment mailing list <enlightenment>
Status: New ---    
Severity: Affects Some People CC: enlightenment, freebsd, gblach, w.schwarzenfeld
Priority: --- Flags: bugzilla: maintainer-feedback? (enlightenment)
Version: Latest   
Hardware: amd64   
OS: Any   

Description mzs_47 2015-03-16 10:02:49 UTC
Hello,

I installed  enlightenment using pkg.
It works, but after locking the screen using screenlock from e19, I am unable to unlock it. To get back to the desktop I either have to stop the display manager or reset the machine.

Following are the details of OS and packages-

[..]
> uname -a
FreeBSD freebsd10_64 10.1-RELEASE FreeBSD 10.1-RELEASE #0 r274401: Tue Nov 11 21:02:49 UTC 2014     root@releng1.nyi.freebsd.org:/usr/obj/usr/src/sys/GENERIC  amd64
[..]

[..]
> pkg info enlightenment
enlightenment-0.19.4,2
Name           : enlightenment
Version        : 0.19.4,2
Installed on   : Sun Mar 15 00:30:20 IST 2015
Origin         : x11-wm/enlightenment
Architecture   : freebsd:10:x86:64
Prefix         : /usr/local
Categories     : x11-wm enlightenment
[..]

It loads after trying more than once using x11/slim.

[..]
> pkg info slim
slim-1.3.6_8
Name           : slim
Version        : 1.3.6_8
Installed on   : Mon Mar  9 12:50:36 IST 2015
Origin         : x11/slim
Architecture   : freebsd:10:x86:64
Prefix         : /usr/local
Categories     : x11
[..]
Comment 1 Anonymous 2015-04-16 23:26:29 UTC
I beleive this is due to enlightenment and friends not having the suid bit, which I have fought long and hard to make this default as this just makes E rather useless out of the box. I will look into it and reply here when I have something to work on.
Comment 2 mzs_47 2015-04-18 09:52:35 UTC
Thank you. Without this I am unable to use enlightenment. As it is necessary to lock my PC when I am at work.
Comment 3 w.schwarzenfeld freebsd_triage 2018-01-12 11:44:41 UTC
We have version 0.21.10. I think it is overcome by events.
Comment 4 w.schwarzenfeld freebsd_triage 2018-01-12 11:45:17 UTC
Respective: Is there a similar problem on the recent version.
Comment 5 mzs_47 2018-01-13 11:43:31 UTC
Yes, the last time(some weeks back) I tried it still had the same issue, I worked around by using PIN feature in the recent version of E.

If you think it makes sense to open a new bug for the new version, then please close this.