Bug 199104

Summary: boot(8) build broken
Product: Base System Reporter: heas
Component: kernAssignee: freebsd-bugs (Nobody) <bugs>
Status: Closed Overcome By Events    
Severity: Affects Only Me CC: kevans
Priority: ---    
Version: 10.1-RELEASE   
Hardware: Any   
OS: Any   

Description heas 2015-04-01 23:02:49 UTC
Building a custom boot(8) as in 26.6.3. Setting a Faster Serial Port Speed of https://www.freebsd.org/doc/handbook/serialconsole-setup.html fails with svn://svn0.us-west.freebsd.org/base/release/10.1.0 r280970:

# cd /sys/boot;make -j 8
Warning: Object directory not changed from original /src/10.1.0/sys/boot
    ....
building shared library userboot.so
cc: error: no such file or directory: '/src/10.1.0/sys/boot/userboot/userboot/../zfs/libzfsboot.a'
*** [userboot.so] Error code 1

make[2]: stopped in /src/10.1.0/sys/boot/userboot/userboot
1 error
# make -C userboot/zfs libzfsboot.a
`libzfsboot.a' is up to date.

using symlink to libzfsboot:
===> userboot/userboot (all)
Warning: Object directory not changed from original /src/10.1.0/sys/boot/userboot/userboot
building shared library userboot.so
/usr/bin/ld: i386 architecture of input file `/src/10.1.0/sys/boot/userboot/userboot/../zfs/libzfsboot.a(zfs.o)' is incompatible with i386:x86-64 output
/usr/bin/ld: warning: creating a DT_TEXTREL in a shared object.
cc: error: unable to execute command: Segmentation fault (core dumped)
cc: error: linker command failed due to signal (use -v to see invocation)
*** Error code 254
Comment 1 Kyle Evans freebsd_committer 2021-10-02 04:12:13 UTC
The standalone build has been 100% overhauled since this PR was made; I'm closing it as OBE, but please do reopen it if it still reproduces.