Bug 199878

Summary: [PATCH] lang/ocaml: configure broken with certain compiler options
Product: Ports & Packages Reporter: Guido Falsi <madpilot>
Component: Individual Port(s)Assignee: Guido Falsi <madpilot>
Status: Closed DUPLICATE    
Severity: Affects Some People Keywords: patch
Priority: ---    
Version: Latest   
Hardware: Any   
OS: Any   
Attachments:
Description Flags
patch madpilot: maintainer-approval? (michipili)

Description Guido Falsi freebsd_committer 2015-05-03 09:26:26 UTC
Created attachment 156267 [details]
patch

Hi,

After the last update lang/ocaml fails to configure with the following error when any compiler option includes a "=":

===>  Configuring for ocaml-4.02.1
[ERROR!]Arguments to this script look like '-prefix /foo/bar', not '-prefix=/foo/bar' (note the '=').


The regexp performing this check in the configure script is really too generic and triggers also for perfectly legitimate compiler options like "-march=xxx".

Attached patch comments out this check. I don't think it's really needed in the port. Creating a correct check allowing the = symbol between quotes looks too difficult for too little advantage.

Can you approve this change?

BTW the update also has another problem. The caml4p parts were removed in this new release, but some other ports did depend on them. I'm creating a port for caml4p from here:

https://github.com/ocaml/camlp4

Was this checked before performing the update?
Comment 1 Guido Falsi freebsd_committer 2015-05-03 09:31:56 UTC
*** Bug 199879 has been marked as a duplicate of this bug. ***
Comment 2 Guido Falsi freebsd_committer 2015-05-03 12:16:11 UTC

*** This bug has been marked as a duplicate of bug 199884 ***